Вход | Регистрация

1С:Предприятие ::

Метки: 

Проверка значения реквизита формы

Я
   falselight
 
08.12.17 - 09:50
НА

ВладелецФормы.Родитель.ВладелецФормы.Объект

пишет, поле объекта не обнаружено (Объект)

Все это идет в проверке условия

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    Если ВладелецФормы <> Неопределено И ТипЗнч(ВладелецФормы) = Тип("ТаблицаФормы") И ТипЗнч(ВладелецФормы.Родитель) = Тип("УправляемаяФорма") 
        И ВладелецФормы.Родитель.ВладелецФормы <> Неопределено
        И (ТипЗнч(ВладелецФормы.Родитель.ВладелецФормы.Объект.Ссылка) = Тип("СправочникСсылка.ФизическиеЛица") 
        ИЛИ ТипЗнч(ВладелецФормы.Родитель.ВладелецФормы.Объект.Ссылка) = Тип("СправочникСсылка.Контрагенты")
        ИЛИ ТипЗнч(ВладелецФормы.Родитель.ВладелецФормы.Объект.Ссылка) = Тип("СправочникСсылка.Пользователи")) Тогда
        
        Элементы.ВладелецКарты.ТолькоПросмотр = Истина;
    КонецЕсли;



Как правильно проверить что этого реквизита вообще не существует? Что бы не шла ошибка при попытки открытия и редактирования справочника из документа

ВладелецФормы.Родитель.ВладелецФормы.Объект
 
 
   butterbean
 
1 - 08.12.17 - 09:59
Сделай параметр типа Булево у этой формы, в него передавай нужное условие, и только его проверяй при созданииНаСервере
   falselight
 
2 - 08.12.17 - 10:02
Можно как то определить что на этом

ВладелецФормы.Родитель.ВладелецФормы.Объект
уже ошибка, - поле объекта не обнаружено (Объект)

и все, прерывать дальнейшую обработку, что бы не было ошибки  ?
   falselight
 
3 - 08.12.17 - 10:02
Попытка ?
   igorPetrov
 
4 - 08.12.17 - 10:05
(3) Может научишься думать и читать? Или хоть что-то одно?
   hhhh
 
5 - 08.12.17 - 10:06
(2) ВладелецФормы.Родитель  что такое Родитель у вас? мы же не знаем что вы зафигачили в это поле?
   falselight
 
6 - 08.12.17 - 10:10
(5) ВладелецФормы.Родитель - управляемая форма
   falselight
 
7 - 08.12.17 - 10:14
Суть такая, когда открывают справочник и редактируют элемент из формы списка он не заходит в условие (0).
А когда открывают форму списка справочника из документа, и пытаются редактировать элемент справочника, вот там ошибка.
   falselight
 
8 - 08.12.17 - 10:24
Я обошел это вот так. На сколько это правильно?

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    Если ВладелецФормы <> Неопределено И ТипЗнч(ВладелецФормы) = Тип("ТаблицаФормы") И ТипЗнч(ВладелецФормы.Родитель) = Тип("УправляемаяФорма") 
        И ВладелецФормы.Родитель.ВладелецФормы <> Неопределено
        // ->

        И ВладелецФормы.Родитель.ВладелецФормы.Имя <> "ДисконтнаяКарта"
        // <-

        И (ТипЗнч(ВладелецФормы.Родитель.ВладелецФормы.Объект.Ссылка) = Тип("СправочникСсылка.ФизическиеЛица") 
        ИЛИ ТипЗнч(ВладелецФормы.Родитель.ВладелецФормы.Объект.Ссылка) = Тип("СправочникСсылка.Контрагенты")
        ИЛИ ТипЗнч(ВладелецФормы.Родитель.ВладелецФормы.Объект.Ссылка) = Тип("СправочникСсылка.Пользователи")) Тогда
        
        Элементы.ВладелецКарты.ТолькоПросмотр = Истина;
    КонецЕсли;
    
    ПриИзмененииВладельцаКарты(Ложь);
    Модифицированность = Ложь;
            
КонецПроцедуры
   hhhh
 
9 - 08.12.17 - 10:36
(8) ну весь этот код - полное дерьмо. Поэтому давай не будем разбираться, какое дерьмо правильное, а какое неправильное. Ну обошел и обошел, значит, всё хорошо, двигайся дальше.
   3achem
 
10 - 08.12.17 - 10:36
(8) Познакомь нас со своим работодателем, я хочу посмотреть в глаза этому человеку
 
  Рекламное место пустует
   Lexey_
 
11 - 08.12.17 - 10:39
(10) Ливингстар фрилансит
   igorPetrov
 
12 - 08.12.17 - 10:43
(11) Жесть какая-то
   vicof
 
13 - 08.12.17 - 10:55
(11) Потому что на постоянку его никто не берет :)
   Lexey_
 
14 - 08.12.17 - 10:57
он пытался на постоянку, но: "Я отказался от задачи, может забудем?
Мне условия не подошли. И бух упреками валит, я её слышу второй день. Такие шлются молча."
УНФ, неверная себестоимость при закрытии месяца
   vicof
 
15 - 08.12.17 - 11:05
(14) Ага, я помню :)) Работодатель понял, что чувак явно невменяемый, и послал его молча)
   igorPetrov
 
16 - 08.12.17 - 11:11
(15) А как он фриланс нашел? )))
   vicof
 
17 - 08.12.17 - 11:14
(16) Вопрос не ко мне. Видимо, очень везучий.
   Lexey_
 
18 - 08.12.17 - 11:18
(16) скорее всего, клиенты постоянно разные
   hhhh
 
19 - 08.12.17 - 11:25
(14) это тоже был фриланс


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует