Вход | Регистрация

1С:Предприятие ::

Метки: 

Динамические команды (вопрос знатокам БСП)

Я
   mikecool
 
06.12.17 - 22:10
Создал форму списка
в модуле менеджера добавил
Процедура ДобавитьКомандыОтчетов(КомандыОтчетов) Экспорт

    ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуСтруктураПодчиненности(КомандыОтчетов);
    ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуДвиженияДокумента(КомандыОтчетов);

на форму, по аналогии с типовой формой, закинул группы подменю команд

в форме 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    // ВводНаОсновании

    ВводНаОсновании.ПриСозданииНаСервере(ЭтотОбъект, Элементы.ПодменюСоздатьНаОсновании);
    // Конец ВводНаОсновании


    // МенюОтчеты

    МенюОтчеты.ПриСозданииНаСервере(ЭтотОбъект, Элементы.ПодменюОтчеты);
    // Конец МенюОтчеты


КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуОтчет(Команда)
    
    МенюОтчетыКлиент.ВыполнитьПодключаемуюКомандуОтчет(Команда, ЭтаФорма, Элементы.Список);
    
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуСоздатьНаОсновании(Команда)
    
    ВводНаОснованииКлиент.ВыполнитьПодключаемуюКомандуСоздатьНаОсновании(Команда, ЭтаФорма, Элементы.Список);
    
КонецПроцедуры

но команды в режиме предприятия не появляются
модули добавления отрабатывают, и как я понимаю - не подхватывается обработчик команды(в этом случае команда и не добавляется на форму)
однако - обработчики я описал в форме
где я что мог забыть?
 
 
   NuclearWinter
 
1 - 07.12.17 - 02:20
Добавить в общие - Определяемые типы - ОбъектСДополнительнымиКомандами ?
   toypaul
 
2 - 07.12.17 - 08:24
Более правильный метод (для поддержки):

модуль ВариантыОтчетовПереопределяемый

процедура ПередДобавлениемКомандОтчетов

ДокументыСОтчетомОДвижениях.Добавить(Метаданные.Документы._ДемоРеализацияТоваров);
    Отчеты.ДвиженияДокумента.ДобавитьКомандуОтчетОДвиженияхДокумента(КомандыОтчетов, Параметры,     ДокументыСОтчетомОДвижениях);
   toypaul
 
3 - 07.12.17 - 08:26
"модули добавления отрабатывают" какие модули отрабатывают?

если ты про ПриСозданииНаСервере, то для ввода на основании мало добавить эти вызовы для типовых типа УТ БП30. нужно еще в модуле менеджера добавлять
   toypaul
 
4 - 07.12.17 - 08:27
для структуры подчиненности также есть модуль СтруктураПодчиненностиПереопределяемый
   mikecool
 
5 - 08.12.17 - 23:48
(2) Это, как я понимаю, для подключаемых отчетов, я же пытаюсь встроенные использовать
(3) да, в присоздании создается ТЗ с командами по списку из модуля менеджера, но - ни одна из добавленных на форме не отражается
   mikecool
 
6 - 08.12.17 - 23:49
прошелся поиском по другим формам списка - все однотипно, вроде бы
как будто действительно - где то прописаны формы, для которых добавление возможно
однако - для форм документов такой метод прокатил(скопировал методы обработчиков, допилил модуль менеджера и все)
   mikecool
 
7 - 10.12.17 - 00:43
сравнил выгруженные в тексты документы - разницы в описании и добавлении команд нет, куда теперь смотреть - не представляю...
   Сергиус
 
8 - 10.12.17 - 03:23
(0)Общие команды - Структура подчиненности - свойства(ПКМ). Посмотри Тип параметра команды, там по идее надо добавить ссылку на твой док.
   Сергиус
 
9 - 10.12.17 - 03:25
+(8) Тоже самое для ПоказатьДвиженияДокумента


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует