Вход | Регистрация

1С:Предприятие ::

Метки: 

Выборка из Таблицы Значений

Я
   Cоляпсус
 
06.12.17 - 17:37
Здравствуйте, застрял на простом месте, помогите пожалуйста сдвинуться с него
Есть ТЗ состоящее из к примеру 200 строк, мне необходимо чтобы в новой ТЗ их осталось только 100 (первых), лишние нужно удалить или выбрать первые 100 (любой из вариантов, лучше менее рерурсоёмкий).
Из исходной ТЗ я скопировал ТЗ1, количество строк количеством() тоже понятно, но вот цикл со счётчиком завалил, наверное попробовал все варианты, кроме правильного и рабочего.
Не сочтите за труд, спасибо))
 
 
   Numerus Mikhail
 
1 - 06.12.17 - 17:39
Показывай, какие варианты пробовал, что не получилось?
   Cоляпсус
 
2 - 06.12.17 - 17:42
Ну как же эти варианты показать, я конечно всё позатёр, пробуя писать.
вот последний 
     Данные1 = Новый ТаблицаЗначений;    
     Данные1 = Данные.Скопировать(); 
     
        Сч = 0;
    Пока Сч < Данные1.Количество()-1 Цикл
        СтрТаб = Данные1.Получить(Сч);
        Если Сч >= 100 Тогда
            Данные1.Удалить(СтрТаб);
        Иначе
            Сч = Сч + 1;
        КонецЕсли;
    КонецЦикла;
Понимаю, что ошибка но не могу понять где
   Петрович 2018
 
3 - 06.12.17 - 17:43
Для Индекс = 0 По 99 Цикл
  НоваяСтрока = ВтораяТвблица.Добавить;
  ЗаполнитьЗначенияСвойств(НоваяСтрока, ПерваяТаблица[Индекс]);
КонецЦикла
   X Leshiy
 
4 - 06.12.17 - 17:56
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ ПЕРВЫЕ 100
        |    МояТЗ.Колонка1 КАК Колонка1,
        |    МояТЗ.Колонка2 КАК Колонка2
        |ИЗ
        |    &МояТЗ КАК МояТЗ";
    
    Запрос.Параметры.Вставить("МояТЗ", МояТЗ);
    ТЗ100 = Запрос.Выполнить().Выгрузить();
   azernot
 
5 - 06.12.17 - 17:59
МассивСтрок = Новый Массив();

Для Индекс = 0 По 99 Цикл
  МассивСтрок.Доабвить(ПерваяТаблица[Индекс]);
КонецЦикла;

ВтораяТаблица = ПерваяТаблица.Скопировать(МассивСтрок);
   Numerus Mikhail
 
6 - 06.12.17 - 18:03
(4) Уверен что выберутся первые записи из тз? Есть вероятность, что могут перемешаться записи
   Cоляпсус
 
7 - 06.12.17 - 18:05
(6) Не уверен конечно, но сейчас попробую всё.
   Cоляпсус
 
8 - 06.12.17 - 18:05
Спасибо Вам Добрые Люди за простейшие подсказки, но они очень в тему ))))))
   Cоляпсус
 
9 - 06.12.17 - 18:07
(5) Вот запросом с внешней ТЗ только видел в теории, хотя запросом всё время хотелось попробовать. )))) Возьму на вооружение))
   Cоляпсус
 
10 - 06.12.17 - 18:08
(4) Ваш запрос))
 
 Рекламное место пустует
   Cоляпсус
 
11 - 06.12.17 - 18:08
Другими методами тоже попробую, чтобы продолжать  "Век живи, век учись")))
   X Leshiy
 
12 - 06.12.17 - 18:12
(6) С какого перепугу, если упорядочивание не указано?
   Numerus Mikhail
 
13 - 06.12.17 - 18:15
(12) В этом и смысл, что упорядочивание не указано и скуль может тащить данные в любом порядке
   X Leshiy
 
14 - 06.12.17 - 18:18
(13) Еще чего. А номер строки тз на что?
   X Leshiy
 
15 - 06.12.17 - 18:19
(13) Ты индекс строки видишь? А он —есть. Почти (с)


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует