Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как заполнить счета учета из обработки заполнения ТЧ

Как заполнить счета учета из обработки заполнения ТЧ
Я
   romanryt
 
06.12.17 - 17:22
Народ, помогите, что-то уперся в такую штуку: в бухгалтерии 3 сделал внешнюю обработку заполнения ТЧ для Поступления товаров и услуг, как правильно из этой обработку вызвать процедуру заполнения счетов учета?

вот мой код
&НаКлиенте
Процедура Заполнить(Команда)
    
    МассивСтрок=Новый Массив;
    
    ВладелецФормы.Объект.Товары.Очистить();
    м=ПолучитьДанныеПоСМР(НачалоПериода,КонецПериода,Организация,Автомобиль,Водитель,МестоНазначения);
    Для Каждого строкаДанных Из м Цикл 
        стрДокумента = ВладелецФормы.Объект.Товары.Добавить();
        стрДокумента.Номенклатура = строкаДанных.Номенклатура;
        стрДокумента.Количество = строкаДанных.КоличествоПриРазгрузке;
        стрДокумента.КоличествоМест = строкаДанных.КоличествоПриРазгрузке;
        стрДокумента.ЕдиницаИзмерения = строкаДанных.ЕдиницаИзмерения;
        стрДокумента.Коэффициент = 1;
        стрДокумента.СтавкаНДС = строкаДанных.СтавкаНДС;
        стрДокумента.СтранаПроисхождения = строкаДанных.СтранаПроисхождения;
        стрДокумента.ОтражениеВУСН    = ПоступлениеТоваровУслугФормыКлиентСервер.ОтражениеВУСН(ВладелецФормы.Объект.ВидОперации, Ложь);
        
    КонецЦикла;
    ЗаполнитьСчетаУчета(ВладелецФормы.Объект,МассивСтрок);
    ЭтаФорма.Закрыть();
КонецПроцедуры

&НаСервере 
Процедура ЗаполнитьСчетаУчета(Объект,МассивСтрок)
    СчетаУчетаВДокументах.ЗаполнитьСтроки(МассивСтрок, "Товары", Объект, Документы.ПоступлениеТоваровУслуг);
КонецПроцедуры


 
 
   nordbox
 
1 - 06.12.17 - 17:33
ну так а настройки счетов сделал?
   Ц_У
 
2 - 06.12.17 - 17:36
массивстрок и чо?
   romanryt
 
3 - 06.12.17 - 17:53
(1) сделал
(2) ни чо

ругается 1с
{ВнешняяОбработка.ЗаполнениеПоступленияПоСМР.Форма.Форма.Форма(32)}: Ошибка при установке значения атрибута контекста (Объект)
    ЗаполнитьСчетаУчета(ВладелецФормы.Объект,МассивСтрок);
по причине:
Нельзя изменять поле, содержащее объект данных формы

   nordbox
 
4 - 06.12.17 - 17:58
// Заполняет все счета в строке документа.

// Предназначена для контекстных вызовов из формы документа при подборе и других массовых добавлениях строк.
//

// Параметры:
//  Строки                 - Массив, ТабличнаяЧасть - коллекция заполняемых строк

//  ИмяТабличнойЧасти    - Строка - Имя табличной части
//  Контекст             - Структура - содержит данные шапки заполняемого документа, необходимые для заполнения

//  МенеджерОбъекта         - ДокументМенеджер - менеджер заполняемого документа. Должен соответствовать требованиям, описанным в ЗаполнениеВнеФормы
//  ВключаяЗаполненные     - Булево - следует ли обновлять (приводить в соответствие другим данным) значения уже заполненных реквизитов
   nordbox
 
5 - 06.12.17 - 18:01
ТЫ владельца формы зачем пытаешься заполнить, не форму?
   Ц_У
 
6 - 06.12.17 - 18:38
(3) вижу что "ни чо" потому и спрашиваю, или ты смотришь в книгу, а видишь фигу?
   romanryt
 
7 - 06.12.17 - 19:47
(5) хорош отвечать вопросом на вопрос, если знаешь как решить проблему - напиши
   Chameleon1980
 
8 - 06.12.17 - 19:55
(7) кыш с неуважением

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует