Вход | Регистрация


1С:Предприятие ::

Метки: 

УТ 10.3 печать чека без НДС

Я
   Grekos2
 
06.12.17 - 12:55
Как напечатать чек без НДС ?
  На всякий случай касса = АТОЛ 22Ф / FPrint-22ПТК

  Пробовал в настройке налогового учета выставить флаг "организация не является платильщиком НДС" . Не помогло.
 
 
   SeriyP
 
1 - 06.12.17 - 13:16
(0) берется ставка НДС из закладки "Налогообложение"
   Grekos2
 
2 - 06.12.17 - 13:31
(1)  Закладка налогообложение где ?

    В настройках НУ на закладке налогообложение выставил
    "Упрощенная" и "Доходы"
    Все равно чек с НДС
   Grekos2
 
3 - 06.12.17 - 13:40
Можно конечно в номенклатуре выставить ставку "без НДС"
но этот вариант не устраивает
   hhhh
 
4 - 06.12.17 - 14:01
(3) самое основное, чтобы в самом документе чек ккм сумма ндс была равна 0.
   SeriyP
 
5 - 06.12.17 - 14:02
(2) Все там же Учетная политика (налоговый учет). Если я правильно помню, чтобы в чеке был ЕНВД - в закладке галочек быть не должно никаких. В релизах от начала года ставка НДС бралась из номенклатуры.
Вот ответ техподдержки 1С от 01.09.2017 по этому вопросу:
Розничная торговля облагается ЕНВД. Если флаг стоит все документы розничной прордажи (Чек, Отчет о розничных продажах) идут по ЕНВД.  

Варианты:

1) Снять флаг «Розничная торговля облагается ЕНВД» и всю номенклатуру, которая должна продаваться без НДС, занести в регистр «Номенклатура, облагаемая ЕНВД».

2) Флаг не снимать. Создавать Чек ККМ только на товары с ЕНВД, а все продажи с НДС оформлять через Реализацию товаров и услуг, указывая в ней НДС 18%.
   Grekos2
 
6 - 06.12.17 - 14:08
(4) Там вроде нету такого реквизита.
   SeriyP
 
7 - 06.12.17 - 14:22
В модуле ЧекККМ в процедуре ПодготовитьДанныеДляФискализацииЧека посмотрите на строчку СтрокаЧека.СтавкаНДС = МенеджерОборудованияКлиентСервер.ПолучитьСтавкуНДСДляФискализацииЧека
            (СтрокаТовара.Номенклатура.СтавкаНДС, ПорядокНалогообложения) и далее.
   hhhh
 
8 - 06.12.17 - 14:23
(6) а, да, не заметил, у меня ут11
   Grekos2
 
9 - 06.12.17 - 15:16
(7) Уже смотрю, но как то стремно править :)
   SeriyP
 
10 - 06.12.17 - 15:24
(9) Если в ЧекККМ нужно исключительно ЕНВД - попробуй СтрокаЧека.СтавкаНДС = ""
 
 Рекламное место пустует
   Grekos2
 
11 - 06.12.17 - 15:27
(10)  Я очень плохо в бухгалтерии разбираюсь. Но говорят , что у нас не ЕНВД, УСН Доход.
      У нас Идивидуальный предприниматель и у него УСН Доход.
   SeriyP
 
12 - 06.12.17 - 15:32
(11) Все равно СтрокаЧека.СтавкаНДС = "". Там наверное вам нужно в драйвере кассы и в ТО 1С настроить соответственно таблицу Налоги (не знаю как это у атолов делается) типа
18 - ОСН
0 - Без НДС
   SeriyP
 
13 - 06.12.17 - 15:37
а из ПКО, РКО, ООППК чеки бьете? Там тоже интересно с НДС. У нас чуть-чуть дописано на эту тему 
ОбщиеПараметры.СистемаНалогообложения =  
в процедуре МенеджерОборудованияВызовСервера.ПодготовитьДанныеДляФискализацииЧека
   Grekos2
 
14 - 06.12.17 - 15:59
(13) У нас сначала чек, а потом РКО и ПКО. :)
   Grekos2
 
15 - 06.12.17 - 15:59
Мен = РегистрыСведений.УчетнаяПолитикаНалоговыйУчет.СоздатьМенеджерЗаписи();
        Мен.Организация=ЭтотОбъект.Организация;
        Мен.Прочитать();
        Если Мен.Выбран() Тогда
            Если Мен.ОрганизацияНеЯвляетсяПлательщикомНДС Тогда
                СтрокаЧека.СтавкаНДС = ""; 
            КонецЕсли;    
        КонецЕсли;
   Grekos2
 
16 - 06.12.17 - 15:59
Вот оно "суперрешение"
   isa2net
 
17 - 06.12.17 - 16:25
(16) Не такой ставки "". Пишите тогда "Без НДС".
   SeriyP
 
18 - 06.12.17 - 17:49
(17) В оригинале так вычисляется 
СтрокаЧека.СтавкаНДС = МенеджерОборудованияКлиентСервер.ПолучитьСтавкуНДСДляФискализацииЧека(СтрокаТовара.Номенклатура.СтавкаНДС, ПорядокНалогообложения)
 
Функция ПолучитьСтавкуНДСДляФискализацииЧека(СтавкаНДС, ПорядокНалогообложения = "") Экспорт
    
    Если СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.БезНДС") 
        ИЛИ СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.ПустаяСсылка")
        ИЛИ ВРег(ПорядокНалогообложения) = "ЕНВД" Тогда
        Результат = "";
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС10") Тогда
        Результат = 10;
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС18") Тогда
        Результат = 18;
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС10_110") Тогда
        Результат = 110;
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС18_118") Тогда
        Результат = 118;
    КонецЕсли;
        
    Возврат Результат;
    
КонецФункции
   piter3
 
19 - 06.12.17 - 17:54
"none"
   isa2net
 
20 - 06.12.17 - 18:29
(18) А, посмотрел, там числом процент ставки предается
   Grekos2
 
21 - 15.12.17 - 09:03
Хочу рассказать про один важный момент.
 Случайно затер код в (15)
 Потом восстановил но вместо :
// СтрокаЧека.СтавкаНДС = ""; 


 написал :
 
  СтрокаЧека.СтавкаНДС = 0;
  
  В результате получилось все плохо. Продажа по ставке НДС 0% и в налоговую какой то бред попал.

 Сейчас работаем с версией: 
 СтрокаЧека.СтавкаНДС = "";
 вроде все нормально
   Grekos2
 
22 - 15.12.17 - 09:05
Вот окончательный вариант:
         З = Новый Запрос;
         З.Текст = "ВЫБРАТЬ
                   |    УчетнаяПолитикаНалоговыйУчетСрезПоследних.ОрганизацияНеЯвляетсяПлательщикомНДС
                   |ИЗ
                   |    РегистрСведений.УчетнаяПолитикаНалоговыйУчет.СрезПоследних(, Организация = &Организация) КАК УчетнаяПолитикаНалоговыйУчетСрезПоследних";
        З.УстановитьПараметр("Организация",ЭтотОбъект.Организация);           
        тзРез = З.Выполнить().Выгрузить();    
        Если тзРез.Количество() > 0 Тогда
            Если тзРез[0]["ОрганизацияНеЯвляетсяПлательщикомНДС"] = Истина Тогда
                СтрокаЧека.СтавкаНДС = "";
            КонецЕсли;    
        КонецЕсли;



Список тем форума
Рекламное место пустует Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует