Вход | Регистрация


1С:Предприятие ::

Метки: 

Вывести остаток по строке на форму

Я
   Aldnepr
 
05.12.17 - 14:54
Переходим с 7,7- 8. Очень нужно смотреть оперативные остатки по требуемому складу на форме расходной накладной, так как это реализовано в 7,7. Т.е. при активации строки в многострочной части дока внизу формы прописывался актуальный остаток на складе. Добывалось это просто- Регистр.ОстаткиТоваров.Остаток(), результат записывался в текстовое поле. Как подобное сделать в 8. Мне говорят надо делать запрос к регистру и выводить результаты в доп. колонки в таблице дока. Но это же капец как затормозит работу. Как в 7.7 нереально сделать?
 
  Рекламное место пустует
   nordbox
 
1 - 05.12.17 - 14:56
И в чем у тебя проблема?
   nordbox
 
2 - 05.12.17 - 14:56
(0)>>Переходим с 7,7- 8
с поддержки хочешь снять???
   nordbox
 
3 - 05.12.17 - 15:00
Конфа то хоть какая?
   vicof
 
4 - 05.12.17 - 15:03
(0) Надо понимать, ты уже искал, как это сделать. В гугле миллионы ссылок по твоей проблеме.
   Aldnepr
 
5 - 05.12.17 - 15:05
(3) ут - проблема в том что не получается сделать аналогично 7
   Aldnepr
 
6 - 05.12.17 - 15:07
(4) видел только вявод в табл часть через запрос
   nordbox
 
7 - 05.12.17 - 15:07
Я так понимаю ты уже делал?
что у тебя не получается?
     ЗапросОстатка.Текст = "ВЫБРАТЬ
        |    ТоварыНаСкладах.Номенклатура,
        |    ТоварыНаСкладах.КоличествоОстаток
        |ИЗ
        |    РегистрНакопления.ТоварыНаСкладах.Остатки(&Склад,&Номенклатура) КАК ТоварыНаСкладах
        |
   lodger
 
8 - 05.12.17 - 15:07
(5) аналогично не надо делать, там же парадигмы изменились.
лучше смотрите как это делается в той же самой УТ.
   lodger
 
9 - 05.12.17 - 15:12
оперативно контроль остатков происходит при проведении.
если хочется еще оперативнее - приделайте реквизит формы и заполняйте при открытии или по пинку команды "Контроль остатков".
он-лайн-по-мере-ввода будет тормозить. но так тоже можно сколхозить. однако, зачем?
   Aldnepr
 
10 - 05.12.17 - 15:18
(9) надо чтобы при наборе юзер видел что на таком то складе столько то а на таком столько остатка подобное есть в подборе
но хотелось бы и при простом выборе было видно
 
  Рекламное место пустует
   lodger
 
11 - 05.12.17 - 15:20
(10) научитесь пользоваться формой подбора. это тот же выбор, но с остатками, ценами и прочим блекджеком.
   nordbox
 
12 - 05.12.17 - 15:21
(10) УТ хоть какая?
а подбор чем не устраивает?
   nordbox
 
13 - 05.12.17 - 15:22
(10)
Если УТ 10.3 то там это есть
   lodger
 
14 - 05.12.17 - 15:25
(13) 2018 уже, а вам бы все в 10.3 поковыряться...
   nordbox
 
15 - 05.12.17 - 15:27
(14) У меня некоторых клиентов с 10.3 только дубиной, под автоматом и с одновременной газовой атакой можно выгнать ))
   Aldnepr
 
16 - 05.12.17 - 15:56
(13) Есть в подборе, это сервисный механизм. Мне нужно чтобы показывались остатки по Склад1, Склад2,Склад3.
   Aldnepr
 
17 - 05.12.17 - 17:21
вот нашел такое, как его прикрутить к таблице товары? Нужно создать колонку Остаток, а дальше?
//----------------------------------

----------------------------------------------------------------------
Соответствие = Новый Соответствие;   
    Массив = Новый Массив;
    Для каждого Стр из ОформленияСтрок Цикл
        Массив.Добавить(Стр.ДанныеСтроки.Ссылка);
        Соответствие.Вставить(Стр.ДанныеСтроки.Ссылка, Стр);    
    КонецЦикла;
    
    ЗапросОстатка = Новый Запрос;
    ЗапросОстатка.Текст = "ВЫБРАТЬ
                           |    УчетНоменклатурыОстатки.Номенклатура,
                           |    УчетНоменклатурыОстатки.КоличествоОстаток
                           |ИЗ
                           |    РегистрНакопления.ТоварыВРознице.Остатки(, Номенклатура В (&Номенклатура)) КАК УчетНоменклатурыОстатки";
    ЗапросОстатка.УстановитьПараметр("Номенклатура", Массив);
    
    Выборка = ЗапросОстатка.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        Соответствие.Получить(Выборка.Номенклатура).Ячейки.Остаток.Значение = Выборка.КоличествоОстаток;
    КонецЦикла;

------------------------------------------------------------------------
   nordbox
 
18 - 05.12.17 - 17:28
А с какого склада ты получать будешь?
   nordbox
 
19 - 05.12.17 - 17:30
+18 Ты сам то понял что написано в коде?
   Aldnepr
 
20 - 05.12.17 - 17:32
(18) Запрос.УстановитьПараметр("Склад",Склад);
так думал добавить.
Код не понял. Выложил человек тут v8: УТ 10.3 вывести остаток товара в строку ТабЧасти документа
   Aldnepr
 
21 - 05.12.17 - 17:35
пробовал так:
Функция ОстатокНаСкладе(Номенклатура) Экспорт
ВидСклада = Склад.ВидСклада;
   Если ВидСклада = Перечисления.ВидыСкладов.Оптовый Тогда
   Текст = "ВЫБРАТЬ
           |   ТоварыНаСкладахОстатки.КоличествоОстаток КАК Количество
           |ИЗ
           |   РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, ) КАК ТоварыНаСкладахОстатки
           |ГДЕ
           |   ТоварыНаСкладахОстатки.Склад = &Склад
           |   И ТоварыНаСкладахОстатки.Номенклатура = &Номенклатура";
КонецЕсли;
Запрос = Новый Запрос;
Запрос.Текст = Текст;
Запрос.УстановитьПараметр("Дата",Дата);
Запрос.УстановитьПараметр("Склад",Склад);
Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Количество = ?(Выборка.Следующий(),Выборка.Количество,0);
Возврат Количество;
КонецФункции
//--------------------------------

Процедура ПоказатьОстатокСклада(КолонкиТабПоля, ЯчейкиСтрокиТабПоля, Номенклатура) Экспорт
Если КолонкиТабПоля.ОстатокСклада.Видимость Тогда
      Если ТипЗнч(Номенклатура) = Тип("СправочникСсылка.Номенклатура") Тогда
          Остаток = ОстатокНаСкладе(Номенклатура);
         ЯчейкиСтрокиТабПоля.ОстатокСклада.УстановитьТекст(Остаток);
      Иначе
         ЯчейкиСтрокиТабПоля.ОстатокСклада.УстановитьТекст("");
      КонецЕсли;
КонецЕсли;   
КонецПроцедуры
//------------------------

добавил колонку в таблицу товары с именем ОстатокТовара, данные- пусто. типПоля- вводДанных. Ругается,
//{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(2767)}: Поле объекта не обнаружено (ОстатокСклада)

Если КолонкиТабПоля.ОстатокСклада.Видимость Тогда
   nordbox
 
22 - 05.12.17 - 17:38
ОстатокСклада и ОстатокТовара
разные вещи
   nordbox
 
23 - 05.12.17 - 17:43
Ты добавил колонку ОстатокТовара
а обращаешься к ней как к ОстатокСклада
   Aldnepr
 
24 - 05.12.17 - 17:46
(22) От спасибо!)) Глюканул конечно, подправил- показывает теперь. Но я так понимаю показывать будет именно на тот момент, когда выбираешь позицию в табл.Товары. Вот проверил- такая штука выходит: Выбираю позицию, был остаток 600шт. -показало в нужной мне колонке. Продаю 80 и провожу, а цифра в колонке остатка не меняется.Ввожу новый документ- там уже 520 шт.
   nordbox
 
25 - 05.12.17 - 17:48
(24) Ну правильно, в лет он читать ничего не будет
   nordbox
 
26 - 05.12.17 - 17:51
+25 Ну все остальное это уже полет твоей фантазии, главного ты добился ))



Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует