Вход | Регистрация


1С:Предприятие ::

Метки: 

Выбор документа на форме обработки

Я
   falselight
 
05.12.17 - 10:55
На форме обработки есть реквизит типа РеализацияТоваровУслуг.
Нужно проверить что выбирается не проведенный документ.
Иначе не давать выбрать его.
В процедуре НачалоВыбора в ВыбранноеЗначение
ссылка но она без возможности смотреть её свойства.
В Объект.Реализация так же ссылка но нельзя смотреть её свойства.
Как обратиться то к выбранному значению в реквизите что бы при его выборе изменении проверять проведен ли он?
 
  Рекламное место пустует
   Волшебник
 
Модератор
1 - 05.12.17 - 10:56
Если ВыбранноеЗначение.Проведен Тогда
   Lexey_
 
2 - 05.12.17 - 11:03
(0) на сервере, Ливингстар, на сервере
   falselight
 
3 - 05.12.17 - 11:05
(1) (2) Получается ВыбранноеЗначение не доступно на клиенте????

(1) Пишет поле объекта не обнаружено .Проведен
   Волшебник
 
Модератор
4 - 05.12.17 - 11:05
(3) У меня всё работает.
   vicof
 
5 - 05.12.17 - 11:05
(0) Дарю
Отбор = Новый Структура;
Отбор.Вставить("Проведен", Ложь);

СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("Отбор", Отбор);

ОткрытьФорму();
   Масянька
 
6 - 05.12.17 - 11:07
А мне интересно посмотреть на сие чудо... Ну, то, что пилит автор.
   falselight
 
7 - 05.12.17 - 11:07
(4) Вот так у вас вмодуле формы все работает????

&НаКлиенте
Процедура РеализацияОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    й=1;
КонецПроцедуры


И можно посмотреть ВыбранноеЗначение.Проведен ?
   falselight
 
8 - 05.12.17 - 11:08
(6) Да совершенно ничего особенного. Загрузка с эксель.
Только вот затупилось внезапно (((
   Масянька
 
9 - 05.12.17 - 11:09
(8) Я не про данный конкретный случай... Я - в общем... Так сказать - масштабно...
   Lexey_
 
10 - 05.12.17 - 11:10
(8) почему внезапно?
 
 
   vicof
 
11 - 05.12.17 - 11:10
(8) Больше всего в этой фразе мне нравится слово "внезапно"
   Lexey_
 
12 - 05.12.17 - 11:10
(11) +1
   falselight
 
13 - 05.12.17 - 11:11
Как быть то мне подскажите?
   Lexey_
 
14 - 05.12.17 - 11:11
(13) так уже
   falselight
 
15 - 05.12.17 - 11:11
У меня тут нет свойств ВыбранногоЗначения (7)
   falselight
 
16 - 05.12.17 - 11:13
как поступить в этом элементарном случае????
что бы проверить на проведенность документ?
   Lexey_
 
17 - 05.12.17 - 11:14
(16) тебе. Уже. Ответили
   Масянька
 
18 - 05.12.17 - 11:15
(17) Лучше большими и буквами и по слогам. :)
   falselight
 
19 - 05.12.17 - 11:16
(17) Эти ответы мне не подходят, иначе я применил бы их уже
   vicof
 
20 - 05.12.17 - 11:16
(0) Ты совсем не обращаешь на меня внимания. Я обиделся. Не буду больше помогать.
   vicof
 
21 - 05.12.17 - 11:17
(19) Подходят. Просто ты как бы это помягче сказать...
   falselight
 
22 - 05.12.17 - 11:17
(20) структура, и зачем она?
   falselight
 
23 - 05.12.17 - 11:18
типовая процедура происходит при начале выбора документа
проверить нужнео выбранное значение, но нет у него свойств
куда ваша структура пойдет (5)?
   vicof
 
24 - 05.12.17 - 11:20
(23) Вижу проблески сознания.
Проверяй до выбора.
   Масянька
 
25 - 05.12.17 - 11:22
(24) Ты уж определись: то (20), то (24) :)))))
   falselight
 
26 - 05.12.17 - 11:29
Так обощелся, -

//

&НаСервере
Функция РеализацияПриИзмененииНаСервере(Док)
    Если Док.Проведен Тогда
        Возврат 1;
    КонецЕсли;
Возврат 0;
КонецФункции
//

&НаКлиенте
Процедура РеализацияПриИзменении(Элемент)
    Если РеализацияПриИзмененииНаСервере(Объект.Реализация) Тогда
        Сообщить("Выбрать можно только не проведенную реализацию!");
        Объект.Реализация = неопределено;
    КонецЕсли;
КонецПроцедуры
//
   Lexey_
 
27 - 05.12.17 - 11:45
Функцию РеализацияПриИзмененииНаСервере нужно в учебники по г...коду
   vicof
 
28 - 05.12.17 - 11:46
(26) Убил бы за такой код.
(24) Видел проблески сознания, но после (26) вижу, что опять все сознание затянуто пеленой тупости и нежелания меняться.
   1Садовник
 
29 - 05.12.17 - 12:54
(5) Угу. Пользюк отменит проведение дока (чтобы отбор пропустил) выберет этот док, а затем снова проведет этот док в другом окне. Потом обработает этот док (который уже проведен) в обработке и обвинит во всем прога если что.
   falselight
 
30 - 05.12.17 - 13:21
Ну покажите пожалуйста аналог (26) который можно считать за правильный? Как эталон!
   vicof
 
31 - 05.12.17 - 13:24
(30) В (5)
   МимохожийОднако
 
32 - 05.12.17 - 13:24
(30) см. типовые конфигурации и демо БСП.
"Никогда не было и вдруг опять" ))
   falselight
 
33 - 05.12.17 - 13:31
(32) Ну а что там для этого смотреть я же не знаю.
Можете поконкретнее места обозначить?
Что бы раз по вашему указанию посмотрел и увидел?
 
 
   vicof
 
34 - 05.12.17 - 13:33
   МимохожийОднако
 
35 - 05.12.17 - 14:13
(33) ОФФ:Может быть и пальцы за тебя загибать?



Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует