Вход | Регистрация


Конвертация данных 2, Субконто.Ключ ?

Конвертация данных 2, Субконто.Ключ ?
Я
   spiller26
 
05.12.17 - 09:55
Делаю обмен из БП_3.0 в КА_2.4
ПКО_ОперацияБух_ПослеЗагрузкиОбъекта
Обработка движения, не пойму как сделать условие "Ключа" субконто, при обходе не срабатывает, как условие применить в этом условии?
//

Если Субконто.Ключ = 
ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.БанковскиеСчета Тогда

Вот код:  

СчетБУ_5504 = ПланыСчетов.Хозрасчетный.ПрочиеСпециальныеСчета;//55.04

Для Каждого Корреспонденция Из Объект.Движения.Хозрасчетный Цикл
    //Дт

    Если Корреспонденция.СчетДт = СчетБУ_5504 Тогда
        Для каждого Субконто из Корреспонденция.СубконтоДт Цикл
            Если Субконто.Ключ = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.БанковскиеСчета Тогда
                Сообщить("СчетДт *** " + Субконто.Значение);    
            КонецЕсли;
        КонецЦикла;    
        //    Сообщить("СубконтоДт === " + Субконто.Ключ);

        //    Сообщить("СубконтоДт (значение) === " + Субконто.Значение);

        //КонецЦикла;    

    КонецЕсли;    
    //Кт

    Если Корреспонденция.СчетКт = СчетБУ_5504 Тогда
        //

    КонецЕсли;    
КонецЦикла;
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует