Вход | Регистрация

1С:Предприятие ::

Метки: 

Конвертация данных. Подмена нескольких номенклатура на одну

Я
   Wefast
 
05.12.17 - 09:40
Если список номенклатур которые при выгрузки должны превращаться в одну.

Пробовал в ПКО после выгрузки перебирать табличную часть
Для каждого Т из Объект.Запасы Цикл
Если Т.Номенклатура.Код = "2342343" Тогда
Т.Номенклатура = Справочники.Ном.найтипоКоду("1");
КонецЕсли;

пишет Что Номенклатура не доступна для изменения

Пробовал этот кусок вставлять в ПВД ПослеВыгрузки
Тоже самое.

Как и где правильно это делать?

В ПКО номенклатураа?

Перед обработкой у источника переопределить поля поиска на нужную номенклатуру?
 
 
   Wefast
 
1 - 05.12.17 - 09:41
Или в ПКО номенклатура делать что то вроде
Если Источник.Код = "2323" Тогда
Источник = Справочники.Ном.найтиПоКоду("1");
КонецЕсли;
   Йохохо
 
2 - 05.12.17 - 09:43
(1) так нельзя, в ПКГС Товары ОбъектЗапасы 
Если Т.Номенклатура.Код = "2342343" Тогда
Значение = Справочники.Ном.найтипоКоду("1");
КонецЕсли;
   Сияющий Асинхраль
 
3 - 05.12.17 - 09:47
(0) Сделай отдельное ПКО для таких номенклатур и при выгрузке номенклатур с нужным кодом выбирай это отдельное ИмяПКО...
   azt-yur
 
4 - 05.12.17 - 09:49
Можно так:

В ПКС полей поиска для ПКО номенклатуры пропиши:
Если Источник.Код = "2323" Тогда
 Значение = КодНужнойНоменклатуры;
КонецЕсли;

Это для Кода, для других полей соответствующе.
И галочку для ПКО номенклатуры поставь Не изменять существующие объекты


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует