Вход | Регистрация


Удаление строк тч по заданному условию

↓ [Волшебник, 04.12.17 - 10:55]
Удаление строк тч по заданному условию
Я
   falselight
 
04.12.17 - 10:38
Есть тч. При удалении строки из этой тч нужно удалить строки
из другой тч в которой содержатся строки с данным значением.
Как это правильно сделать в обычном приложении?
Найти строки с этой строкой функцией НайтиСтроки()?
Как правильно потом удалить их?
 
 
   Волшебник
 
Модератор
1 - 04.12.17 - 10:39
методом Удалить() в цикле
   Адинэснег
 
2 - 04.12.17 - 10:47
Для Каждого СТр Из Массив Строк Цицл
 ТЧ.Удалить(СТр);
КонецЦикла;

элемент массива - ссылка на строку, с индексом можешь лохануться если не обратным счетчиком пойдешь
   falselight
 
3 - 04.12.17 - 10:53
верно ли так?

        ПараметрыОтбора = Новый Структура;
        ПараметрыОтбора.Вставить("Магазин", Элемент.ТекущаяСтрока.Магазин);
        НайденныеСтроки = ПП_ТоварыМагазинов.НайтиСтроки(ПараметрыОтбора);
        Для каждого СтрДляУд Из НайденныеСтроки Цикл
            ПП_ТоварыМагазинов.Удалить(ПП_ТоварыМагазинов.Индекс(СтрДляУд));
        КонецЦикла;
   VladZ
 
4 - 04.12.17 - 10:55
(3) можно и так: ПП_ТоварыМагазинов.Удалить(СтрДляУд)
   vde69
 
Модератор
5 - 04.12.17 - 10:55
если это на сервере то верно так


        ПараметрыОтбора = Новый Структура;
        ПараметрыОтбора.Вставить("Магазин", Элемент.ТекущаяСтрока.Магазин);
        НайденныеСтроки = ППТоварыМагазинов.НайтиСтроки(ПараметрыОтбора);
        Для каждого СтрДляУд Из НайденныеСтроки Цикл
            ППТоварыМагазинов.Удалить(СтрДляУд);
        КонецЦикла;
   Волшебник
 
Модератор
6 - 04.12.17 - 10:55
(3) Тебе уже код написали, но ты продолжаешь тупить

ПП_ТоварыМагазинов.Удалить(СтрДляУд)
   falselight
 
7 - 04.12.17 - 11:16
(4,5,6) в процедуру удалить нужно передавать же индекс?!
   dezss
 
8 - 04.12.17 - 11:19
(7) дочитай сп до конца. То, что после запятой, тоже прочитай.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует