Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: Отправка почты из 7.7

Я
   knopik777
 
04.12.17 - 09:20
Друзья, попалась база 7.7 из которой рассылаем счета клиентам.
Организовано все через DialMail.dll
Все работает и отправляет, но хочется видеть отправленные письма в почтовой программе. Не могу найти параметр как их сохранить в почте.
Надеюсь ясно выразился.
Кто пользуется этой длл помогите.
        ОтправкаПочты.РабочийКаталог=КаталогПользователя();
        ОтправкаПочты.ИспользоватьПрокси=0;
        ОтправкаПочты.ИспользоватьSSL=1;
        ОтправкаПочты.ВестиЛогФайл = 1;
        ОтправкаПочты.ИмяЛогФайла = КаталогПользователя()+"dialmail.smtp.log";
        МойАдрес=СокрЛП(тз.Адрес);
        СМТП="smtp.yandex.ru";
        Логин = "____"; 
        Пароль = "____"; 
        ОтправкаПочты.ПочтоваяПрограмма="Client on DialMail";
        ОтправкаПочты.MakeContentDescriptionTag = 0;
        ОтправкаПочты.ТипТелаПисьма=1;  
        ЗаголовокСообщения = "Счёт за ";
        текст  = "Высылаем в Ваш адрес счёт за";
    текписьмо=ОтправкаПочты.СоздатьПисьмо(Логин,МойАдрес,,ЗаголовокСообщения,,текст,ВыбФайл);
        текписьмо=ОтправкаПочты.СоздатьПисьмо(Логин,МойАдрес,,ЗаголовокСообщения,,текст,ВыбФайл);

        Если ОтправкаПочты.Подключиться(СМТП,465,Логин,Пароль,1)=0 тогда
Сообщить("Не смогли подключиться к SMTP-серверу");
ОтправкаПочты.Отключиться();
        КонецЕсли;
        рез=ОтправкаПочты.ОтправитьПисьмо(,1,0);
 
  Рекламное место пустует
   Масянька
 
1 - 04.12.17 - 09:49
(0) Я, лично, не нашла. Найдешь - маякни, пожалуйста.
Обошла: в спец. папку сохраняются файлы с док-ми (т. е. то, что цепляется к письму).
   Builder
 
2 - 04.12.17 - 09:51
Настраивал как то давно так - скрытая копия на свой адрес, там все и сохранялось.
   mishaPH
 
Модератор
3 - 04.12.17 - 09:54
Процедура ИнициализацияПочтовойСистемы() Экспорт
    Если ЕстьКомпонентаПочты = 0 Тогда
        СоздатьСлужебныеКаталоги();
        ЗагрузитьВнешнююКомпоненту(КаталогИБ()+"DialMail.dll");
        ОтправкаПочты= СоздатьОбъект("AddIn.SMTP");
        ПолучениеПочты= СоздатьОбъект("AddIn.POP3");
        SystComm = СоздатьОбъект("AddIn.SystComm");
        ОтправкаПочты.РабочийКаталог=КаталогИБ()+"Auto\mail\out\";
        ПолучениеПочты.РабочийКаталог=КаталогИБ()+"Auto\mail\in\";
        ОтправкаПочты.УстановитьКодировкуИСпособКодирования(22,3);
    КонецЕсли;
КонецПроцедуры// ИнициализацияПочтовойСистемы
   knopik777
 
4 - 04.12.17 - 10:03
(3) Не совсем понимаю что с этим делать
   knopik777
 
5 - 04.12.17 - 10:04
(2) как вариант, хорошая идея
   Остап Сулейманович
 
6 - 04.12.17 - 10:08
(0) "хочется видеть отправленные письма в почтовой программе."
Кто есть "почтовая программа"? Если АутГлюк или ЗеБет - можно отправлять с их помощью. И оно будет сохранять в отправленных само. За громоптицу не скажу, но скорее всего и там возможна автоматизация.
   mishaPH
 
Модератор
7 - 04.12.17 - 10:13
(4) я не дочитал что ты хотел. думал ошибка с отправкой.

а видеть в другой почтовой в виде отправленных - нельзя.
можно только при формировании письма поставить адрес свой в копию и смотреть так
   Chameleon1980
 
8 - 04.12.17 - 10:16
я тоже делал как (2)
и все норм
   Duke1C
 
9 - 04.12.17 - 10:17
(0) Перепиши отправку на V7PLUS.DLL
   Владимир1С
 
10 - 04.12.17 - 10:18
(2) Самый простой и быстрый в реализации механизм. Заодно отследишь, работает отправка как таковая или нет. Отправляю через CDO.
 
  Рекламное место пустует
   Владимир1С
 
11 - 04.12.17 - 10:20
(0) Если не секрет, в какой операционной системе работает 1С-ка?
   knopik777
 
12 - 04.12.17 - 10:24
(11) win 7 x64
   Владимир1С
 
13 - 04.12.17 - 10:30
(12) спасибо за ответ.
   pofigos
 
14 - 04.12.17 - 12:01
(0) У меня объеденены : сохранение  на диск прикрепленного к письму документа + скрытая копия на общий ящик, с которого идет отправка + копия человеку, который отправляет письмо из 1С ( в справочнике сотрудников есть реквизит email)
   mishaPH
 
Модератор
15 - 04.12.17 - 12:02
вообще после создания письма, оно сохраняет в формате msg. потом отправляет. Можно при желании отправить в почтовую систему
   Злопчинский
 
Ведущий
16 - 04.12.17 - 12:05
У меня из одноэса манагеры всякую оперативку рассылают. Отправленные письма складируются в папки , из одноэса можно посмотреть письма отправленные. Глубина хранения 2 недели.
   Злопчинский
 
Ведущий
17 - 04.12.17 - 12:07
Картинки тута есть
http://catalog.mista.ru/public/14131/
   opus70
 
18 - 04.12.17 - 12:14
loConfig = CreateObject("CDO.Configuration");

        loCdoMessage = CreateObject("CDO.Message");
        
        loCdoMessage.Configuration = loConfig;
        loCdoMessage.From    = СокрЛП(ОбрАдр);
        loCdoMessage.To      = СокрЛП(Мыло);
        loCdoMessage.Subject = СокрЛП(ТемаП);
        
        ТекстСообщения = "Текст письма";
        
        HTMLBody = "<html>
        |<head>
        |<meta content=""text/html; charset=Windows-1251"" http-equiv=""content-type"">
        |<title> Тестовое сообщение </title>
        |</head>
        |<body>
        |<h3>" + СокрЛП(ТемаП) + "</h3>
        |<p></p>
        |</body>
        |</html>";
        
        loCdoMessage.BodyPart.Charset = "windows-1251";
        loCdoMessage.HTMLBody = HTMLBody;        
        
        
        _Вложения="";
        
        Если ФС.СуществуетФайл(КаталогИБ()+"mail\"+СокрЛП(НомДок)+".jpg")=1 Тогда
            _Вложения = КаталогИБ()+"mail\"+СокрЛП(НомДок)+".jpg";
        ИначеЕсли ФС.СуществуетФайл(КаталогИБ()+"mail\"+СокрЛП(НомДок)+".png")=1 Тогда     
            _Вложения = КаталогИБ()+"mail\"+СокрЛП(НомДок)+".png";
        ИначеЕсли ФС.СуществуетФайл(КаталогИБ()+"mail\"+СокрЛП(НомДок)+".bmp")=1 Тогда     
            _Вложения = КаталогИБ()+"mail\"+СокрЛП(НомДок)+".bmp";
        КонецЕсли;
                                
        loCdoMessage.AddAttachment(_Вложения);
                                                  
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusing";).            Value = 2;
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserver";).           Value = СокрЛП(СервСМТП);
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserverport";).       Value = СокрЛП(Порт);
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate";).     Value = 1;
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusername";).         Value = СокрЛП(Логин);
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendpassword";).         Value = СокрЛП(Пар);
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpusessl";).           Value = 1;
        loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpconnectiontimeout").Value = 60;

        loConfig.Fields.Update();
        loCdoMessage.Send();        
        
        Сообщить("Отправлен Счет "+ СокрЛП(ВыбСчет.НомерДок)+" от " +Формат(ВыбСчет.ДатаДок,"Д ДДММММГГГГ")+" для "+СокрЛП(ВыбСчет.Контрагент.Наименование)+".");
   opus70
 
19 - 04.12.17 - 12:15
остальное там не все обвязки
   Владимир1С
 
20 - 04.12.17 - 12:52
(19) Вопрос: С CDO , по факту, яндекс сейчас работает? Была непроверенная информация, что вроде как от CDO интернет-почты хотят отказываться. На официальных сайтах ничего внятного не нашёл, к сожалению.
   opus70
 
21 - 04.12.17 - 13:19
(20) это кусок из абсолютно работающей обработки насколько это вообще возможно в нашем мире (отправляю через smtp.mail.ru)
   ADirks
 
22 - 04.12.17 - 13:33
(20) CDO - это кусок винды.
Всякие интернет-почты могут намудрить чего-нибудь с аутентификацией, но от SMTP как-то врядли смогут отказаться.
   opus70
 
23 - 04.12.17 - 13:41
у интернет почты щас один бзик все полюбили ssl, вот и вышла что через публичные smtp только через ssl или через свой почтовик по старинке все пашет без бубнов из 7.7
   Chieftain
 
24 - 04.12.17 - 14:26
(20) Хотят отказаться от SMTP?
(23) Никаких проблем с ssl при отправке из 77 через CDO
   opus70
 
25 - 04.12.17 - 14:32
(24) через  CDO уходит на отлично
loConfig.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpusessl";;).           Value = 1;



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует