Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

8.2 Получить элемент после записи на форме

8.2 Получить элемент после записи на форме
Я
   breezee
 
30.11.17 - 17:00
Добрый день! 8.2 УПП Есть не типовая обработка, в которой есть кнопка. По нажатию кнопки открывается форма элемента номенклатуры. Элемент номенклатуры не создан. Вопрос, можно ли как-то без изменения формы номенклатуры вернуть созданный элемент номенклатуры?
То есть с изменением я бы открывал модально и в Закрыть() передавал бы нужный элемент. Или подключил обработчик оповещения и оповестил о записи элемента. А можно ли как-то без изменения типовой формы это сделать? Обычные формы
 
 
   Fragster
 
1 - 30.11.17 - 17:04
если открыть форму в режиме выбора, то, ЕМНИП, в обработку выбора вернется записанный элемент. ну, или не вернется, если отказались от закрытия. только открывать надо не модально.
   Fragster
 
2 - 30.11.17 - 17:05
хотя может и с модально тоже будет работать
   breezee
 
3 - 30.11.17 - 17:09
(2) Да, для выбора знаю, но мне надо именно на сохдание
   breezee
 
4 - 30.11.17 - 18:13
Последний ап, не выйдет - допишу. Подскажите, также, пожалуйста, Если не использовать на форме свою кнопку, а использовать обработчик ПриЗакрытии() можно что-то вернуть? Пытаюсь передать в параметры, код:
Процедура ПриЗакрытии()
      Параметры.Вставить("2", "2");
КонецПроцедуры
Система ругается что не знает что такое параметры
   Fragster
 
5 - 30.11.17 - 18:17
если использовать обработчик ПриЗакрытии, то нужна переменная-флаг и другой обработчик


Процедура ПередЗакрытием(Отказ,...)
    Если Не ЗначениеЗаполнено(ГлобальнаяПеременнаяФлаг) Тогда
        Отказ = Истина;
        Закрыть("Я не умею пользоваться поиском");
    КонецЕсли;
КонецПроцедуры
   Fragster
 
6 - 30.11.17 - 18:17
забыл 
     ГлобальнаяПеременнаяФлаг = Истина
между установкой отказа и закрытием :)
   breezee
 
7 - 30.11.17 - 18:24
(5) Спасибо, идею понял. Самому прописывать логику закрытия, я просто, хотел без этого обойтись, чуть более "По типовому". Ну раз нельзя - так нельзя) Поиском правда не умею, не знаю, по каким словам такое искать искал в гугле "При закрытии формы передавать параметр 1С" нашел только с формой выбора

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует