Вход | Регистрация


1С:Предприятие ::

Метки: 

Онлайн кассы Штрих версия формата 1.0.5 пробитие кредита, как?

Я
   Cav123
 
30.11.17 - 13:41
Касса по кредиту пробивает как по пластиковой карте. Кредиты бывают таких видов, полный, или с первым взносом, который по идеи может быть но нал. или плат картой. Кто с сталкивался с такой проблемой? как оформлять по коду, с заполнением таблице оплат и позиций чека, по суммам, и признакам предмета расчета?
 
 
   isa2net
 
1 - 30.11.17 - 14:09
(0) Прошивка какая?
   nordbox
 
2 - 30.11.17 - 14:12
(0) не знаю как там у тебя, но это Виды оплаты рулят
   Cav123
 
3 - 30.11.17 - 14:21
Сборка ПО: 43342
 Дата ПО : 05.10.2017
   Cav123
 
4 - 30.11.17 - 14:22
Касса Штрих
   Cav123
 
5 - 30.11.17 - 14:30
СуммаТипаОплатыНаличные = ПолучитьСуммуНаличнойОплаты(АкзицныйЧек, Истина);
    Если СуммаТипаОплатыНаличные <> 0 Тогда
        СтрокаОплаты = Новый Структура();
        СтрокаОплаты.Вставить("ТипОплаты", ПредопределенноеЗначение("Перечисление.ТипыОплатыККТ.Наличные"));
        СтрокаОплаты.Вставить("Наименование", "Наличная оплата");
        СтрокаОплаты.Вставить("Сумма", СуммаТипаОплатыНаличные);
        ОбщиеПараметры.ТаблицаОплат.Добавить(СтрокаОплаты);
    КонецЕсли;
    
    СуммаТипаОплатыПлатежнойКартой = ПолучитьСуммуОплатыПлатежнойКартой(АкзицныйЧек, Истина);
    Если СуммаТипаОплатыПлатежнойКартой <> 0 Тогда
        СтрокаОплаты = Новый Структура();
        СтрокаОплаты.Вставить("ТипОплаты", ПредопределенноеЗначение("Перечисление.ТипыОплатыККТ.Электронно"));
        СтрокаОплаты.Вставить("Наименование", "Платежная карта");
        СтрокаОплаты.Вставить("Сумма", СуммаТипаОплатыПлатежнойКартой);
        ОбщиеПараметры.ТаблицаОплат.Добавить(СтрокаОплаты);

    КонецЕсли;

    СуммаТипаОплатыБезналичнойОплаты = ПолучитьСуммуБезналичнойОплаты(АкзицныйЧек, Истина);
    Если СуммаТипаОплатыБезналичнойОплаты <> 0 Тогда
        СтрокаОплаты = Новый Структура();
        СтрокаОплаты.Вставить("ТипОплаты", ПредопределенноеЗначение("Перечисление.ТипыОплатыККТ.Электронно"));
        СтрокаОплаты.Вставить("Наименование", "Банковский кредит");
        СтрокаОплаты.Вставить("Сумма", СуммаТипаОплатыБезналичнойОплаты);
        ОбщиеПараметры.ТаблицаОплат.Добавить(СтрокаОплаты);

    КонецЕсли;
    
    Для Каждого СтрокаТовара Из ЧекККМ.Товары Цикл
    
        СтрокаЧека = МенеджерОборудованияКлиентСервер.ПараметрыФискальнойСтрокиЧека();
        СтрокаЧека.Количество = СтрокаТовара.Количество;// Количество предмета расчета 

        СтрокаЧека.Цена = ЦенаВЧек;// Цена без учета скидок и наценок

        СтрокаЧека.ЦенаСоСкидками = СтрокаТовара.Сумма / СтрокаТовара.Количество;// Цена с учетом скидок и наценок

        СтрокаЧека.Сумма = СтрокаТовара.Сумма;// Cтоимость предмета расчета с учетом скидок и наценок

        
        Если СтрокаТовара.Номенклатура.ВидНоменклатуры.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.ПодарочныйСертификат Тогда
            
            СтрокаЧека.ПризнакСпособаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиСпособаРасчета.Аванс");
            //СтрокаЧека.ПризнакПредметаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиПредметаРасчета.ПлатежВыплата");

            СтрокаЧека.ПризнакПредметаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиПредметаРасчета.ИнойПредметРасчета");
        ИначеЕсли СуммаТипаОплатыБезналичнойОплаты <> 0 Тогда
            // Это кредит

            Если СтрокаТовара.СуммаКредита = СтрокаТовара.Сумма Тогда
                // Без предоплаты

                СтрокаЧека.ПризнакСпособаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиСпособаРасчета.ПередачаБезОплаты");
                СтрокаЧека.ПризнакПредметаРасчета = ?(АкзицныйЧек, ПредопределенноеЗначение("Перечисление.ПризнакиПредметаРасчета.ПодакцизныйТовар"), МенеджерОборудованияВызовСервера.ОпределитьПризнакПредметаРасчета(СтрокаТовара.Номенклатура));
                
            Иначе
                // С предоплатой

                СтрокаЧека.ПризнакСпособаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиСпособаРасчета.ПередачаСЧастичнойОплатой");
                СтрокаЧека.ПризнакПредметаРасчета = ?(АкзицныйЧек, ПредопределенноеЗначение("Перечисление.ПризнакиПредметаРасчета.ПодакцизныйТовар"), МенеджерОборудованияВызовСервера.ОпределитьПризнакПредметаРасчета(СтрокаТовара.Номенклатура));
                СтрокаЧека.Сумма = СтрокаТовара.Сумма - СтрокаТовара.СуммаКредита;// Возможно не верно?

            КонецЕсли;    

        Иначе
            СтрокаЧека.ПризнакСпособаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиСпособаРасчета.ПередачаСПолнойОплатой");
            СтрокаЧека.ПризнакПредметаРасчета = ?(АкзицныйЧек, ПредопределенноеЗначение("Перечисление.ПризнакиПредметаРасчета.ПодакцизныйТовар"), МенеджерОборудованияВызовСервера.ОпределитьПризнакПредметаРасчета(СтрокаТовара.Номенклатура));
        КонецЕсли;    
            
        ОбщиеП
   isa2net
 
6 - 30.11.17 - 14:33
(5) Конфа, релиз, типовая?
   SeriyP
 
7 - 30.11.17 - 14:36
(0) В таблице 5 в ТестДрайвера "Наименования типов оплат" что написано?
   Cav123
 
8 - 30.11.17 - 14:36
Конфа не типовая, передирал функционал из УТ (10.3.45.4)
   Cav123
 
9 - 30.11.17 - 14:39
Приписывал в таблице с мастер карт, на НАЛИЧНЫМИ,ПЛАТ.КАРТОЙ, КРЕДИТОМ,СЕРТИФИКАТОМ
   nordbox
 
10 - 30.11.17 - 14:58
тебе сказали в (8)
у тебя чек на ккм как формируется? что ты туда отправляешь?
вот что отправишь так и будет.
в 10.3... там даже специальный справочник для этого есть, Виды оплаты чеков ККМ
коды в этом справочнике должны совпадать с драйвером
 
  Рекламное место пустует
   Cav123
 
11 - 30.11.17 - 15:03
Виды оплаты чеков ККМ, там по моему где вид оплаты цифровой 0 - наличка, 1 - плат карта, это для формата 1.0, а сейчас по другому, добавлены признак расчета, перечисления и предмет расчета, и способ оплаты ККТ, перечисление
   Cav123
 
12 - 30.11.17 - 15:10
когда был на формате 1.0 на онлайн, все пробивалось, а нужно делать авансы, и зачет авансов, а это форматом 1.0 не поддерживаться, теперь не разберусь по какому принципу кредиты пробивать, аванс запахал.
   isa2net
 
13 - 30.11.17 - 15:27
(12) У формата 1.0 нет тегов 1.05, должны поддерживать драйвер, конфа, прошика формат 1.05, читать здесь https://its.1c.ru/db/metod8dev#content:4829:hdoc
   isa2net
 
14 - 30.11.17 - 15:28
   isa2net
 
15 - 30.11.17 - 15:39
(14) +Вот на штриховском форуме обсуждали https://forum.shtrih-m-partners.ru/index.php?topic=32472.0, но согласно : "Однако формат ФФД 1.0 настолько неудобен и недостаточен, что готовится поправка, которая отменяет данное требование. А пока суд да дело, некоторые производители предлагают на рынке переходную версию драйверов ФФД 1.0+, в котором поддерживаются некоторые необязательные для 1.0 теги. В частности признак способа расчета, о котором мы сегодня говорим. А также Суммовые показатели чека и Оборотные показатели смены."

Согласно этому прошивка расширяет формат до 1.0+ и не надо перерегистрации, но надо тогда определить в конфе с каким форматом вы работаете, ведь при запросе параметров ФН из ккт она вернет вам версию 1.0, в УТ 11 сделали "костыли" когда на предпросмотре чека можно выбрать формат ФФД, предварительно включив константу в настойках.
   Cav123
 
16 - 30.11.17 - 15:54
я за последние 2-е суток, перевожу вместе с сервисными работниками 40 касс, еще 10 не онлайн, мне приходиться с мимимальными затратами времени останавливать точку и вести на ней разработку, и экспериментировать с форматом 1.0+, не могу позволить. через тест драйвера нормально бъеться, где указываем сумму3
   Cav123
 
17 - 30.11.17 - 16:10
"ведь при запросе параметров ФН из ккт она вернет вам версию 1.0" сделал, что бы возвращала "1.05", для это перепроверка должна сопровождаться с перерегистрацией которую проводят спецы из сервиса кто обслуживает, там указывается формат "1.05".
   piter3
 
18 - 30.11.17 - 16:12
Без замены ФН?А что они уже есть или это все 1.0+
   Cav123
 
19 - 30.11.17 - 16:14
Без замены ФН, это идет только изменения ФФД (формат фискальных данных). изменения в конфе, слизывал из УТ, прошивки, перерегистрации, драйвере DrvFR_4.14_624. с поддержкой 1.05, обработке обслуживания.
   Cav123
 
20 - 30.11.17 - 16:15
ОбработкаОбслуживания.ПолучитьПараметрыККТ(ОбъектДрайвера);  
            ВерсияФормата = МенеджерОборудованияКлиентСервер.ВерсияФФД(ОбъектДрайвера.ВыходныеПараметры);
возвращает "1.05"
   isa2net
 
21 - 30.11.17 - 16:22
(20) ShtrihMkkt подключена свежая?
   isa2net
 
22 - 30.11.17 - 16:35
(20) Здесь вы что получаете
[/1c]
Функция ПолучитьXMLПакетДляФискализацияЧека(ОбщиеПараметры, ВыходныеПараметры, СуммаЧека, ШиринаСтроки = 32, НовыйФормат = Ложь, ВерсияФФД = 0) Экспорт
    
    ПозицииЧека  = ОбщиеПараметры.ПозицииЧека;
    ТаблицаОплат = ОбщиеПараметры.ТаблицаОплат;
    СуммаЧека = 0;
    
    // Пакетная печать чека. Подготовка пакета.

    ЗаписьXML = Новый ЗаписьXML();
    ЗаписьXML.УстановитьСтроку("UTF-8");
    ЗаписьXML.ЗаписатьОбъявлениеXML();
    
    ЗаписьXML.ЗаписатьНачалоЭлемента("CheckPackage");
    ЗаписьXML.ЗаписатьНачалоЭлемента("Parameters");
    
    ТипРасчета = МенеджерОборудованияКлиентСервер.ПолучитьКодТипаРасчетаДенежнымиСредствами(ОбщиеПараметры.ТипРасчета);
    СистемаНалогообложения = МенеджерОборудованияКлиентСервер.ПолучитьКодТипаСистемыНалогообложенияККТ(ОбщиеПараметры.СистемаНалогообложения);
    ЗаписьXML.ЗаписатьАтрибут("PaymentType", XMLСтрока(ТипРасчета));
    ЗаписьXML.ЗаписатьАтрибут("TaxVariant" , XMLСтрока(СистемаНалогообложения));
    ЗаписьXML.ЗаписатьАтрибут("CashierName",  XMLСтрока(ОбщиеПараметры.Кассир));
    Если ВерсияФФД > 0 Тогда// Атрибуты с ФФД 1.0.5 

        Если Не ПустаяСтрока(ОбщиеПараметры.КассирИНН) Тогда 
            ЗаписьXML.ЗаписатьАтрибут("CashierVATIN", XMLСтрока(ОбщиеПараметры.КассирИНН));
        КонецЕсли;
        Если Не ПустаяСтрока(ОбщиеПараметры.ОтправительEmail) Тогда
            ЗаписьXML.ЗаписатьАтрибут("SenderEmail", XMLСтрока(ОбщиеПараметры.ОтправительEmail));
        КонецЕсли;
    КонецЕсли;
[/1c]
   Cav123
 
23 - 30.11.17 - 16:46
ShtrihMkkt брал с официального сайта 1с из личного кабинета 121117, свежая сейчас скачал новую, сравнение объединения провел, нет изменений
   isa2net
 
24 - 30.11.17 - 16:48
(20) Из этой же функции
[/]
Если ВерсияФФД > 0 Тогда// Атрибуты с ФФД 1.0.5

                ЗаписьXML.ЗаписатьАтрибут("Cash"             , XMLСтрока(СуммаНаличными));
                ЗаписьXML.ЗаписатьАтрибут("ElectronicPayment", XMLСтрока(СуммаЭлектронными));
                ЗаписьXML.ЗаписатьАтрибут("Credit"           , XMLСтрока(СуммаПостоплатой));
                ЗаписьXML.ЗаписатьАтрибут("AdvancePayment"   , XMLСтрока(СуммаПредоплатой));
                ЗаписьXML.ЗаписатьАтрибут("CashProvision"    , XMLСтрока(СуммаПредоставлением));
            Иначе
                ЗаписьXML.ЗаписатьАтрибут("Cash"             , XMLСтрока(СуммаНаличными));
                ЗаписьXML.ЗаписатьАтрибут("ElectronicPayment", XMLСтрока(СуммаЭлектронными + СуммаПостоплатой + СуммаПредоплатой + СуммаПредоставлением));
            КонецЕсли;
            ЗаписьXML.ЗаписатьКонецЭлемента();
        КонецЕсли;
[/1c]
   isa2net
 
25 - 30.11.17 - 16:51
(24)+В эту функцию вы попадаете при формировании чека и какое значение параметра ВерсияФФД?
   Cav123
 
26 - 30.11.17 - 17:11
Функция ПолучитьXMLПакетДляФискализацияЧека возвращает, но я экспериментировал с признаком предмета расщета по строке, все в кредит 
        СтрокаЧека.ПризнакСпособаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиСпособаРасчета.ПередачаБезОплаты");
                СтрокаЧека.ПризнакПредметаРасчета = ?(АкзицныйЧек, ПредопределенноеЗначение("Перечисление.ПризнакиПредметаРасчета.ПодакцизныйТовар"), МенеджерОборудованияВызовСервера.ОпределитьПризнакПредметаРасчета(СтрокаТовара.Номенклатура));

 

<?xml version="1.0" encoding="UTF-8"?>
<CheckPackage>
    <Parameters PaymentType="1" TaxVariant="3" CashierName="Консультант - эксперт Яценко" CustomerEmail="" CustomerPhone=""/>
    <Positions>
        <FiscalString Name="Омыватель стекол &quot;ZIMA&quot; -30*С (5 л)(шт)" Quantity="1" PriceWithDiscount="130" SumWithDiscount="130" DiscountSum="" Department="2" Tax="none" SignMethodCalculation="6" SignCalculationObject="1" TaxSum=""/>
    </Positions>
    <Payments Cash="0" ElectronicPayment="130" Credit="0" AdvancePayment="0" CashProvision="0"/>
</CheckPackage>
   isa2net
 
27 - 30.11.17 - 17:15
(26) Credit="0" - здесь почему 0?
   Cav123
 
28 - 30.11.17 - 17:40
Да, хороший вопрос, черт функция серверная, в отладчик не зайти, в рееестре дебагер ставить надо, ну зато есть куда копать. ВерсияФФД = 1
   piter3
 
29 - 30.11.17 - 17:46
Может уже стоит посмотреть какой драйвер в обработке?Он же не в конфе вроде
   nordbox
 
30 - 30.11.17 - 17:59
(28)
- поле "ElectronicPayment" - Сумма электронной оплаты
- поле "AdvancePayment" - Сумма из предоплаты (зачетом аванса)
- поле "Credit" - Сумма постоплатой(в кредит)
- поле "CashProvision" - Сумма оплаты встречным предоставлением (сертификаты, тара, др. мат. ценности)
   isa2net
 
31 - 30.11.17 - 18:01
(29) Если ShtrihMkkt свежая, то он из её макета берет интеграционную компоненту и создает объект драйвера. У меня вот последняя версия http://imglink.ru/show-image.php?id=88c83864ca2151501b6a63d5a49fe5cf. (23) Может из крайнего релиза из папки TradeWareEpf попробовать взять? Хотя с сайта должно тоже самое быть, но так, на всякий...
   Neg
 
32 - 30.11.17 - 18:05
А с Атолами такой хрени нет???
   isa2net
 
33 - 30.11.17 - 18:07
(32) Думаете у Штриха компонента кривая? Все возможно...))
 
 
   isa2net
 
34 - 30.11.17 - 18:12
То, что штрих по тегу 1209 возвращает версию 1.05 без перерегистрации это уже круто, у меня Атол так не может, хотя если он был уже со свежей ФН взят...
   piter3
 
35 - 30.11.17 - 18:15
(34) да наверняка
   LienXo
 
36 - 30.11.17 - 18:29
(8) а че не с Розницы / УТ 11? Там функционал кредитов по 1.05 реализован и вполне реально работает на 4.14.624 драйвере.
   isa2net
 
37 - 30.11.17 - 18:38
(36) Вероятно у человека на обычных формах конфа.
   Mikhail Volkov
 
38 - 01.12.17 - 06:38
(11) Про "признак расчета" можно подробнее? Почему из-за него Альфа-Авто 4.1 не может поддерживать формат ФФД 1.05? https://rarus.ru/forum/messages/forum7/topic11493/message73361/#message73361
   Cav123
 
39 - 01.12.17 - 12:17
Если чек, полносностью в кредит без первоначального взноса. Устанавливать надо постоплату в таблице оплат, в таблице позиции чека, устанавливал СтрокаЧека.ПризнакСпособаРасчета = ПредопределенноеЗначение("Перечисление.ПризнакиСпособаРасчета.ПередачаБезОплаты"); Система налогообложения - Общая, в чек выходит и в х, и z вероятно, строчка "Последующая оплата (КРЕДИТ)" и сумма кредита, так же считается НДС, а если пробивать через Тест драйвера пишется просто КРЕДИТ, а НДС "Без НДС", нужно уточнять у бухгалтеров как правильно, и как то странно Последующюю оплату видеть, это нормально? С первоначальным взносом, пока не игрался.



Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует