Вход | Регистрация

1С:Предприятие ::

Метки: 

Блокирование не всей формы

Я
   _barracuda_
 
30.11.17 - 12:37
добрый день.подскажите альтернативу Доступность,потому как при Доступности  даже закладки блокируются так что их нельзя проклацать и даже посмотреть что на них.была использована ТолькоПросмотр на форму но понадобилось освободить некоторые реквизиты на редактирование.ТолькоПросмотр в Истину позволял смотреть документ  по любым закладкам и даже печатать.а Доступность ничего не позволяет делать

                                    Для каждого Элемент Из ЭтаФорма.ЭлементыФормы цикл 
                    Имя_ = Элемент.Имя;
                    Если имя_="Название" ИЛИ  имя_="Комментарий" ИЛИ имя_="Статус" Тогда
                        //    продолжить

                        Элемент.Доступность= Истина; 
                    Иначе
                        Элемент.Доступность= Ложь; 
                    КонецЕсли; 
                КонецЦикла;
 
 
   Гипервизор
 
1 - 30.11.17 - 12:43
(0) ТолькоПросмотр для избранных элементов формы чем не устраивает?
   _barracuda_
 
2 - 30.11.17 - 12:44
(1)Элемент.ТолькоПросмотр = Истина;
ругается
   _barracuda_
 
3 - 30.11.17 - 12:46
Элемент.ТолькоПросмотр = Истина; 
                    Иначе
                        Элемент.ТолькоПросмотр = Ложь; 
                    КонецЕсли; 


Поле объекта не обнаружено (ТолькоПросмот)
   Dmitriy_76
 
4 - 30.11.17 - 12:53
(3) а что у тебя в Элемент ?
   Dmitriy_76
 
5 - 30.11.17 - 12:54
не у всех элементов формы есть ТолькоПросмотр
   Dmitriy_76
 
6 - 30.11.17 - 12:55
смотри на его Вид
   Ц_У
 
7 - 30.11.17 - 12:56
Процедура ДоступностьЭлементовФормыПриСозданииНаСервере(Форма,СписокЭлементов) Экспорт 
    Если ЗначениеЗаполнено(СписокЭлементов) Тогда
        Элементы = Новый Структура(СписокЭлементов,);
        Для каждого Элемент Из Форма.Элементы Цикл
            
            Если Элементы.Свойство(Элемент.Имя) Тогда
                Элемент.Доступность = Истина;
            Иначе
                //исключения, кнопки, группы элементов и ТЧ

                Если ТипЗнч(Элемент) = Тип("ГруппаФормы") ИЛИ ТипЗнч(Элемент) = Тип("КнопкаФормы") Тогда
                    Продолжить;
                КонецЕсли;    
                //ТЧ и ее состав

                Если ТипЗнч(Элемент) = Тип("ТаблицаФормы") Тогда
                    Элемент.ТолькоПросмотр = Истина;
                    Продолжить;
                КонецЕсли;    
                //элементы ТЧ не блокируем они и так "для чтения" по родителю

                Если ТипЗнч(Элемент.Родитель) = Тип("ТаблицаФормы") Тогда
                    Продолжить;
                КонецЕсли;    
                //

                Попытка
                    Элемент.Доступность = Ложь;
                Исключение
                    Продолжить;
                КонецПопытки;
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры
   _barracuda_
 
8 - 30.11.17 - 12:58
(6) наверное тип?
   _barracuda_
 
9 - 30.11.17 - 12:59
(7)спасибо


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует