Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

ПКО Составного типа

ПКО Составного типа
Я
   breezee
 
29.11.17 - 18:34
Добрый день! Подскажите, пожалуйста. Делаю выгрузку на КД2. Данные собираю запросом в ПВД. Понадобилось, чтобы в зависимости от типа источника использовались разные правила. Использую "ВыгрузитьПоПравилу"(код ниже), выгрузка не использует мое правило. Подскажите, где я накосячил? Пожалуйста
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
        Если ТипЗнч(ВыборкаДетальныеЗаписи.Ссылка) = Тип("ДокументСсылка.ПлатежноеПоручениеИсходящее") Тогда 
            Если ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.Субконто1) Тогда
            Если ТипЗнч(ВыборкаДетальныеЗаписи.Субконто1) = ТИП("СправочникСсылка.Контрагенты") Тогда    
                Сообщить("2");
                
                ВыгрузитьПоПравилу(ВыборкаДетальныеЗаписи.Субконто1, , , , "КонтрагентыВКонтрагенты2");
                
            КонецЕсли;                                   
            КонецЕсли;                       
        КонецЕсли;
        
        НСтрокаТабличнойЧасти = ТабличнаяЧасть.Добавить();
        ЗаполнитьЗначенияСвойств(НСтрокаТабличнойЧасти, ВыборкаДетальныеЗаписи);
        
    КонецЦикла;
 
 
   breezee
 
1 - 29.11.17 - 18:34
(0)   Сообщить("2"); - выводится
   breezee
 
2 - 29.11.17 - 18:42
В ПКС не могу указать правило, так как выгрузка реквизита идет в табличную часть. А в ПКС доступна только ссылка, по ссылке ничего узнать не могу. Единственный вариант, который вижу - указывать правило в момент выгрузки данных. Указал, не отработало. Возможно, элемент в нужном справочнике создался, но в самой выгруженной табличной части получился контрагент, выгруженный по другим правилам
   breezee
 
3 - 29.11.17 - 18:44
Приоритет у моих правил тоже сделал ниже(149 у моих правил), 200 у правил, по которым выгрузился элемент. Не помогает. Система по типу цепляет не те правила.
   breezee
 
4 - 29.11.17 - 18:45
Если есть идеи - предложите, пожалуйста.
   Franchiser
 
5 - 29.11.17 - 18:48
(3) по-моему приоритет нужно делать не ниже у твоих, а выше. Попробуй
   Franchiser
 
6 - 29.11.17 - 18:51
Если одному типу-источника есть соответствие нескольких правил, то выберется то правило, у которого значение поля Приоритет (закладка Дополнительно) НАИБОЛЬШЕЕ, т.е. правило более позднее в справочнике ПКО.
   Cyberhawk
 
7 - 29.11.17 - 19:49
Отказ = Истина забыл до/после ВыгрузитьПоПравилу
   breezee
 
8 - 30.11.17 - 03:07
(6) Спасибо! Помогло. Хотя, для других типов документов нужен другой приоритет, вроде. Можно как-то программно задавать приоритет правила в момент выгрузки данных? (7) "Отказ - Булево. Если установить значение Истина, то выгрузка данных по данному правилу не производится" Зачем мне отказ?
   Cyberhawk
 
9 - 30.11.17 - 12:22
(8) Видимо ты прочитал только часть моего сообщения
   Franchiser
 
10 - 30.11.17 - 15:50
(8) нет программно приоритет задать нельзя. Ты можешь программно устанавливать ИмяПКО в зависимости от каких либо условий, например, анализируя входящие данные
 
 Рекламное место пустует
   Franchiser
 
11 - 30.11.17 - 15:53
В ПВД у тебя стоит "произвольный алоритм"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует