Вход | Регистрация

1С:Предприятие ::

Метки: 

проверка заполнения реквизитов

Я
   _barracuda_
 
29.11.17 - 13:24
Добрый день.Подскажите что не так.ругается:  Процедура или функция с указанным именем не определена (ЭтоНовый)
    Если <<?>>ЭтоНовый() Тогда (Проверка: Сервер)


&НаСервере
Процедура  ййй()
    Если ЭтоНовый() Тогда
    СтавкаНДС=Перечисления.СтавкиНДС.БезНДС;
    ЕдиницаИзмерения=Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию("шт");
    КонецЕсли;
КонецПроцедуры
 
  Рекламное место пустует
   СамыйУмный
 
1 - 29.11.17 - 13:25
Объект.ЭтоНовый()
   _barracuda_
 
2 - 29.11.17 - 13:27
(1)тогда при создании товара или открытии пишет метод объекта не обнаружен Новый
   Волшебник
 
Модератор
3 - 29.11.17 - 13:28
(2) глаза разуй
   Mankubus
 
4 - 29.11.17 - 13:28
Если Объект.Ссылка.Пустая() Тогда // новый
   _barracuda_
 
5 - 29.11.17 - 13:31
(3)Разул.метод объекта не обнаружен (этоновый)

&НаСервере
Процедура  ЗаполнимРекв(Объект)
    Если Объект.ЭтоНовый() Тогда
    СтавкаНДС=Перечисления.СтавкиНДС.БезНДС;
    ЕдиницаИзмерения=Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию("шт");
    КонецЕсли;
КонецПроцедуры
   LienXo
 
6 - 29.11.17 - 13:35
1. Если &НаСервере зачем передавать объект в процедуру
2. ставкандс это реквизит формы или объекта? если объекта тогда объект.ставкандс
   _barracuda_
 
7 - 29.11.17 - 13:35
всем спасибо .


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует