Вход | Регистрация

1С:Предприятие ::

Метки: 

Вывод в табличную часть данных

Я
   Mitka90
 
29.11.17 - 10:15
Доброго времени суток, уважаемые!
Нужно вывести данные из справочника "Материалы" в табличную часть "Материалы" документа "Начисления ВДГО" по нажатию кнопки "Подбор", но при попытке добавить данные появляется ошибка вида:
[code]{Документ.НачисленияВДГО.Форма.ФормаДокумента.Форма(1637)}: Метод объекта не обнаружен (ДобавитьСтроку)
        материалы.ДобавитьСтроку();[/code]

Вот сама процедура:

[code]Процедура МатериалыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    
Сообщить(ВыбранноеЗначение);    
    //  Для СчетчикЦикла = 0 по ВыбранноеЗначение.ВГраница() цикл

    //    НоваяСтрока = Материалы.Добавить();

    //    НоваяСтрока.Материал = ВыбранноеЗначение[СчетчикЦикла];

    //КонецЦикла;


    Для Каждого Элемен из Материалы Цикл
        
        Если Элемен.Материал=ВыбранноеЗначение Тогда 
        Элемен.Количество=Элемен.Количество+1  Иначе
        КонецЕсли        
    КонецЦикла;
        Элемент=0;       
     Для Каждого Элемен из Материалы Цикл    
        Если Элемен.Материал = ВыбранноеЗначение Тогда Элемент=Элемент+1
        КонецЕсли    
        КонецЦикла;
       Если Элемент=0  Тогда 
        материалы.ДобавитьСтроку();
        материалы.ТекущиеДанные.материал=ВыбранноеЗначение;
        КонецЕсли
    
             
КонецПроцедуры[/code]

Подскажите, в чём может быть проблема? Заранее спасибо!
 
 
   Волшебник
 
Модератор
1 - 29.11.17 - 10:28
Добавлять надо в табличную часть, а не в табличное поле

НовСтрока = материалы.Добавить();
НовСтрока.Материал = ВыбранноеЗначение;
   Mitka90
 
2 - 29.11.17 - 13:13
Волшебник,
большое спасибо, всё работает!
   Mitka90
 
3 - 01.12.17 - 13:16
Кстати, как можно сделать так, чтобы в табличную часть "Материалы" добавлялось также, кроме столбца "Материал", ещё и данные из столбца "Цена", например?
   _Дайвер_
 
4 - 01.12.17 - 13:33
(3) НовСтрока.Цена= ВыбранноеЗначение[индекс];
   vicof
 
5 - 01.12.17 - 13:59
За такое форматирование, имена переменных, отстуствие точек с запятыми - пожизненный эцих с гвоздями.
   Mitka90
 
6 - 04.12.17 - 14:59
Спасибо, получилось так вывести:
[code]
       Если Элемент=0  Тогда 
           НовСтрока = материалы.Добавить();
        НовСтрока.Материал = ВыбранноеЗначение;
        НовСтрока.Количество = 1;
        НовСтрока.Цена = ВыбранноеЗначение.Цена;
        НовСтрока.Стоимость = НовСтрока.Цена * НовСтрока.Количество;
        КонецЕсли
[/code]


Список тем форума
Рекламное место пустует Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует