Вход | Регистрация


GUID в строке ТЧ управляемой формы

GUID в строке ТЧ управляемой формы
Я
   Charity
 
29.11.17 - 07:49
Доброго дня, уважаемые.
Что-то я затупила, помогите разобраться, пожалуйста.
Сабж: есть некий РС (регистр сведений) вида: Элемент справочника; GUID (тип = Уникальный идентификатор). Создала обработку, вытаскивающую записи этого РС. В качестве реквизита обработки сделала ТЧ с элементами соответствующего типа: Элемент справочника; GUID.
Создала управляемую форму с таблицей, привязанной к ТЧ объекта.
ТЧ инициализируется запросом по кнопке. Запрос выдергивает GUID, отображает его в консоли. А в обработке GUID пустой. Что не так?
Пните в нужном направлении. Спасибо!
 
 
   Mikhail Volkov
 
1 - 29.11.17 - 07:53
> Сабж: есть некий РС (регистр сведений) вида: Элемент справочника; GUID (тип = Уникальный идентификатор).
И что еще? Если больше ничего, то зачем такой РС?
   Charity
 
2 - 29.11.17 - 07:57
Mikhail Volkov,структура метаданных такая, какая есть. Необходимо вывести уникальный идентификатор на управляемую форму. в запросе УИ отображается, в ТЧ нет.
   igorPetrov
 
3 - 29.11.17 - 08:09
(2) Ну, так смотрите ТЧ и её реквизиты, нам отсюда не видно что там.
   Рэйв
 
4 - 29.11.17 - 08:19
(0)Зачем тебе непременно именно сам УИД? Почему бы вместо целого объекта не держать его в качестве строки? Полезности от  УИД в виде объекта в данном случае - ноль
   Charity
 
5 - 29.11.17 - 08:20
ТЧ имеет 2 реквизита:
1) тип справочникСсылка
2) тип УникальныйИдентификатор

Реквизитом формы упр.является Объект, у которого есть данная ТЧ.

Код формы по кнопке заполнения:


&НаКлиенте
Процедура Заполнить(Команда)
    Если Не ЗначениеЗаполнено(Объект.Дата) ИЛИ Не ЗначениеЗаполнено(Объект.Организация) Тогда
        Сообщить("Не заполнена дата или организация");
        Возврат;
    КонецЕсли;
    ЗаполнитьНаСервере(Объект.Организация, Объект.Дата);
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере(Организация, Дата)
*******тут запрос, его текст и инициализация параметров
 Объект.Материалы.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры

В результате заполняются все поля кроме GUIDa
   Charity
 
6 - 29.11.17 - 08:23
Рэйв, как мне сконвертировать GUID в строку, оператор ВЫРАЗИТЬ в запросе выдает ошибку
   Рэйв
 
7 - 29.11.17 - 08:26
(6)Изначально измерение сделать строкий и там и хранить.
перейти тоже просто.Добавляешь измерение УИДСтрока, заполняешь его по текущим записям из УИД, потом УИД удаляешь и все
   Charity
 
8 - 29.11.17 - 08:28
(7) Я правильно понимаю, что вы предлагаете изменить в РС структуру измерений? Структуру метаданных менять нельзя.
   Charity
 
9 - 29.11.17 - 08:37
(4) Спасибо, Рэйв, вы меня натолкнули на простейшее решение. в ТЧ поменяла тип реквизита, содержащего GUID, на Строка(50) и при заполнении ТЧ из запроса платформа сама получила строковое представление GUIDa и колонки таким образом у меня заполнились
Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует