Вход | Регистрация


1С:Предприятие ::

Метки: 

Получить данные Z-отчета, напрямую через драйвер кассы ?

Я
   Radion
 
28.11.17 - 19:13
УТ 11. Я помню, поднимали тему с печатью z отчета для касс онлайн. Стоит вопрос получать данные (к примеру в фоновом задании) напрямую из кассы через драйвер. Кто нибудь уже решал такие задачи? Спасибо.
 
 
   МимохожийОднако
 
1 - 28.11.17 - 19:23
(0) Если касса занята из 1С, то не получится к ней подключиться из драйвера. Пожалуйста.
   kofeinik
 
2 - 28.11.17 - 19:26
(0) Может речь про x-отчет, который для онлайн касс с использованием некоторых драйверов действительно не печатается?
   Woldemar177
 
3 - 28.11.17 - 19:46
(1) Еще как получится, но делать этого не стоит. расхождения будут.
   Woldemar177
 
4 - 28.11.17 - 19:46
(2) Ага? Каких именно?
   МимохожийОднако
 
5 - 28.11.17 - 19:49
(3) Расскажи. Мужики-то не знают
   Woldemar177
 
6 - 28.11.17 - 20:06
(5) Что расказывать? В чт или пт закрывали, 1с зависла, смена открыта,  через драйвер закрыли. Атол 11ф или 30ф, не помню. Можно и чек выбить
   МимохожийОднако
 
7 - 28.11.17 - 20:16
(6) Через драйвер закрывали и при этом одновременно работали в 1С? Это вряд ли. Я к тому что в сабже был разговор о "фоновом" обращении к драйверу. А твой пример встречал несколько раз. Особых проблем не было. В 1С всегда есть возможность нестандартными методами обойти проблемы неправильно закрытой смены. Я предполагал, что ты знаешь что-нибудь об одновременной работе с кассой из разных программ.
   Woldemar177
 
8 - 29.11.17 - 09:47
(7) Одновременно то зачем??? Я ж сказал когда 1с зависла, со всеми бывало, с системой город, у вас такой нет.
   Radion
 
9 - 29.11.17 - 11:46
Я так понял, что после закрытия Z отчета никаких данных по внесению /снятию / выручке получить не получиться - т.к. данные обнуляются. А есть код для подключения через драйвер к кассе и получения суммы внесения / списания / выручки пока смена не закрыта, z отчет не снят ?
   Radion
 
10 - 29.11.17 - 11:47
(9) обнуляются на кассе конечно
 
 Рекламное место пустует
   GenAcid
 
11 - 29.11.17 - 12:18
(7) В БПО начиная с версии 2 порт кассы не блокируется постоянно, по крайней мере при работе с Атоловскими аппаратами. Перед печатью драйвер подключается, после печати отпускает. Правда пару раз замечал что порт был занят пока была открыта форма, из которой щла работа с оборудованием. Но это редкость, обычно сразу после печати чека можно открыть тест драйвера и сделать в нем что душе угодно.
   Галахад
 
12 - 29.11.17 - 12:32
(9) Идея какая-то странная. Зачем из 1С-ки читать выручку?
И почему это нельзя сделать потом? Где журнал кассира с Z-отчетами?
   Radion
 
13 - 29.11.17 - 13:37
(12) потому что, когда нет возможности вбивать чеки из 1с (нет инета в центре продаж. у нас их около 30), то они выбивают чеки на ФР через спец программу. Получая данные через драйвер, перед закрытием Z отчета мы получаем реальные обороты в кассе.
   LienXo
 
14 - 29.11.17 - 13:41
(11) при открытии РМК порт блокируется на все время пока форма открыта что в УТ что в рознице. Если печатаешь из чека, ПКО или накладной - блокирует на момент обращения.
   Mikhail Volkov
 
15 - 29.11.17 - 13:43
(0) В УТ11 нет обработки закрытия смены? У нас иногда бывали случаи: смену открыли, но ни одного чека не отбили (неполадки с кассой). Тогда Сервис/Параметры/Свойства/Сервис оборудования/Отчет "Z-отчет с гашением". Если чеков за смену не было, то бумажку Z-отчета можно не смотреть - все нулевое.
   Radion
 
16 - 29.11.17 - 13:52
(15) вопрос автоматизации импорта кассовых документов из УТ 11 в БП 3.0. исключить ручной труд операторов кассиров.
   Mikhail Volkov
 
17 - 29.11.17 - 16:14
(16) При чем тут "из УТ 11 в БП 3.0"? Или вопрос не понял... снять Z-отчет - смену закрыть? Почему не обработкой закрытия смены? Если напрямую через драйвер кассы, то Сервис/Параметры/Свойства/Сервис оборудования/Отчет "Z-отчет с гашением", но данные с чека Z-отчета вручную вбивать в базу придется.
Когда то в 7-ке так снимал:

//*******************************************

Процедура СформироватьZ()
    
    ФР = СоздатьОбъект("AddIn.FprnM45");
    // занимаем порт

    ФР.DeviceEnabled = 1;
    Если ФР.ResultCode <> 0 тогда
        Сообщить("Не удалось занять порт", "!");
        Возврат;
    КонецЕсли;

    // если смена открыта снимаем Z-отчет

      Если ФР.SessionOpened = 1 тогда

        // Отчет по секциям

        ФР.Mode = 2;
        Если ФР.SetMode() <> 0 тогда
            Сообщить("Не удалось войти в режим регистрации", "!");
            Возврат;
        КонецЕсли;
//        ФР.SetMode();

        ФР.ReportType = 7;
        ФР.Report();
    
        // снимаем Z-отчет

        ФР.Mode = 3;
        ФР.SetMode();
        ФР.ReportType = 1;
        ФР.Report();
    Иначе
        Предупреждение("Не открыта кассовая смена!",60);
      КонецЕсли;

    // освобождаем порт

    ФР.DeviceEnabled=0;   
КонецПроцедуры
   Radion
 
18 - 29.11.17 - 16:36
(17) хотим автоматизировать процесс, импорта кассовых документов (ведение кассовой дисциплины). Для этого требуется автоматизировать процесс импорта документов из УТ 11 в БП. Предполагается, что перед закрытием смены (z отчета) формируется файл с оборотами по конкретной кассе. После чего, вечером по регламентному заданию, БП загрузить обороты по кассе в базу.
   Radion
 
19 - 29.11.17 - 16:37
(17) спасибо, этот код есть. а вот как получить оборот - выручку данные списания и внесения ?
   serpentt
 
20 - 29.11.17 - 16:43
(19) Надо обращаться к соответствующим регистрам в ККТ
   serpentt
 
21 - 29.11.17 - 16:47
//Получаем Номера и сумму

ОбъектECR.RegisterNumber = 51;
ОбъектECR.GetRegister();
НомерЧека = ОбъектECR.НомерДокумента;
НомерФД   = ОбъектECR.ФискальныйПризнак;
СуммаЧека = ОбъектECR.Сумма;


Вы соответственно выбирайте тот регистр где хранится нужная Вам информация.
   Radion
 
22 - 29.11.17 - 17:05
(21) Спасибо! Сейчас попробую.
   Mikhail Volkov
 
23 - 30.11.17 - 14:53
(20) Зачем? ККТ - принтер чеков, бумажки печатает. А деньги - кассовые документы, по ним надо.



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует