Вход | Регистрация

1С:Предприятие ::

Метки: 

На управляемой форме редактирую таблицу при помощи обработки, после

Я
   Ivan_495
 
28.11.17 - 19:12
На управляемой форме редактирую таблицу при помощи обработки, после редактирования данные пишу в регистр, но при повторном открытии не вижу этих данных в таблице

&НаКлиенте
Процедура Команда1(Команда)
    // Вставить содержимое обработчика.

    
    Отказ = Истина;
  
    эл=Адрес();    
          
    ОбработкаРедактирования = Обработки.РедактированиеКонтактнойИнформации.Создать();
    ОбработкаРедактирования.ДоступностьОбъекта = Истина;
    ОбработкаРедактирования.РедактироватьЗапись(эл[0], , ЭтаФорма, , Истина);
    
    тек_ = эл[0];

    Объект.Адрес_Доставки=тек_.Представление;
          
КонецПроцедуры
 
 
   Ivan_495
 
1 - 28.11.17 - 19:25
&НаСервере
Функция Адрес()
    эл=РеквизитФормыВЗначение("АдресДоставки");
    возврат эл;
КонецФункции
   МимохожийОднако
 
2 - 28.11.17 - 19:31
(0) Где в представленном коде запись в регистр?
   Ivan_495
 
3 - 28.11.17 - 19:34
после закрытия этой обработки, пишется в регистр
ОбработкаРедактирования.РедактироватьЗапись(эл[0], , ЭтаФорма, , Истина);
   МимохожийОднако
 
4 - 28.11.17 - 19:36
(3) Убедился, что после закрытия формы записи есть в регистре?
   Ivan_495
 
5 - 28.11.17 - 19:38
да
думал что можно на управляемой форме поработать только с объектом без отображения . не получается.
   МимохожийОднако
 
6 - 28.11.17 - 19:39
(5) Да, есть записи? Или да , нет записей?
Твой ответ меня только запутал. Не шучу.
   Ivan_495
 
7 - 28.11.17 - 19:40
да записи есть
   МимохожийОднако
 
8 - 28.11.17 - 19:42
Если записи есть, то смотри процедуру чтения этого регистра.Процедура повторного чтения запускается?
   МимохожийОднако
 
9 - 28.11.17 - 19:45
ОбновитьОтображениеДанных(<ОбновлятьЭлементы>)
   Ivan_495
 
10 - 28.11.17 - 19:48
(9) пробовал ОбновитьОтображениеДанных
не помогло
 
 Рекламное место пустует
   МимохожийОднако
 
11 - 28.11.17 - 19:51
Ты приведи код. То, что ты показывал к сабжу отношения не имеет.
   Ivan_495
 
12 - 28.11.17 - 19:53
если в конце пишу записать закрыть, то все нормально работает
НаКлиенте
Процедура Команда1(Команда)
    // Вставить содержимое обработчика.


    
    Отказ = Истина;
  
    эл=Адрес();    
          
    ОбработкаРедактирования = Обработки.РедактированиеКонтактнойИнформации.Создать();
    ОбработкаРедактирования.ДоступностьОбъекта = Истина;
    ОбработкаРедактирования.РедактироватьЗапись(эл[0], , ЭтаФорма, , Истина);
    
    тек_ = эл[0];

    Объект.Адрес_Доставки=тек_.Представление;
 записать();
закрыть();
          
КонецПроцедуры
   МимохожийОднако
 
13 - 28.11.17 - 20:06
(12) Зачем закрываешь? Вместо закрытия добавь процедуры записи в регистр, потом обнови данные и закрой.
   МимохожийОднако
 
14 - 28.11.17 - 20:06
...а может быть  и не закрывать форму?
   Ivan_495
 
15 - 28.11.17 - 20:24
ОбработкаРедактирования.РедактироватьЗапись(эл[0], , ЭтаФорма, , Истина);
эта обработка вызывает форму на ней редактирую даннные и записываю их в регистр


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует