Вход | Регистрация

1С:Предприятие ::

Метки: 

Ввод на основании получить данные

Я
   Roma1314704
 
28.11.17 - 17:42
День добрый. Есть самописная Конфа. Есть счет фактура, есть расходная накладная. Расходная заполнятся на основании счета (создана с помощью на конструктора)
Задача нужно в макет расходной вывести поле Основание где должен быть счет № дата.
Вопрос как в расходную дернуть Ссылку на документ (в данном случае счет)+ его номер и дату?
 
  Рекламное место пустует
   piter3
 
1 - 28.11.17 - 17:43
докоснование.дата
   Roma1314704
 
2 - 28.11.17 - 17:54
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

    // Данный фрагмент построен конструктором.

    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.Счет") Тогда
        // Заполнение шапки

        Валюта = ДанныеЗаполнения.Валюта;
        Договор = ДанныеЗаполнения.Договор;
        Контрагент = ДанныеЗаполнения.Контрагент;
        КонтрагентПолноеИмя = ДанныеЗаполнения.КонтрагентПолноеИмя;
        Примечание = ДанныеЗаполнения.Примечание;
        Склад = ДанныеЗаполнения.Склад;
        Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.ЕдИзм = ТекСтрокаТовары.ЕдИзм;
            НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
            НоваяСтрока.НаименованиеДляПечати = ТекСтрокаТовары.НаименованиеДляПечати;
            НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
            НоваяСтрока.Цена = ТекСтрокаТовары.ЦенаРозничная;
        КонецЦикла;
    КонецЕсли;
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

КонецПроцедуры
   Roma1314704
 
3 - 28.11.17 - 17:55
как в одно поле расходной выдернуть ссылку+номер+дата?
   piter3
 
4 - 28.11.17 - 17:55
Строка(дата) +" "+ строка(номер)
   Roma1314704
 
5 - 28.11.17 - 17:57
Т.е. получить по отдельности 3 значения, далее путем конкатенации соединить, правильно?
   piter3
 
6 - 28.11.17 - 17:58
Ну да.только ссылка зачем нужна?
   Roma1314704
 
7 - 28.11.17 - 18:10
название документа  - счет фактура как получить?
   Roma1314704
 
8 - 28.11.17 - 18:21
Спасибо, разобрался.
piter3 - спасибо за помощь
   Roma1314704
 
9 - 30.11.17 - 13:53
маленький вопрос  - как с ссылки на документ (где соотвественно кроме название документа ) есть дата и время
Как с этой ссылки удалить время?
   piter3
 
10 - 30.11.17 - 13:55
Формат(Дата, ФорматДаты)
ФорматДаты = "ДФ='дд ММММ гггг'"
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует