Вход | Регистрация

1С:Предприятие ::

Метки: 

Не типовая УТ11, точнее уже совсем не ут.

Я
   riks05
 
28.11.17 - 06:40
Добрый день дорогие пользователи, вопрос скорей всего бональный и просто но чёто у меня башка не варит. ЕСТЬ УТ11. в ней куча не типовых документов, всё это дорабатывалось ещё до того как я школу окончил. Так вот выдаёт ошибку на один документ при запуске под толстым клиентом.
{Документ.БесплатныйАкт.МодульМенеджера(20,7)}: Переменная не определена (УправлениеПечатью)
{Документ.БесплатныйАкт.МодульМенеджера(30,2)}: Переменная не определена (ФормированиеПечатныхФорм)
Собственно смотрел на код типовых объектов, на код других не типовых объектов и там то по сути всё теже модули вызываются и они работают, а тут чтото не так идёт.
Процедура:
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
           
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт_АНВИК") Тогда
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
            КоллекцияПечатныхФорм,
            "Акт_АНВИК",
            НСтр("ru = 'Акт на информационные услуги'"),
            ПечатьАктНаИнформационныеУслуги("Анвик_АктНаИнформационныеУслуги", МассивОбъектов),
            ,
            "Документ.Анвик_БесплатныйАкт.Анвик_АктНаИнформационныеУслуги");
    КонецЕсли;
    
    ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
    
КонецПроцедуры
 
 
   shadow_sw
 
1 - 28.11.17 - 06:46
бАнальный :)
в какой момент ошибка то вываливается? при открытии/при печати?
   riks05
 
2 - 28.11.17 - 06:49
(1) ошибка как ни странно вываливается при открытии формы списка документов
   shadow_sw
 
3 - 28.11.17 - 06:51
(2) отладку запускай и смотри пошагам, форме списка ПриОткрытии()
   VladZ
 
4 - 28.11.17 - 06:58
Это, случайно, не тот Анвик, который на Невского 1?
   mehfk
 
5 - 28.11.17 - 07:01
(4) Опять франч студентов отправил на клиентах обучаться...
   riks05
 
6 - 28.11.17 - 07:04
(5) не на клиентах, эту конфу и использует франч.
   shadow_sw
 
7 - 28.11.17 - 07:06
франч пригласил студентов?  О_о
   Рэйв
 
8 - 28.11.17 - 07:13
(0)Смотри галки в свойствах у общих модулей УправлениеПечатью и ФормированиеПечатныхФорм и с сервера или клиента они вызываются.
   Рэйв
 
9 - 28.11.17 - 07:14
А то судя по сабжу вызов идет с сервера, а не факт что они (общие модули)под это заточены
   riks05
 
10 - 28.11.17 - 07:14
(7) да, дали тестовое задание, ВПФ, ну я написал, пригласили, в основном все задачи и состоят в написании внешних отчётов обработок и пеачатных форм. Но бывают иногда и интересные доработки, и переносы настроек. Но вот тут у меня конкретная засада с этой ут. Отладчик не помогает. пишет ошибка инициализации модуля менеджера документа и выдёт то что я описал выше.
 
 Рекламное место пустует
   riks05
 
11 - 28.11.17 - 07:15
(9) галки на сервере стоят, но при вызове этих модулей из других объектов всё работает и под тонким и толстым клиентом. а вот тут засада.
   МимохожийОднако
 
12 - 28.11.17 - 07:46
(11) Значит вызываешь не оттуда или не в том режиме. Какие галки стоят? Как вызываешь?
   h-sp
 
13 - 28.11.17 - 07:50
(11) ну это элементарно решается. Запусти Конфигурация-Проверка конфигурации. И там проставь галки, то что касается толстого клиента. Ну и другие галки. Она тебе выдаст все ошибки в конфе.
   riks05
 
14 - 28.11.17 - 07:51
(12) как вызываю написано в процедуре выше. галки в модел управление печатью стоят только напротив "сервер" и "внешнее соединение"
   h-sp
 
15 - 28.11.17 - 08:00
(14) а зачем в толстом клиенте работаешь? Работай в тонком.
   Рэйв
 
16 - 28.11.17 - 08:01
(14)Тогда с клиента они у тебя не видны. А толстый работает на клиенте
   LordCMEPTb
 
17 - 28.11.17 - 08:18
Еще не предлагали текст модуля менеджера и модуля объекта обрамить инструкциями препроцессора "#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
#КонецЕсли"?
   Рэйв
 
18 - 28.11.17 - 08:31
(17)Тут дело имхо не в этом. Они ему нужны всегда работающими.
Но в  толстом весь код работает на клиенте не зависимо от &НаСервере. А у него не видно модулей, потому что они только для сервера.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует