Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

1C 8.3.10 сервер х64 + Платформа х 32 + апач (x86, x64)

1C 8.3.10 сервер х64 + Платформа х 32 + апач (x86, x64)
Я
   Demasiado
 
25.11.17 - 11:33
Добрый день, коллеги

Есть сервер win2008r2, на него установлен Сервер 1с х64, веб расширение также установлено х64 и клиент х32, апач  2.4. При попытке опубликовать базу в вебе из-под конфигуратора, конфигуратор пишет - не обнаружено установленное веб расширение. Ставим веб расширение от х32 платформы - не стартует апач. Заходим в файл в папку апача, находим конфигурационный файл, исправляем путь к wsrapi22.dll - апач стартует, база опубликована. Но при попытке зайти из-под браузера видим только заставку, авторизацию не выдает. В чем может быть проблема? Вроде как проблема возникает из-за разницы в разрядности серверов или забить на все и поставить и сервер 1с и клиент 1с и апач 64-разрядные?
 
 
   Demasiado
 
1 - 25.11.17 - 11:37
Апач пробовали и х32 и х64, результат один и тот же. Сам апач работает (видим по приветствию), 1с показывает только заставку
   nordbox
 
2 - 25.11.17 - 11:44
На сервак не ставил, но  у себя на буке на Win 10 x64 поставил апач 2.2 х32, платформа 8.3.10 х32 вроде проблем нет, балуюсь иногда ))
Но я ставил апач именно с инсталяшки, а не тупым копированием папки с апачем и правкой файлов, взлетел с пол пинка.
   Demasiado
 
3 - 25.11.17 - 11:50
Апач везде ставили с инсталятора, сколько 32х битных серверов не поднимал (или просто платформ, если база файловая) - никакого гемора, а здесь - Оп и уперлись, и непонятно где ковырять. Журнал регистрации 1с пустой
   nordbox
 
4 - 25.11.17 - 11:57
Так наверное не ЖР 1с смотреть надо.
Кстати ты права выдал правильно?
   nordbox
 
5 - 25.11.17 - 12:02
LocalService
   Demasiado
 
6 - 25.11.17 - 12:19
(4) даже запускал службу из под учетки администратора, ЖР тоже смотрят. Вдруг в нем грабля
   Юрий Лазаренко
 
7 - 25.11.17 - 12:20
(0) Апач однозначно надо ставить 64, он значительно быстрее работает, хотя и под 32 работать будет.
(2) Разницы между инсталляшкой и тупым копированием нет, разве что после копирования надо прописать пути в httpd.conf и проинсталлить службу одной командой.
   Юрий Лазаренко
 
8 - 25.11.17 - 12:22
(0) В тонком клиенте через Апач тоже виснет? Разные браузеры пробовал?
   nordbox
 
9 - 25.11.17 - 12:29
(7) ну про правку я ему говорил
   Demasiado
 
10 - 25.11.17 - 12:31
Браузеры разные пробовал, сейчас еще раз запустил службу от администратора. Через тонкий клиент пустило, веб браузер ругнулся на лицензию "Не найдена лицензия. Не обнаружен ключ программы бла бла бла"
 
 Рекламное место пустует
   Юрий Лазаренко
 
11 - 25.11.17 - 13:45
(10) А флажок "разрешить выдачу лицензий сервером 1С Предприятия" установлен? А то тонкий клиент может тащит лицензию по локалке, а браузер-то этого не умеет.
   Demasiado
 
12 - 25.11.17 - 13:50
(11) Сейчас проверю, но вроде стоял. По крайней мере тонкий не в сессии РДП запускается, а совсем удаленно, с другого компа, который совсем не в сети. Подозреваю этот что то хостер VDS натупил, отправили пьсмо в саппорт
   Demasiado
 
13 - 25.11.17 - 13:54
да, стоит раздавать лицензии сервером. Про этот флаг знаю)
   kittystark
 
14 - 25.11.17 - 18:04
если апач 2.4 х64 то в httpd.conf нужно вместо 22-ой dll 
прописать wsap24.dll из с:\Program files\ (!!!простой, НЕ из х86 !!!)
   kittystark
 
15 - 25.11.17 - 18:06
да, и с публикацией в диалоге может быть засада - апача 2.2 в системе уже нет, но он как-то остался и первый по умолчанию в списке, приходится руками перевыбирать 2.4
   Demasiado
 
16 - 25.11.17 - 20:09
(15) Это да, знаем
(14) вот это -нет, спасибо, будем пробовать
   Юрий Лазаренко
 
17 - 25.11.17 - 22:38
(14) Если прописать не тот, то апач не стартанет.
   Andreyyy
 
18 - 25.11.17 - 22:45
(0) Такая же проблема, грешу на обновление платформы 8.3.10.2650, у Вас какая версия ?
Помогает ненадолго чистка папки "C:\Program Files\1cv8\srvinfo\reg_1541"
   Andreyyy
 
19 - 25.11.17 - 22:48
+(18) Проблема с зависшей заставкой в любом браузере и отсутствием окна авторизации.
   Demasiado
 
20 - 25.11.17 - 22:53
у нас 2580
   Demasiado
 
21 - 26.11.17 - 16:52
Проблема решилась. Нетхасп.ини забросили в папку с установленной клиентской платформой, а где был сервер х64 - нет. Как только нетхасп.ини засунули везде - работа через браузер наладилась. Хотя странно, что до этого все работало, кроме веб клиента.
   Andreyyy
 
22 - 27.11.17 - 01:59
Аналогично, с ключом была проблема.
Интересно, что 8.3.10.2650 тупо висела с окном заставки, а помладше платформа выдавала что ключа нет.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует