Вход | Регистрация


поиск и сравнение значения УФ

поиск и сравнение значения УФ
Я
   gurni
 
24.11.17 - 13:57
Есть такая процедура

&НаКлиенте
Процедура ДанныеСотрудникиПриИзменении(Элемент)
    // Вставить содержимое обработчика.

    ТекТип = НайтиТип("000000003");
    Если Объект.ТипОплаты = ТекТип Тогда
            СтрокаТЧ = Элементы.Данные.ТекущиеДанные;
             СтрокаТЧ.Сумма = ПолучитьЗначениеРеквизитаНаСервере(СтрокаТЧ.Сотрудники,"Оклад");
        Иначе
            СтрокаТЧ = Элементы.Данные.ТекущиеДанные;
            СтрокаТЧ.Сумма = (ПолучитьЗначениеРеквизитаНаСервере(СтрокаТЧ.Сотрудники,"Оклад"))/2;
        
    КонецЕсли;
КонецПроцедуры

в ней обращаемся к функции
&НаСервере
Функция НайтиТип(ТипОпл)
   
    Перем ТипДляПоиска, СсылкаНайденногоТипа;
    ТипДляПоиска = Справочники.ТипОплаты;
    СсылкаНайденногоТипа = ТипДляПоиска.НайтиПоНаименованию(ТипОпл);
    Если СсылкаНайденногоТипа = ТипДляПоиска.ПустаяСсылка() Тогда
        Возврат "Тип не найден";
   Иначе
        Возврат СсылкаНайденногоТипа.Наименование;
    КонецЕсли;
   
КонецФункции; 
переменная ТекТип принимает значение "Отпускные" (именно в кавычках)
а Объект.ТипОплаты передает Отпускные (без кавычек)
и выходит при сравнении они не равны(((
в чем моя ошибка? подскажите плиз
 
 
   Lexey_
 
1 - 24.11.17 - 14:08
(0) Возврат СсылкаНайденногоТипа.Наименование;
Так ты строку возвращаешь, чему удивляешься?
   gurni
 
2 - 24.11.17 - 14:18
(1) а как верно получить значение этого поля?
   Lexey_
 
3 - 24.11.17 - 14:19
(2) Возврат СсылкаНайденногоТип
   gurni
 
4 - 24.11.17 - 14:24
(3) спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует