Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Нужно подкрутить взаимодействие с весами LP15.

v7: Нужно подкрутить взаимодействие с весами LP15.
Я
   Gugolovski
 
24.11.17 - 04:21
1C 7.7 торговля склад
Нужно подкрутить взаимодействие с весами LP15:  
добавить в загрузку в весы текстовых сообщений (дополнительная информация о товаре).

Весы принимают 8 строк сообщений, по 50 символов каждая. Информация будет браться из справочника "номеклатура".

Сколько это стоит, можно на почту (в личной карточке присутствует)
 
 
   big
 
1 - 24.11.17 - 05:30
Весы сетевые или RS-232? В зависимости от этого будут варианты решения
   big
 
2 - 24.11.17 - 05:32
(1) + вот тут смотрел что и как?

http://cas.ru/3_produkt/software/Prog_obesp/
   Gugolovski
 
3 - 24.11.17 - 06:43
(1) сетевые. в настоящий момент подгружаются данные о: штрихкоде, плу, цена, срок_годности, наименование.

И в обработке выгрузки, которая сейчас работает, кажись есть возможность выгрузки сообщений. Но не соображу как она работает
   Gugolovski
 
4 - 24.11.17 - 07:05
Подскажите, как понять, куда отсылает программа. Вот, например, процедура:

//************************

Процедура ЗагрузитьТекстЭтикетки(РеклСтр1,РеклСтр2)
    Если ПустоеЗначение(Объект) = 1 Тогда
        Предупреждение("Неудачная попытка обращения к драйверу весов");   
        Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
            Форма.Параметр.Установить("Результат",0);
        КонецЕсли;
        Возврат;
    КонецЕсли;    
    
    СтрПодключения = СформироватьСтрокуПодключения();
    
    Если ПустоеЗначение(СтрПодключения) = 1 Тогда
        ВывестиСообщение("Не удалось сформирвать строку подключения весов!"); 
        Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
            Форма.Параметр.Установить("Результат",0);
        КонецЕсли;
        Возврат;
    КонецЕсли;
    
    КодОшибки = Объект.Подключить(СокрЛП(СтрПодключения ));
    Если КодОшибки <> 0 Тогда
        ВывестиСообщение("Ошибка установления связи с весами N"+Весы.Код+Объект.ТекстОшибки(КодОшибки));
        Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
            Форма.Параметр.Установить("Результат",0);
        КонецЕсли;
        Объект.СбросОшибки();
        Возврат;
    КонецЕсли;     
    смв = симв(1);  
    СтрокиРекламнойИнформации = РеклСтр1+смв+РеклСтр2; 

    
    КодОшибки = Объект.ПередатьТекстЭтик(СтрокиРекламнойИнформации);
    
    Если КодОшибки <> 0 Тогда    
        Сообщить("Рекламная информация для этикетки не загружена");
        ВывестиСообщение("Ошибка (весы N"+Строка(Весы.Код)+"): "+Объект.ТекстОшибки(КодОшибки));
        Объект.СбросОшибки();  
    Иначе
        Сообщить("Рекламная информация для этикетки загружена");
    КонецЕсли; 
    
    КодОшибки = Объект.Отключить();
    Если КодОшибки <> 0 Тогда
        ВывестиСообщение("Ошибка разрыва связи с весами N"+Весы.Код+Объект.ТекстОшибки(КодОшибки)); 
        Объект.СбросОшибки();
    КонецЕсли; 
КонецПроцедуры// ЗагрузитьТекстЭтикетки     


//************************


Загрузка данных на весы инициализируется строкой: "Объект.ПередатьТекстЭтик(СтрокиРекламнойИнформации);"

Объект, СтрокиРекламнойИнформации - это переменные.
А как понять что такое: "ПередатьТекстЭтик". Никаких объяснений в этой обработке нет. Включаю поиск по конфигурации там только одно упоминание этой фразы - в этой процедуре.
   big
 
5 - 24.11.17 - 07:45
ПередатьТекстЭтик() - это метод объекта Объект.

Надо увидеть как иницируется Объект, что за библиотека (драйвер) используется.

Надо узнать о свойствах и методах драйвера
   Gugolovski
 
6 - 24.11.17 - 07:51
(5)
...Если ЗагрузитьВнешнююКомпоненту("CASV16.dll") <> 0 Тогда            Объект    = СоздатьОбъект("AddIn.CASLPv16");..

а где подобная информация берется, гуглится, или есть описатель методов в 1С?
   big
 
7 - 24.11.17 - 08:02
По этой компоненте надо информацию искать. Или же на базе другой обмен делать
   Сияющий в темноте
 
8 - 24.11.17 - 10:16
текст этикетки это не сообщения
сообщения отдельным методом пишутся в таблицу
а товару просто назначаются уже записанные сообщения
пишите в почту-помогу
   Gugolovski
 
9 - 27.11.17 - 06:45
"текст этикетки это не сообщения " - это понятно. "ПередатьТекстЭтик" у нас реализовано, привел как пример.А с почтой вашей непонятно - скрыта))
   Gugolovski
 
10 - 27.11.17 - 09:09
(7) Нашлась информация. В при установке драйверов к весам, устанавливался и описатель к CASV16.dll. При его помощи удалось выгрузить первое сообщение, ура! Спасибо
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует