Вход | Регистрация

1С:Предприятие ::

Метки: 

Как проверить у объекта наличие подписок на событие?

Я
   Hipocrisy2013
 
23.11.17 - 13:12
Как проверить у объекта наличие подписок на событие?
 
  Рекламное место пустует
   azt-yur
 
1 - 23.11.17 - 13:14
(0) Правой кнопкой на объекте и Поиск ссылок на объект
   DTX 4th
 
2 - 27.11.17 - 13:14
(1) Плюс надо как-то найти подписки, у которых в источнике указан ДокументОбъект.
   GenAcid
 
3 - 27.11.17 - 13:18
Я так ищу:

Функция ПолучитьСписокПодписок(ТипОбъектаБД)
    
    мПодписок = новый Массив;
    
    Для Каждого Подписка Из Метаданные.ПодпискиНаСобытия Цикл
        ИмяОбъектаМетаданных = Метаданные.НайтиПоТипу(ТипОбъектаБД.типы()[0]).ПолноеИмя();

         ИмяТипа = СтрЗаменить(ИмяОбъектаМетаданных,".","Объект.");

         Если Подписка.Источник.СодержитТип(Тип(ИмяТипа)) Тогда
            
            мПодписок.Добавить(Подписка.Имя);     
            
         КонецЕсли;
    КонецЦикла;
        
    Возврат мПодписок;    
    
КонецФункции


Список тем форума
  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует