Вход | Регистрация

1С:Предприятие ::

Метки: 

Не изменять наименование справочника в приемнике по условию

Я
   Vladislava-smile
 
23.11.17 - 10:15
Можно думаю написать так:
Если Объект.Код = "000000001" тогда 
    
    Объект.Наименование = "GS основной склад";
    
КонецЕсли;    

в ПКО, но может есть способ проще?
 
 
   Ёпрст
 
1 - 23.11.17 - 10:18
(0) есть . в свойствах Наименования воткнуть галку - не изменять свойство у существующих  бла бла бла
   Ёпрст
 
2 - 23.11.17 - 10:19
если по-условию, то в передвыгрузкой в наименовании поставить отказ = истина
   Ёпрст
 
3 - 23.11.17 - 10:20
чтоб свойство вообще не выгружалосб, главное, чтоб это поле не участвовало в поиске по реквизитам
   Vladislava-smile
 
4 - 23.11.17 - 10:23
(2) Нужно только с условием по одному коду справочника. А как из ПКС Наменования получить Код?
Или проверять только на сравнение Наименований?
   Vladislava-smile
 
5 - 23.11.17 - 10:24
То есть в ПКС Наименования:
Если Источник = "бла-бла" тогда 
    
    Отказ = Истина;
    
КонецЕсли; 
Так?
   Ёпрст
 
6 - 23.11.17 - 10:24
(5)
Если Источник.Код = ... Тогда
  Отказ = Истина;
КонецЕсли;
   Ёпрст
 
7 - 23.11.17 - 10:25
надеюсь, галки поиск на наименовании у тя нет :)
   Vladislava-smile
 
8 - 23.11.17 - 10:27
(7) Нее, спасибо )
   Vladislava-smile
 
9 - 23.11.17 - 11:51
А еще вопрос по документу:

Надо выгружать только доки с определенным контраегнтом. Пишем в ПКО реализацииТиУ перед выгрузкой:
Если Источник.Контрагент <> "ЦНТ010086" тогда 
    
    Отказ = Истина;
    
КонецЕсли;    

Так должно работать? чет не пашет у меня просто ...
   Ёпрст
 
10 - 23.11.17 - 11:52
(9) контрагент - не строка :)
 
 Рекламное место пустует
   Ёпрст
 
11 - 23.11.17 - 11:53
в худшем случае, так:
Если Источник.Контрагент.Код <> "ЦНТ010086"
   Vladislava-smile
 
12 - 23.11.17 - 11:53
блин, точно, а источник. или объект.?
   Ёпрст
 
13 - 23.11.17 - 12:09
(12) в ПередВыгрузкой  - Источник


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует