Вход | Регистрация

  1  2   
1С:Предприятие ::

Метки: 

Конвертация данных. Набор движений регистра бухгалтерии.

Я
   razbiralshik
 
22.11.17 - 12:21
Переношу проводки с самописного документа (точнее с хозрасчетного регистра бухгалтерии с регистратором = самописному документу) в УПП в ОперацияУпр.

В ПВД написл запрос, код, в конце ВыгрузитьПоПравилу(,, ВходящиеДанные,, "ОперацияУпр");        

Теперь в ПКО "ОперацияУпр" без источника с ПКС где галки "получить из входящих данных" хочу добавить както группу полей для источника с типом приемника "Набор движений регистра бухгалтерии" куда и будут писаться проводки, но как го выбрать? Как его добавить в конфигурация КД чтобы его выбрать? т.к. у меня в свойства ОперацияУпр его в свойства нет, есть только реквизиты шапки и все. В примерах вижу в инете что люди так переносят и у них есть группа свойств "Хозрастчетный", а у меня нет. Подскажите пожалуйста.
 
 
   Ёпрст
 
1 - 22.11.17 - 12:22
(0) изначально, при выгрузке структуры своей базы, нужно было правильно расставлять галочки
   Ёпрст
 
2 - 22.11.17 - 12:23
выгрузи по-новой и обнови структуру в КД.
И усё будет
   Ёпрст
 
3 - 22.11.17 - 12:24
ну и выгрузить по-правилу там не нужно.
Нужно всего лишь сделать ПКО свой самописный документ - ОперацияУпр с пкгс Хозрасчетный.
Усё
   razbiralshik
 
4 - 22.11.17 - 12:49
(1) Какую галку то снять? "не выгружать регистры бухгалтерии"? ее я снял в обоих конфах и перегрузил, но не появилось того что я хочу.
   Ёпрст
 
5 - 22.11.17 - 12:52
(4) да. Потом в синхронизации свойств будет твой регистр бухгалтерии
   razbiralshik
 
6 - 22.11.17 - 12:54
(5) Сделал же так, не появился регистр в свойствах
   razbiralshik
 
7 - 22.11.17 - 13:29
ап!
кто подскажет?
   Ёпрст
 
8 - 22.11.17 - 13:30
(6) закрой обработку выгрузки метаданных и кд, и сделай по-новой. Всё там будет.
   razbiralshik
 
9 - 22.11.17 - 13:56
(8) да уже 3 раза так сделал и ничего...
   Ёпрст
 
10 - 22.11.17 - 13:57
загрузи в новую базу, тоже нет ?
 
 Рекламное место пустует
   Franchiser
 
11 - 22.11.17 - 14:04
Сделай автосинхронизацию свойств
   razbiralshik
 
12 - 22.11.17 - 15:25
(10) развернул новую базу, загрузил ЦФ КД, создал в ней конфигурации из описании той что мне нужна (выгрузил без флажка "не выгружать регистры бухгалтерии"), загрузил и тоже нет там в документе Операция регистра бухгалтерии...
   razbiralshik
 
13 - 22.11.17 - 15:27
Может быть все таки как-то по другому создается этот "Набор движений регистра бухгалтерии" у документов?
http://expert.chistov.pro/upload/iblock/077/333.png
   Ёпрст
 
14 - 22.11.17 - 15:39
(13) ?
у тя на картинке уже есть ПКГС Хозрасчетный, что тебя не устраивает ?!
   razbiralshik
 
15 - 22.11.17 - 15:40
(14) не у меня, а у когто из инета, я нашел картинку показать что же это такое, может быть вы о другом четомто думаете
   Ёпрст
 
16 - 22.11.17 - 15:44
(15) Когда нажимаешь на синхронизацию свойств, там нет разве у тебя Хозрасчетный ?
Мот ты там на кнопарь нажал - не показывать наборы движений
   razbiralshik
 
17 - 22.11.17 - 15:49
(16) Нету.

http://s019.radikal.ru/i603/1711/b2/b011f06a1971t.jpg

Вот скриншот
   razbiralshik
 
18 - 22.11.17 - 15:52
Вот еще: http://i013.radikal.ru/1711/e1/a6c9c4e58d52t.jpg

развернул свойства
   Ёпрст
 
19 - 22.11.17 - 15:54
кнопарь "не показывать наборы движений" понажимай, появилась ?
   Ёпрст
 
20 - 22.11.17 - 15:55
ну или заново выгрузи описание конфы. Все галки там поснимай, чтоб вообще ВСЁ выгружалось.
   razbiralshik
 
21 - 22.11.17 - 15:55
(19) да, посмотри (18)
   razbiralshik
 
22 - 22.11.17 - 15:56
(20) все мне не нужно, должно куча документов переносится без проводок.
   Ёпрст
 
23 - 22.11.17 - 15:56
   Ёпрст
 
24 - 22.11.17 - 15:57
(22) И че ?
Описание конфы выгрузи полностью!
   Ёпрст
 
25 - 22.11.17 - 15:57
потом в синхронизации не нужные тч с движениями не ставь
Или отключи правило.
   razbiralshik
 
26 - 22.11.17 - 16:15
(24) Выгрузил, загрузил, появилось, видимо это движения документов все таки.
   Ёпрст
 
27 - 22.11.17 - 16:18
(26) так и есть, А ты как хотел ?
   razbiralshik
 
28 - 22.11.17 - 16:19
(25) понятно, спасибо, попробую
   razbiralshik
 
29 - 23.11.17 - 08:58
(3) Этот вариант не прокатывает, т.к. документы имеют очень разную структуру и только запросов можно получить нужные данные, но если делать запросом то не будет источника.
Соответственно данные нужно гдето както прописать, чтобы при выгрузке был документ уже, т.к. щас не выгружается:


Начало выгрузки:   23.11.2017 8:57:39

Ошибка получения свойства объекта из входящих данных 
    ПКО                    =  ОперацияУпр  (ДокументСсылка.ОперацияУпр)
    ПКС                    =  1  (--> Дата)
    Объект                 =    (Не определено)
    СвойствоПриемника      =  Дата  (Дата)
    ОписаниеОшибки         =  Поле объекта не обнаружено (Дата)
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML(8211)
    КодСообщения           =  68

Ошибка в обработчике события ПередОбработкойПравилаВыгрузки
    ПВД                    =  ОперацияУпр
    Обработчик             =  ПередОбработкойВыгрузкиДанных
    ОписаниеОшибки         =  Ошибка получения свойства объекта из входящих данных 
    ПКО                    =  ОперацияУпр  (ДокументСсылка.ОперацияУпр)
    ПКС                    =  1  (--> Дата)
    Объект                 =    (Не определено)
    СвойствоПриемника      =  Дата  (Дата)
    ОписаниеОшибки         =  Поле объекта не обнаружено (Дата)
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML(8211)
    КодСообщения           =  68
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML(1618)
    КодСообщения           =  31

Ошибка при выгрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML(1637)}: Ошибка в обработчике события ПередОбработкойПравилаВыгрузки
    ПВД                    =  ОперацияУпр
    Обработчик             =  ПередОбработкойВыгрузкиДанных
    ОписаниеОшибки         =  Ошибка получения свойства объекта из входящих данных 
    ПКО                    =  ОперацияУпр  (ДокументСсылка.ОперацияУпр)
    ПКС                    =  1  (--> Дата)
    Объект                 =    (Не определено)
    СвойствоПриемника      =  Дата  (Дата)
    ОписаниеОшибки         =  Поле объекта не обнаружено (Дата)
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML(8211)
    КодСообщения           =  68
    ПозицияМодуля          =  ВнешняяОбработка.УниверсальныйОбменДаннымиXML(1618)
    КодСообщения           =  31
   Ёпрст
 
30 - 23.11.17 - 09:12
(29) ?
Какая разница, что разная структура ?
И источник у тебя всегда есть - это сам документ со своими проводками.
Правила то настрой.
   razbiralshik
 
31 - 23.11.17 - 09:24
   Ёпрст
 
32 - 23.11.17 - 09:32
(31) слишком крупно, может, поменьше скриншот сделаешь ?
   Ёпрст
 
33 - 23.11.17 - 09:33
(31) какую ошибку то хоть ?
И это, планы счетов хоть сопоставил, для начала ?
 
 
   Ёпрст
 
34 - 23.11.17 - 09:35
+ если планы счетов в части какого-либо счета имеют разное количество субконто, например, то после загрузки нужно очищать такие субконто
   Ёпрст
 
35 - 23.11.17 - 09:39
Так, например:

в ПКО ОперацияУпр в ПослеЗагрузки пишешь
ПараметрыАлгоритмов = Новый Структура;
ПараметрыАлгоритмов.Вставить("Объект",Объект);
Выполнить(Алгоритмы.УдалитьЛишниеВидыСубконтоИзПроводок);

в самом алгоритме, параметры - ПараметрыАлгоритмов  и текст:

КоллекцияДвижений = ПараметрыАлгоритмов.Объект.Движения.Найти("Управленческий");
Если  КоллекцияДвижений <> Неопределено Тогда
    Для каждого Корреспонденция ИЗ КоллекцияДвижений Цикл
        Для каждого Субконто ИЗ Корреспонденция.СубконтоДт Цикл
            НайденоСубконто = Ложь;
            Для каждого ВидыСубконто ИЗ  Корреспонденция.СчетДт.ВидыСубконто Цикл
                Если ВидыСубконто.ВидСубконто = Субконто.Ключ Тогда
                     НайденоСубконто = Истина;
                     Прервать;
                 КонецЕсли;
             КонецЦикла;
             Если Не НайденоСубконто Тогда
                 Корреспонденция.СубконтоДт.Удалить(Субконто.Ключ);
             Конецесли;
        КонецЦикла;     
        Для каждого Субконто ИЗ Корреспонденция.СубконтоКт Цикл
            НайденоСубконто = Ложь;
            Для каждого ВидыСубконто ИЗ  Корреспонденция.СчетКт.ВидыСубконто Цикл
                Если ВидыСубконто.ВидСубконто = Субконто.Ключ Тогда
                     НайденоСубконто = Истина;
                     Прервать;
                 КонецЕсли;
             КонецЦикла;
             Если Не НайденоСубконто Тогда
                 Корреспонденция.СубконтоКт.Удалить(Субконто.Ключ);
             Конецесли;
        КонецЦикла;     
    КонецЦикла;
КонецЕсли;
   razbiralshik
 
36 - 23.11.17 - 09:49
(33) Счета сопоставил.
Теперь не ошибку выдает, а выгружает 0.
Причем не дает сделать отбор по документу для выгрузки конкретного документа, что очень странно.
   razbiralshik
 
37 - 23.11.17 - 09:57
   Ёпрст
 
38 - 23.11.17 - 10:02
   Ёпрст
 
39 - 23.11.17 - 10:02
и не надо тэги от картинок вставлять вообще
   Ёпрст
 
40 - 23.11.17 - 10:04
(36) пвд есть от этого документа ?
Там стоит что ? СтандартнаяВыборка, или что ?
   razbiralshik
 
41 - 23.11.17 - 10:12
(40) ПВД я полностью убрал как ты написал
   Ёпрст
 
42 - 23.11.17 - 10:13
(41) круто. Каким образом ты теперь этот вид документа выгружаешь ? :)
   Ёпрст
 
43 - 23.11.17 - 10:14
добавь документ в пвд.
Перезагрузи правила в обработке выгрузки - появится твой вид документа, там ставь фильтр на один док и выгружай.
   Ёпрст
 
44 - 23.11.17 - 10:15
в ПВД всё типовое - т.е нет никаких обработчиков и СтандартнаяВыборка.
   razbiralshik
 
45 - 23.11.17 - 10:28
(44) Лед стронулся, документ с проводками перенесся, теперь надо с субконто разобраться, они не перенеслись почему-то.
В ПКС к ним я указал: ИмяПКОВидСубконто = "ВидыСубконтоХозрасчетные";
ПВХ у меня настроены и есть и в ПВД и в ПКО.
   Ёпрст
 
46 - 23.11.17 - 10:33
(45) картинку покажи, че делаешь хоть
   razbiralshik
 
47 - 23.11.17 - 10:35
Попытался добавить твой алгортм, перестало загружаться:


Начало загрузки:   23.11.2017 10:34:18
Ошибка в обработчике события ПослеЗагрузкиОбъекта
    ИмяПКО                 =  ОперацияУпр
    ТипОбъекта             =  Операция (управленческий учет)
    Объект                 =  Операция (управленческий учет) AT000722 от 01.11.2017 12:00:00
    Обработчик             =  ПослеЗагрузкиОбъекта
    ОписаниеОшибки         =  Поле объекта не обнаружено (УдалитьЛишниеВидыСубконтоИзПроводок)
    ПозицияМодуля          =  (16)
    КодСообщения           =  21

Ошибка при загрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1566)}: Ошибка в обработчике события ПослеЗагрузкиОбъекта
    ИмяПКО                 =  ОперацияУпр
    ТипОбъекта             =  Операция (управленческий учет)
    Объект                 =  Операция (управленческий учет) AT000722 от 01.11.2017 12:00:00
    Обработчик             =  ПослеЗагрузкиОбъекта
    ОписаниеОшибки         =  Поле объекта не обнаружено (УдалитьЛишниеВидыСубконтоИзПроводок)
    ПозицияМодуля          =  (16)
    КодСообщения           =  21

Окончание загрузки: 23.11.2017 10:34:28

Загружено объектов: 120
   razbiralshik
 
48 - 23.11.17 - 10:39
   Ёпрст
 
49 - 23.11.17 - 10:48
(48) переложи картинки сюда
http://znimg.ru/
 
 Рекламное место пустует
   razbiralshik
 
50 - 23.11.17 - 10:50
   Ёпрст
 
51 - 23.11.17 - 11:03
(50) а чего в выдысубконто, нет наименования ?
А конвертация значений там заполнена ?
   Ёпрст
 
52 - 23.11.17 - 11:06
ну и нафига у пкс СубконтоДт писать так ?
ИмяПКОВидСубконто = ....
выкинь этот екод оттуда совсем
   razbiralshik
 
53 - 23.11.17 - 11:17
(52) убрал "ИмяПКОВидСубконто = .... " еще убрал алгоритм
все равно при загрузке вот это:

Начало загрузки:   23.11.2017 11:15:23
В проводке по дебету 3 по счету 20 не заполнены субконто: статья затрат, или проект, или подразделение, или регион

Конвертация значений есть: http://s24.znimg.ru/1511424780/1318axchfz.png
   Ёпрст
 
54 - 23.11.17 - 11:19
(53) очень хорошо.
ПКО для справочников статьиЗатрат, Проект, Регион - есть ?
   razbiralshik
 
55 - 23.11.17 - 11:25
(54) СтатьиЗатрат есть, а в базе источник нет таких справочников как "регион" и "проект", есть "ПодразделениеОрганизации".
   Ёпрст
 
56 - 23.11.17 - 11:26
(55) что ты тогда хочешь увидеть в значениях этих субконто ?
:)
   Ёпрст
 
57 - 23.11.17 - 11:26
вот что есть, то и конвертируй.
   Ёпрст
 
58 - 23.11.17 - 11:27
для начала, хотя бы СтатьиЗатрат и Подразделения чтоб переносились.
   Ёпрст
 
59 - 23.11.17 - 11:27
потом уже думать, нужны ли тебе субконто проект и регион в проводках.
   razbiralshik
 
60 - 23.11.17 - 11:29
(56) в составе источника субконто нет ни региона, ни проекта.
в составе приемника субконто есть регион, и проект.
В субконто тех проводок что я переношу нет ни проекта, ни региона соответственно.
Создать на регион и проект новые ПКо без источника?
   razbiralshik
 
61 - 23.11.17 - 11:45
В проводках есть все что нужно: контрагенты, договора, номенклатуры, по ним всем есть ПКО.
Почему они не переносятся то и ошибка эта лезет?
   Ёпрст
 
62 - 23.11.17 - 11:51
Можешь проверять тип источника и в зависимости от этого подсовывать разные знаяения
   razbiralshik
 
63 - 23.11.17 - 12:09
(62) Где именно это делается?
   Ёпрст
 
64 - 23.11.17 - 12:12
(63) можешь прям в самом ПКС СубконтоДт/СубконтоКт
   razbiralshik
 
65 - 23.11.17 - 12:53
(64) Попробовал написать хотя бы так:

Сообщить(Субконто);
Если ТипЗнч(Субконто) = Тип("СправочникСсылка.Контрагенты")  Тогда 
    ИмяПко = "Контрагенты";
КонецЕсли;


Но даже Контрагенты не заполнились...
   Ёпрст
 
66 - 23.11.17 - 12:54
(65) контрагенты сами по себе хоть летят из базы в базу ?
   Ёпрст
 
67 - 23.11.17 - 12:56
+ нужный счет в источнике и приёмнике имеет одинаковое количество субконто ? Они находятся в том же порядке ?
   Ёпрст
 
68 - 23.11.17 - 12:57
ну и для субконтоДт нужно пользовать ИмяПКОВидСубконто
   Ёпрст
 
69 - 23.11.17 - 13:00
тут еще почитай
http://catalog.mista.ru/public/120035/
   razbiralshik
 
70 - 23.11.17 - 13:09
(66) Да, летят.
например счет источника 62.1 имеет 3 субконто.
счет приемника 62 имеет 2 субконто.
Количество субконто разное если смотреть сам счет, а в проводки источника заполняется всего 2 субконто и их оба нужно переносить.
Тоже самое 76.7 - 76.03.
ИмяПКОВидСубконто это использовал как и той ссылке что ты кинул: ИмяПКОВидСубконто = "ВидыСубконтоХозрасчетные";
   Ёпрст
 
71 - 23.11.17 - 13:12
(70) стоп. у тя 62.1 никогда не полетит в 62, если ты только спецом это не указал где-то
   Ёпрст
 
72 - 23.11.17 - 13:12
как ты сам план счетов сопоставил ?
   Ёпрст
 
73 - 23.11.17 - 13:13
там у тя есть, что 62.1 в 62 прилетит ?
   razbiralshik
 
74 - 23.11.17 - 13:38
(73) да, все верно
   Ёпрст
 
75 - 23.11.17 - 13:41
(74) номер субконто совпадает ?
ну, субконто клиентос, например первое в источнике, в приёмнике оно тоже первое у тебя ?
Само пко для клиентосов есть ?
Клиентосы сами по себе летят ?
Если да, то всё и так должно переносится без всяких бубнов.
   Ёпрст
 
76 - 23.11.17 - 13:42
+ какой обработкой переносишь хоть ?
Просто универсальноы xml, или через план обмена и встроенной в конфу обработкой переноса ?
   razbiralshik
 
77 - 23.11.17 - 13:48
Смотри, в связке 62.1 - 62 и 76.7 - 76.03. у всех них субконто1 - контрагент, субконто2 - договор.

А вот ту поинетресней:
Счет 20 в счет 44.
Счет 20: субконто1 - Подразделения, Субконто2 - Номенклатурные группы, Субконто3 - Статьи затрат.
Счет 44: субконто1 - Статьи затрат, Субконто2 - Проекты, Субконто3 - Подразделения, Субконто4 - Регионы.
   razbiralshik
 
78 - 23.11.17 - 13:49
выгружаю и загружай обработкой: универсальный обмен данными xml.
ни для одного счета ни одной проводки ни один субконто не проставляется.
другие документы без проводок переношу там и контрагенты и их договора переносятся нормально. проблема только тут в субконто проводок.
   Ёпрст
 
79 - 23.11.17 - 13:55
для начала, создать ПВД для плана счетов и сделать так, чтоб он переносился без ошибок.
   razbiralshik
 
80 - 23.11.17 - 14:00
(79) есть такой, счета все переносятся верно
   Ёпрст
 
81 - 23.11.17 - 14:10
Ну, тогда толькорежим отладки включать и смотреть, что  в выгруженных данных.
Сами проводки вообще не появляются ? Или появляются, но с пустыми субконто ?
   razbiralshik
 
82 - 23.11.17 - 14:10
(81) появляются с пустыми субконто, только в них дело осталось...
   razbiralshik
 
83 - 23.11.17 - 14:13
я же поставил сообщить, и там видно что все субконто выгружаются, но не загружаются ))
   Ёпрст
 
84 - 23.11.17 - 14:17
если не згружаются, то  нет необходимого пко для загрузки, или у тя еще чего в настройках свойства стоит
   Ёпрст
 
85 - 23.11.17 - 14:18
нет ли галки - не замещать свойства бла-бла бла..
или в самом пко в настройках - поиск по св-мам бла-бла бла
   Ёпрст
 
86 - 23.11.17 - 14:18
?
   Ёпрст
 
87 - 23.11.17 - 14:19
и покажи картинку со свойствами хозрасчетный
   razbiralshik
 
88 - 23.11.17 - 15:23
(87) Вот вкладка планов счетов: http://s24.znimg.ru/1511439660/x9rutvpfis.png

Это ты имел ввиду?
   Ёпрст
 
89 - 23.11.17 - 15:32
(88) не, в документе, все свойства хозрасчетный.

ЗЫ: а чего планы счетов не создаешь, если  не найдены ?
:)
   Ёпрст
 
90 - 23.11.17 - 15:33
подумаешь, будет куча ручный счетов создано
   Ёпрст
 
91 - 23.11.17 - 15:33
ручных
   razbiralshik
 
92 - 23.11.17 - 15:59
(89) вот что есть: http://s26.znimg.ru/1511441880/ed4oapyixi.png

новые счета создавать нельзя (решения началсьтва)
   Ёпрст
 
94 - 23.11.17 - 16:04
(92) покажи все свойства набора движений хозрасчетный
   razbiralshik
 
95 - 23.11.17 - 16:11
(94) я не понимаю о чем ты (( я тебе могу сто скринов выложить но врятли это будет, можешь показать или подскать что где как
   Ёпрст
 
96 - 23.11.17 - 16:24
(95) ладно, выложи правила на посмотреть
   Ёпрст
 
97 - 23.11.17 - 16:24
и желательно, выгруженные метаданные обоих баз еще
   razbiralshik
 
98 - 23.11.17 - 16:36
(97) попробуй отсюда качнуть: http://dropmefiles.com/5c8vP
   Ёпрст
 
99 - 23.11.17 - 16:47
(98) для начала, выкинь код из послеЗагрузки в документе ОперацияУпр - не надо его еще раз перепроводить там.
   Ёпрст
 
100 - 23.11.17 - 16:47
он должен прилететь со своими движениями, а не создавать новые в новой базе!!!

  1  2   

Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует