Вход | Регистрация

1С:Предприятие ::

Метки: 

API APPLE GSX

Я
   business_sergey
 
21.11.17 - 18:17
привет всем.
кто нибудь сталкивался с api apple gsx это сервис ремонта
проблема собственно такая при открытии в веб странички выходит это:

<wsdl:definitions xmlns:tns="http://gsxws.apple.com/services/core/depot/am"; xmlns:http="http://schemas.xmlsoap.org/wsdl/http/"; xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"; xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"; xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"; xmlns:xs="http://www.w3.org/2001/XMLSchema"; xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"; xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"; xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy"; xmlns:wsoma="http://schemas.xmlsoap.org/ws/2004/09/policy/optimizedmimeserialization"; xmlns:global-rr="http://gsxws.apple.com/elements/global"; xmlns:core-rr="http://gsxws.apple.com/elements/core"; xmlns:depot-rr="http://gsxws.apple.com/elements/core/depot"; name="GsxWSAmDepotService" targetNamespace="http://gsxws.apple.com/services/core/depot/am">;
<wsdl:documentation>Release Date: 15-Feb-2016 06:00 PM Pacific</wsdl:documentation>
<!--  ///////// MTOM Policy Declaration: START  -->

<wsp:Policy wsu:Id="GlobalMTOMPolicy">
<wsp:ExactlyOne>
<wsp:All>
<wsoma:OptimizedMimeSerialization/>
</wsp:All>
</wsp:ExactlyOne>
</wsp:Policy>
<!--  ///////// MTOM Policy Declaration: END  -->
<!--  ///////// XSD Types Declaration: START  -->
<wsdl:types>
<xs:schema>
<xs:import namespace="http://gsxws.apple.com/elements/global"; schemaLocation="gsx-global-requestResponse-elements.xsd"/>
<xs:import namespace="http://gsxws.apple.com/elements/core"; schemaLocation="gsx-core-requestResponse-elements.xsd"/>
<xs:import namespace="http://gsxws.apple.com/elements/core/depot"; schemaLocation="gsx-coreDepot-requestResponse-elements.xsd"/>

</xs:schema>
</wsdl:types>
<!--  ///////// XSD Types Declaration: END  -->
<!--  ///////// Message Declarations: START  -->
<!--  Message 1: authenticate  -->
<wsdl:message name="authenticateRequestMessage">
<wsdl:documentation>Incoming message for "Authenticate" API</wsdl:documentation>
<wsdl:part name="parameters" element="global-rr:Authenticate"/>
</wsdl:message>
<wsdl:message name="authenticateResponseMessage">
<wsdl:documentation>Outgoing message for "Authenticate" API</wsdl:documentation>
<wsdl:part name="parameters" element="global-rr:AuthenticateResponse"/>

пытаюсь после этого из 1С получить доступ к методу авторизации
ssl3 = Новый ЗащищенноеСоединениеOpenSSL(
            Новый СертификатКлиентаWindows(),
            Новый СертификатыУдостоверяющихЦентровОС());

Прокси = WSСсылки.bs_gsx.СоздатьWSПрокси(
                                         "http://gsxws.apple.com/services/core/depot/am","GsxWSAmDepotService";, "GsxWSAmDepotPort",,,ssl3);    // Вставить содержимое обработчика.
//Получаем тип параметра, который передается в метод GetCursOnDate.
    ТипWSПараметра = Прокси.ФабрикаXDTO.Пакеты.Получить("http://gsxws.apple.com/elements/global").Получить("authenticateRequestWrapperType";);
    //Создаем параметр на основе типа и заполняем значение параметра On_Date.
    //    ТипWSПараметра.Проверить(Объект.userId);
    //Свойство = ТипWSПараметра.Свойства[0];
    //Для Каждого ДопСвойство из Свойство.Тип.Свойства Цикл
        
    //КонецЦикла;
    Для Каждого Ствойство1 из ТипWSПараметра.Свойства Цикл
        //ПодТип =    Прокси.ФабрикаXDTO.Пакеты.Получить("http://gsxws.apple.com/elements/global").Получить("AuthenticateRequest";);
         WSТип = Прокси.ФабрикаXDTO.Тип("http://gsxws.apple.com/elements/global","authenticateRequestType");//Ствойство1.Тип);
        WSПараметр = Прокси.ФабрикаXDTO.Создать(WSТип);
        Токен  = Прокси.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema","token";);
        Токен2 = Прокси.ФабрикаXDTO.Тип("http://gsxws.apple.com/types/basic","Token_2";);
        
        UserId                = Прокси.ФабрикаXDTO.Создать(Токен,Объект.userId);              
        ServiceAccountNo    = Прокси.ФабрикаXDTO.Создать(Токен,Объект.serviceAccountNo);
        languageCode        = Прокси.ФабрикаXDTO.Создать(Токен2,Объект.languageCode);
        userTimeZone        = Прокси.ФабрикаXDTO.Создать(Токен,Объект.userTimeZone);
    //Для Каждого Свойство из Ствойство1.Тип.Свойства Цикл
    //    Если Свойство.Имя = "userId" Тогда
    //WSПараметр = Прокси.ФабрикаXDTO.Создать(Токен);
    WSПараметр.userId             = UserId;//Прокси.ФабрикаXDTO.Создать(Токен,Объект.userId);
    //    ИначеЕсли Свойство.Имя     = "serviceAccountNo" Тогда
    WSПараметр.ServiceAccountNo = ServiceAccountNo;//Прокси.ФабрикаXDTO.Создать(Токен,Объект.ServiceAccountNo);
    //    ИначеЕсли Свойство.Имя     = "languageCode" Тогда
    WSПараметр.languageCode     = languageCode;//Прокси.ФабрикаXDTO.Создать(Токен2,Объект.languageCode);
    //    ИначеЕсли Свойство.Имя     = "userTimeZone" Тогда
    WSПараметр.userTimeZone     = userTimeZone;//Прокси.ФабрикаXDTO.Создать(Токен,Объект.userTimeZone);
    //    КонецЕсли;
    //КонецЦикла;
КонецЦикла;
WrapperType       = Прокси.ФабрикаXDTO.Создать(ТипWSПараметра);
WrapperType.AuthenticateRequest = WSПараметр;
WrapperType.Проверить();
    //WSПараметр.userId            = userId;
    //WSПараметр.ServiceAccountNo = Объект.serviceAccountNo;
    //WSПараметр.languageCode     = Объект.languageCode;
    //WSПараметр.userTimeZone        = Объект.userTimeZone;
//    WSПараметр.password            = Объект.password;
    
    //Вызываем метод веб-сервиса, записываем результат в переменную КурсыВалют.
    Попытка
    РезультатАвторизации = Прокси.Authenticate(WrapperType);
Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;

выдает ошибку
{ВнешняяОбработка.РаботаСGSX.Форма.Форма.Форма(55)}: Ошибка при вызове метода контекста (Authenticate): При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса:  {http://gsxws.apple.com/services/core/depot/am}:GsxWSAmDepotService:Authenticate(): При вызове веб-сервиса произошла ошибка. Ошибка SOAP сервера:  java.lang.NullPointerException
Код ошибки: Server
 
 
   Serginio1
 
1 - 21.11.17 - 18:50
Вроде не понимает 1с безопасностью на уровне SOAP сообщений (WS-Security),
https://www.techdays.ru/videos/1331.html
   business_sergey
 
2 - 21.11.17 - 19:31
(1) ну я читал про внесене всех данных сертификатов в спец файл в 1С я все сделал, пока веду диалоги с поддержкой яблочной посмотрим что там скажут
   Serginio1
 
3 - 22.11.17 - 11:37
Если, что можешь воспользоваться Использование классов .Net в 1С для новичков
   Serginio1
 
4 - 22.11.17 - 11:39
   Serginio1
 
5 - 22.11.17 - 11:44
   Serginio1
 
6 - 22.11.17 - 11:48


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует