Вход | Регистрация

1С:Предприятие ::

Метки: 

Чтение ексель файла в веб-клиенте.

Я
   antihacker
 
21.11.17 - 11:14
Всем привет !

Вот так пытаюсь прочитать файл ексель 

         #Если ВебКлиент Тогда 

+ Code
            Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
                    УстановитьРасширениеРаботыСФайлами();
                    ПодключитьРасширениеРаботыСФайлами();
            КонецЕсли;    
        #КонецЕсли



        СтандартнаяОбработка=ложь;      
        Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
        Диалог.Заголовок = "Выберите файл";
        Диалог.ПолноеИмяФайла = ""; 
        Фильтр = "* (*.*)|*.*"; 
        Диалог.Фильтр = Фильтр; 
        Диалог.МножественныйВыбор = Ложь;
        Диалог.Каталог = "E:\temp\";

    ЕСЛИ Диалог.Выбрать() ТОГДА

         ПутьКФайлу = СокрЛП(Диалог.ПолноеИмяФайла);
          
      //Импорт


       Док =  ПолучитьCOMОбъект(ПутьКФайлу);
       
       Для ДанныеНачинаютсяС = 2 по 10 Цикл
      // ФИОУчастника = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 1).Value;


      //Пока СокрЛП(ФИОУчастника) <> "" Цикл


          //  Добавление строки с файла в документ


          НоваяСтрока =  Объект.ТЧИсторияДанныхСотрудников.Добавить();
          НоваяСтрока.ФИОСотрудника =  Док.Sheets(1).Cells(ДанныеНачинаютсяС, 1).Value;
          НоваяСтрока.Образование = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 2).Value;
          НоваяСтрока.Категория = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 3).Value;
          НоваяСтрока.РНН = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 4).Value;
          НоваяСтрока.ИНН = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 5).Value;
          НоваяСтрока.МВЗ = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 6).Value;
          ДанныеНачинаютсяС = ДанныеНачинаютсяС + 1;
          //ФИОУчастника = Док.Sheets(1).Cells(ДанныеНачинаютсяС, 2).Value;


    //КонецЦикла;


 КонецЦикла;
 
 Сообщить("Импорт завершён");
      Док.Application.Quit();

КонецЦикла;   
 
         КонецЕсли;



Ругаеться на строку - "       Док =  ПолучитьCOMОбъект(ПутьКФайлу)" 

Ошибка -"com- объекты поддерживаются только в Microsoft Internet Explorer"

А ведь используемый браузер и есть IE. Он что слепой ?
 
 
   lodger
 
1 - 21.11.17 - 11:15
(0) ослики разных версий по разному поют.
   antihacker
 
2 - 21.11.17 - 11:22
Версия платформы.
1С:Предприятие 8.3 (8.3.9.1850)
   antihacker
 
3 - 21.11.17 - 12:00
Ни каких идеии ?
   1Сергей
 
4 - 21.11.17 - 12:01
(3) обнови ехплорер. Тебе же сказали в (1)
   john90
 
5 - 21.11.17 - 12:27
поместитьфайлвовременноехранилище
   Юрий Лазаренко
 
6 - 21.11.17 - 12:31
(0) Отправляй файл на сервер и читай там.
   mTema32
 
7 - 21.11.17 - 12:43
+(6)
И убирай "диалог". В веб-клиенте так работать с файлами некошерно. Используй ОписаниеОповещения.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует