Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Адрес контрагента

Адрес контрагента
Я
   ZADR
 
21.11.17 - 09:52
Здравствуйте,

1С:Предприятие 8.3 (8.3.10.2561)
Бухгалтерия для Казахстана, редакция 2.0, разработка для Казахстана: «1С-Рейтинг» (2.0.25.10)
Copyright (С) ООО "1C", 2007-2017. Все права защищены.
(http://www.1c.ru/)

Проблема вот в чем, во всех контрагентах не указаны юридические и фактические адреса.
Через "групповая обработка справочников и документов" не получается.

Подскажите какую нибудь обработку, что бы во всех контрагентах поставить "Республика Казахстан"
 
 
   YFedor
 
1 - 21.11.17 - 09:54
(0) А сам адрес не нужно заполнять?
   ZADR
 
2 - 21.11.17 - 09:55
(1) там очень много конрагентов, там каждому ставить адрес не вариант
   YFedor
 
3 - 21.11.17 - 10:00
(2) У всех будет один адрес "Республика Казахстан"
   ZADR
 
4 - 21.11.17 - 10:05
(2) да
   YFedor
 
5 - 21.11.17 - 10:06
(4) адрес это просто строка - написать обработку самому
   Рэйв
 
6 - 21.11.17 - 10:07
(0)Если на всех будет один адрес, то чем он логически отличается от пустого?
   ZADR
 
7 - 21.11.17 - 10:07
(6) на данный момент там ничего нет, пусто
   ZADR
 
8 - 21.11.17 - 10:08
(5) думал есть что то готовое и удобное
   Рэйв
 
9 - 21.11.17 - 10:08
(7)Вот я и говорю, что от того, что там у всех появится "Республика Казахстан" ничего принципиально не поменяется. Если вам не нужны конкретные адреса, так и не заполняйте их
   mehfk
 
10 - 21.11.17 - 10:10
"На деревню дедушке".
 
 Рекламное место пустует
   Ц_У
 
11 - 21.11.17 - 10:11
(10) главное что бы евойной мордой потом не начали в конфу тыкать :)
   ZADR
 
12 - 21.11.17 - 10:11
(9) там должно хоть что то быть, чтобы выгружать документ "электронные счет фактуры выданные"
   Рэйв
 
13 - 21.11.17 - 10:15
(12)Насколько я помню - это РС "КонтактнаяИнформация". Написать код заполнения на коленке - 5 минут
   ZADR
 
14 - 21.11.17 - 10:19
(13) помогите с кодом,

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
     
     выбрать12 = справочники.Контрагенты.Выбрать(Дата1, КонецДня(Дата2));
     Пока выбрать12.Следующий() Цикл
          документ1 = выбрать12.ПолучитьОбъект();        
          Для Каждого стр из документ1.ПолучитьФорму(ФормаЭлемента,,) цикл
              стр.Контактнаяинформация
              УправлениеКонтактнойИнформацией.
    
        
         
     КонецЦикла;
      
       документ1.Записать();
   ZADR
 
15 - 21.11.17 - 10:44
помогите с кодом
   1Сергей
 
16 - 21.11.17 - 10:55
(14) что за магические даты ты указываешь в следующей строке?

выбрать12 = справочники.Контрагенты.Выбрать(Дата1, КонецДня(Дата2));
   1Сергей
 
17 - 21.11.17 - 10:57
у меня есть обработка (сам написал), которая грузит адреса из XLS. но, не дам
   1Сергей
 
18 - 21.11.17 - 11:02
Может, поможет...

            НЗ = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
            НЗ.Отбор.Объект.Установить(СтрокаДанных.Ссылка);
            НЗ.Отбор.Тип.Установить(Перечисления.ТипыКонтактнойИнформации.Адрес);
            НЗ.Отбор.Вид.Установить(Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента);
            НЗ.Прочитать();
            
            ФлагУжеЕстьТакойАдрес = Ложь;
            Для Каждого Запись Из НЗ Цикл
                Если СокрЛП(Запись.Представление) = СокрЛП(СтрокаДанных.ФактическийАдрес) Тогда
                    ФлагУжеЕстьТакойАдрес = Истина;
                КонецЕсли;
            КонецЦикла;
            
            Если Не ФлагУжеЕстьТакойАдрес Тогда
                НЗ.Очистить();
                Запись = НЗ.Добавить();
                Запись.Объект = СтрокаДанных.Ссылка;
                Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
                Запись.Вид = Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента;
                Запись.Представление = СокрЛП(СтрокаДанных.ЮридическийАдрес);
                НЗ.Записать(Истина);
                Сообщить("Записан юр.адрес Контрагента [" + СтрокаДанных.Ссылка + "]");
            КонецЕсли;

   Has
 
19 - 21.11.17 - 11:47
с ИТС "загрузка данных из табличного документа" вроде в регистр сведений пишет

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует