Вход | Регистрация


обход строк дерева значений

обход строк дерева значений
Я
   Razzle Kay
 
21.11.17 - 07:19
Привет, обхожу Дерево
Для каждого Строка из ДеревоЗначений.Строки Цикл
..
...
....
КонецЦикла

в Строка попадает только 3 строки первого уровня, как перебрать всю иерархию ?
 
 
   shadow_sw
 
1 - 21.11.17 - 07:22
выборка как делается?
надо как то так
ДеревоЗначений = Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
   Razzle Kay
 
2 - 21.11.17 - 07:23
(1) да так и делается, в дерево то норм всё выводится, только вот перебирая в цикле строки, чтобы кое чё там умножать/складывать
попадает только верхний уровень
   shadow_sw
 
3 - 21.11.17 - 07:26
(2) в общем в запросе, его итогах проблема
   Mankubus
 
4 - 21.11.17 - 07:26
(2)
Для каждого СтрокаПервогоУровня из ДеревоЗначений.Строки Цикл 
Для Каждого СтрокаВторогоУровня Из СтрокаПервогоУровня.Строки Цикл

Для Каждого СтрокаТретьегоУровня Из СтрокаВторогоУровня.Строки Цикл

КонецЦикла;

КонецЦикла;
...
....
КонецЦикла
   Razzle Kay
 
5 - 21.11.17 - 07:29
(4) и как мне угадать скок урвоней ?
   Гипервизор
 
6 - 21.11.17 - 07:32
(5) Рекурсия вам в помощь.
   1Сергей
 
7 - 21.11.17 - 07:43
можно и без рекурсии
   Гипервизор
 
8 - 21.11.17 - 07:46
(7) Можно. Только мое сообщение содержит подсказку, а ваше чем поможет?
   Antony8x
 
9 - 21.11.17 - 07:48
(8) )
   Веселый собака
 
10 - 21.11.17 - 08:17
Строки.количество()
 
 Рекламное место пустует
   Razzle Kay
 
11 - 21.11.17 - 08:18
(10) ?)
   Веселый собака
 
12 - 21.11.17 - 08:20
А вообще, судя по всему, автор впервые дерево увидел. С ветками только из ствола.)

(11) как только станет = 0, значит дальше веток нет. И не будет.
   Razzle Kay
 
13 - 21.11.17 - 08:21
ну я и с 1с не так давно, а дерево да, 1ый раз

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует