Вход | Регистрация

1С:Предприятие ::

Метки: 

Помогите разобраться с изменением табличной части документа ПоступлениеТоваровУслуг

Я
   mrleo
 
20.11.17 - 13:29
Есть работающая обработка в 1С Предприниматель 8.3 редакция 2

    БазаПереброски = Новый XBase;
    ФайлБазыПереброски = Новый Файл(ФайлБазы);
    Если ФайлБазыПереброски.Существует()= Истина Тогда
        БазаПереброски.ОткрытьФайл(ФайлБазы,,Ложь);
        Если БазаПереброски.КоличествоЗаписей()>0 Тогда
            БазаПереброски.Первая();
            ДокДляПравки            = Документы.ПоступлениеТоваровУслуг.НайтиПоНомеру(БазаПереброски.NDOC,БазаПереброски.DDOC);
            ЗаполнитьТабЧастьДокумента=ДокДляПравки.ПолучитьФорму("Документ.ПоступлениеТоваровУслуг.Форма.ФормаДокумента");
            ЗаполнитьТабЧастьДокумента.Записать(РежимЗаписиДокумента.ОтменаПроведения);
            Для Каждого ТекущаяСтрока Из ЗаполнитьТабЧастьДокумента.Товары Цикл 
                ТекущаяСтрока.Цена = БазаПереброски.CENA;
                ТекущаяСтрока.Сумма = Окр(ТекущаяСтрока.Количество*ТекущаяСтрока.Цена,2);
                ТекущаяСтрока.СуммаНДС= Окр(ТекущаяСтрока.Сумма * 0.1/1.1,2);
                БазаПереброски.Следующая();
            КонецЦикла;
            БазаПереброски.ЗакрытьФайл();
               ЗаполнитьТабЧастьДокумента.Записать(РежимЗаписиДокумента.Проведение);
            //Сообщить("Изменены цены для документа ПОСТУПЛЕНИЕ ТОВАРОВ № "+УдалитьНули(ДокДляПравки.Номер)+" от "+Формат(ДокДляПравки.Дата,"ДЛФ=ДД"));

        КонецЕсли;
    Иначе
        //Предупреждение("DBF Файл для корректировки цен для ПОСТУПЛЕНИЯ ТОВАРОВ не найден!!!");

    КонецЕсли;

Но для редакции 3 выдается ошибка Интереактивные операции запрещены. Как подправить программу?
 
 
   Cyberhawk
 
1 - 20.11.17 - 13:33
"Как подправить программу?" // Прикласить программоправа


Список тем форума
Рекламное место пустует Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует