Вход | Регистрация

1С:Предприятие ::

Метки: 

Учет фактических отпусков в ЗУП 3

Я
   егаис
 
19.11.17 - 13:39
По какой причине не формируются движения по регистру "Фактические отпуска" в документе "Отпуск". Внедрили пока только подсистему кадрового учета с переносом остатков отпусков. Фактические отпуска не учитываются.
 
  Рекламное место пустует
   Amra
 
1 - 19.11.17 - 13:40
(0) ФО расчета зарплаты отключена?
   егаис
 
2 - 19.11.17 - 13:42
нет, просто пока вносятся данные только кадровиками. Расчетные данные не заполняются
   егаис
 
3 - 19.11.17 - 13:43
признак "расчет утвердил" выставляем программно.
   егаис
 
4 - 19.11.17 - 13:51
ясно, там привязка к таблице начислений в момент формирования движений
        Для Каждого СтрокаДанных Из Начисления Цикл
            Если Не ЗначениеЗаполнено(СтрокаДанных.ВидЕжегодногоОтпуска) Тогда
                Продолжить;
            КонецЕсли;
            Если НЕ СтрокаДанных.ИспользованиеПериода = ПредопределенноеЗначение("Перечисление.ВариантыИспользованияПериодаНачисления.НеИспользовать") Тогда
                Продолжить;
            КонецЕсли;
            Если ДатыНачалаКомпенсаций.Получить(СтрокаДанных.Сотрудник) <> Неопределено Тогда
                Продолжить;
            КонецЕсли;
            ДатыНачалаКомпенсаций.Вставить(СтрокаДанных.Сотрудник, СтрокаДанных.ДатаОкончания);
        КонецЦикла;



глупое решение однако...
   егаис
 
5 - 21.11.17 - 14:00
Народ, подскажите, туплю
Возможно ли вызвать экспортную процедуру на сервере в модуле формы объект из вне?
Нужно запустить через обработку во всех документах отпуска.
&НаСервере
Процедура ПерезаполнитьНачисленияСотрудника(Сотрудник = Неопределено, СохранятьИсправления = Истина, ПерезаполнитьНачисления = Истина) Экспорт
   егаис
 
6 - 21.11.17 - 14:34
экспортную процедуру на сервере в модуле форма похоже нельзя вызвать.
Хорошо, тестирую через толстого клиента
#Если ТолстыйКлиентУправляемоеПриложение Тогда

&НаКлиенте
Процедура обработатьотпусканаклиенте()
ОтпускОб = Документы.Отпуск.НайтиПоНомеру("0000-000009", Дата(2017,01,30)).ПолучитьОбъект();
ФормаОб = ОтпускОб.ПолучитьФорму("ФормаДокумента");
ФормаОб.РассчитатьНачисления("");
КонецПроцедуры
#КонецЕсли 

РассчитатьНачисления - экспортная процедура "на клиенте" в модуле формы. При этом ФормаОб возвращает нужную мне форму.
Падает с ошибкой, что метод объекта не обнаружен.
Но если написать
ФормаОб = ОтпускОб.ПолучитьФорму("Документ.Отпуск.Форма.ФормаДокумента");
ФормаОб.РассчитатьНачисления("");

Процедура видится, только возвращается форма нового объекта.
Подскажите плиз
   егаис
 
7 - 21.11.17 - 14:45
все, решил проблему
надо работать через ссылку, а не объект


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует