Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как закрыть ОкноКлиентскогоПриложения?

Как закрыть ОкноКлиентскогоПриложения?
Я
   totparen
 
19.11.17 - 08:02
Подскажите как можно закрыть ОкноКлиентскогоПриложения, это это не форма? Табличный документ.

Закрываю все открытые окна, а табличный документ так не получается закрыть лОкно.Содержимое.Количество() = 0 .
    лОкна = ПолучитьОкна();
    
    лФормыКЗакрытию = Новый Массив;
    
    Для каждого лОкно Из лОкна Цикл
        
        Если лОкно.Содержимое.Количество() = 0 Тогда
            Продолжить;
        КонецЕсли; 
        
        пФорма = лОкно.Содержимое[0];
        лФормыКЗакрытию.Добавить(пФорма);

    КонецЦикла; 
    
    Для каждого лФорма Из лФормыКЗакрытию Цикл
        лФорма.Закрыть();
    КонецЦикла;
 
 
   totparen
 
1 - 19.11.17 - 08:03
Хм.. Возможно ли вообще получить открытый ТабличныйДокумент и проанализировать его?
   МимохожийОднако
 
2 - 19.11.17 - 08:37
Объясни этот фрагмент:
Если лОкно.Содержимое.Количество() = 0 Тогда
            Продолжить;
        КонецЕсли;
   totparen
 
3 - 19.11.17 - 08:40
(2)

У открытого табличного документа, нет содержимого. И получить форму к закрытию я не могу.
   МимохожийОднако
 
4 - 19.11.17 - 08:44
Может быть, средствами операционной системы отловить это окно?
   totparen
 
5 - 19.11.17 - 08:52
Ууу.. )) Это уж лишка. Мне ещё и содержимое этого табличного документа нужно получить.
   Cyberhawk
 
6 - 19.11.17 - 09:53
Оповестить + ОбработкаОповещения
   SleepyHead
 
7 - 19.11.17 - 11:44
Такое чувство, что для каминовской конфы что-то пишешь, автор
   H A D G E H O G s
 
8 - 19.11.17 - 11:55
Никак

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует