Вход | Регистрация


1С:Предприятие ::

Метки: 

Можно ли настроить отражение проводок сразу при проведении?

Я
   Kissundra_5
 
15.11.17 - 11:54
Добрый день. Подскажите, можно ли в комплексной автоматизации 2.4 настроить отображение проводок сразу при проведении?
 
 
   spiller26
 
1 - 15.11.17 - 12:10
(0) 2 варианта, 
1. Дорабатывать проведение в Общем модуле (не помню какой)
2. Ставить 30 секунд
   Kissundra_5
 
2 - 15.11.17 - 12:11
(1) понятно. Печально. Спасибо за ответ. А то я думала,что может быть не знаю чего...
   Cyberhawk
 
3 - 15.11.17 - 12:22
1С считает, что проводки оперативно никому не нужны. А вам зачем понадобились?
   spiller26
 
4 - 15.11.17 - 12:25
(3) Вот тут можно модифицировать.
//
ОбщийМодуль.МодификацияКонфигурацииПереопределяемый
Процедура ПослеЗаписиНаСервере

Вставить в процедуру следующее...

    //Автоматическое отражение в регламентированном учете при проведении документа

    //автоматическое отражение в Регл. учете

    Если ПараметрыЗаписи.Свойство("РежимЗаписи") Тогда
        Если ПараметрыЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение 
            И Метаданные.Обработки.ОтражениеДокументовВРеглУчете.Команды.ПроводкиРеглУчета.ТипПараметраКоманды.СодержитТип(ТипЗнч(ТекущийОбъект.Ссылка))
        Тогда
            //если документ может быть отражен в РУ нужно еще проверить, что по нему есть запись в регистре в статусе "К отражению"

            мЗаписи = РегистрыСведений.ОтражениеДокументовВРеглУчете.СоздатьНаборЗаписей();
            мЗаписи.Отбор.Регистратор.Установить(ТекущийОбъект.Ссылка);
            мЗаписи.Прочитать();
            Для каждого мЗапись Из мЗаписи Цикл
                //есть запись, проверим статус

                Если мЗапись.Статус = Перечисления.СтатусыОтраженияДокументовВРеглУчете.КОтражениюВРеглУчете Тогда
                    СтруктураРеквизиты = Новый Структура("Ссылка, Дата, Организация", ТекущийОбъект.Ссылка, ТекущийОбъект.Дата, Неопределено);
                    РеглУчетПроведениеСервер.ОтразитьДокумент(СтруктураРеквизиты, Истина);
                КонецЕсли;
                Прервать;
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;
   Kissundra_5
 
5 - 15.11.17 - 12:40
(4) спасибо
   Kissundra_5
 
6 - 15.11.17 - 12:41
(3) А наши бухгалтера хотят проводки сразу
   Cyberhawk
 
7 - 15.11.17 - 12:43
(6) С таким подходом к ответам на вопросы далеко не уедете
   probably
 
8 - 15.11.17 - 13:03
(6) видимо, они с семерки перешли, там же, вроде, это было штатно?..
   КнОпка
 
9 - 15.11.17 - 13:04
(6) там же кнопка есть в самом документе - отразить проводки
Пусть туда и нажимают
   vvspb
 
10 - 15.11.17 - 15:34
(3) кем считается? любому буху удобно когда проводки видно сразу во всех бух. отчетах
 
 Рекламное место пустует
   Aleksey
 
11 - 15.11.17 - 15:38
(3) 1С считает что и себестоимость никому не нужна. Нет конечно для продаж с коробок с 1С она может не нужна, ну или тем у кого чисто услуги. А вот для остальных ...
   Cyberhawk
 
12 - 15.11.17 - 15:39
(11) Какие проблемы с с/с? :)
   Fragster
 
13 - 15.11.17 - 15:53
переходите на БП, там это реализовано
   HeKrendel
 
14 - 15.11.17 - 16:02
(12) Тоже вопрос такой же ;-)
   maximkasuper
 
15 - 15.11.17 - 16:35
(0) Добрый день. Помимо расчета регламентным заданием, есть и другой способ, можно  установить галочку "Отражать в учете при открытии" в форме "Проводки регламентированного учета". Соответственно, программа будет формировать автоматически проводки, при открытии формы.
   breezee
 
16 - 15.11.17 - 16:38
Даже не знал, что в какой-то конфе это реализовали. Отличный способ ухода от модальности. Может, везде так будет? А как там коллизии решаются, когда, допустим не хватило остатков для проведения?
   maximkasuper
 
17 - 15.11.17 - 16:46
(16) Проведение документа в режиме "онлайн" по оперативным регистрам никуда не делось.
   Fragster
 
18 - 15.11.17 - 16:46
(16) там по основным регистрам накопления обычное проведение
   breezee
 
19 - 15.11.17 - 16:47
(17) (18) Вы меня расстроили(
   Kissundra_5
 
20 - 15.11.17 - 17:01
(15) да, точно. Это оно и есть. Спасибо!
   Aleksey
 
21 - 15.11.17 - 17:37
(12) Теже что и с проводками. Т.е. их отсутсвие
   Cyberhawk
 
22 - 15.11.17 - 17:41
(21) "их отсутсвие" // Кого отсутствие?
   Aleksey
 
23 - 15.11.17 - 18:45
(22) С/с при проведении
   Cyberhawk
 
24 - 15.11.17 - 22:50
(23) Ну вот в ЕРП посчитали, что типа "скользящая" с/с после каждого проведения накладно считать и это типа муть



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует