Вход | Регистрация


Где в ут11 настраивается доступ к внешним печатным формам?

Где в ут11 настраивается доступ к внешним печатным формам?
Я
   33554432
 
14.11.17 - 13:02
Где в ут11 настраивается доступ к внешним печатным формам? Какие роли за это отвечают?
 
 
   DrShad
 
1 - 14.11.17 - 13:04
там же где они и регистрирцются
   ildary
 
2 - 14.11.17 - 13:10
(0) Роль "Использование дополнительных отчетов и обработок УТ"
   ildary
 
3 - 14.11.17 - 13:11
Если речь идет о том, что в этот отчет пускаем, а в этот не пускаем - то насколько я понял - такого нет и приходится изгаляться через
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
        
    Если Не РольДоступна( "ПолныеПрава" ) Тогда
        СтандартнаяОбработка = Ложь;
    КонецЕсли;

КонецПроцедуры

либо если есть форма, в ней:

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        
        Если Не РольДоступна( "ПолныеПрава" ) Тогда
                Отказ = Истина;
        КонецЕсли;
        
КонецПроцедуры

Но если я неправ - буду рад послушать правильную схему.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует