Вход | Регистрация

1С:Предприятие ::

Метки: 

Перетаскивание из проводника в 1с

Я
   Harun_dev
 
14.11.17 - 03:12
Ребята СРОЧНО помогите,, нужно сделать обработку прикрепления фото к физ лицам. т.е в таблице значений две колонки - список физ.лиц (из справочника физ.лица) и вторая колонка фотография, нужно реализовать путем перетаскивания файла в нужную строку с физ лицом, и чтобы фото сохранялось в базу данных...

Естественно колонку с физ.лицом я заполняю, а вот как реализовать перетаскивание из проводника в 1С?
 
 
   Harun_dev
 
1 - 14.11.17 - 03:13
Знаю про события проверка перетаскивания и перетаскивание, но мне нужен конкретный пример
   H A D G E H O G s
 
2 - 14.11.17 - 03:23
Час – разобраться в себе, пока еще тихо.
Собачья вахта, холодно, скоро рассвет.
В детстве в лесу рассвет пах земляникой,
Теперь пахнет водкой, и разницы в принципе нет.

Час будто ночь, одиночество старит год за три,
Сколько бы битв не кипело в твоей голове,
Здесь каждый сам за себя, только выживет вряд ли –
Дай мне надежду, будь на моей стороне.

© Александра Сергеевна
   H A D G E H O G s
 
3 - 14.11.17 - 03:25
Я знаю, скоро утро взорвется рассветом.
И это будет последний мирный рассвет.
Здравствуй, дружок, ты хотел быть поэтом?
Прошу к амбразуре – теперь ты поэт.

© Александра Сергеевна
   Lexusss
 
4 - 14.11.17 - 04:11
Пример есть а 1с документооборот
   Сергиус
 
5 - 14.11.17 - 04:33
(0)События у таблицы Начало, Проверка, Окончание перетаскивания.
   Harun_dev
 
6 - 14.11.17 - 09:26
(4) где этот пример можно просмотреть, скинь пожалуйста
   Flover
 
7 - 14.11.17 - 09:35
(0)
Копируются пути к файлам, адаптируй под себя

&НаКлиенте
Процедура ФайлыПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Поле)
    СтандартнаяОбработка = ложь;
    Если Вопрос("Добавить файл?",РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
         возврат;
    КонецЕсли;
    
    ФайлыНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, истина);
    
КонецПроцедуры

&НаКлиенте
Процедура ФайлыНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, Выполнение)
    СтандартнаяОбработка = ложь;
    НовыйФайл = Новый Файл(ПараметрыПеретаскивания.Значение.ПолноеИмя);
    
        ИмяФайла = ПараметрыПеретаскивания.Значение.ПолноеИмя;
        
        ТекущийФайл = Новый Файл(ИмяФайла);
        
        КлючУникальности = Новый УникальныйИдентификатор();
        КлючУникальности = Строка(КлючУникальности);
        НовоеИмяФайла = КлючУникальности+ТекущийФайл.Расширение;
        Каталог = ПутьКаталога();
        
        КаталогНаДиске = Новый Файл(Каталог);
        Если не КаталогНаДиске.Существует() Тогда
            СоздатьКаталог(Каталог);               
        КонецЕсли;

        ФайлИсточник = ИмяФайла;
        ФайлПриемник = Каталог + НовоеИмяФайла;
        
        Попытка
            КопироватьФайл(ФайлИсточник, ФайлПриемник);
            НовСтрока = Объект.Файлы.Добавить();
            НовСтрока.ИмяФайла = ТекущийФайл.Имя; 
            НовСтрока.Путь = ФайлПриемник;
            НовСтрока.Пользователь = ТекущийПользователь();
            НовСтрока.Дата = ТекущаяДата();
            Сообщить("Копирование прошло успешно!");
        Исключение
            Предупреждение("Ошибка копирования файла!", 5);
            Отказ = Истина;
        КонецПопытки;
КонецПроцедуры
   Harun_dev
 
8 - 14.11.17 - 10:00
(7) Работаю с БП 3.0
выдает ошибки

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(63,13)}: Процедура или функция с указанным именем не определена (ПутьКаталога)
        Каталог = <<?>>ПутьКаталога(); (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(78,38)}: Процедура или функция с указанным именем не определена (ТекущийПользователь)
            НовСтрока.Пользователь = <<?>>ТекущийПользователь(); (Проверка: Тонкий клиент)
   h-sp
 
9 - 14.11.17 - 10:04
(8) ну это элиментарщина уже сам найдешь, где там у тебя путь к каталогу и текущий пользователь.
   Harun_dev
 
10 - 14.11.17 - 10:39
(7)(9) что такое ПутьКаталога()?
это метод или функция что это?
 
 Рекламное место пустует
   LeoKeyn
 
11 - 14.11.17 - 10:45
(10) ТекущийФайл.Путь или расположение попробуй, должно быть в синтакспомошнике
   LeoKeyn
 
12 - 14.11.17 - 10:46
(10) Файл (File)
Путь (Path)
Использование:

Только чтение.
Описание:

Тип: Строка.
Содержит путь к файлу, с которым связан объект.
Пример: если Файл.ПолноеИмя = "c:\temp\test.txt", то Файл.Путь = "c:\temp\".

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
   Harun_dev
 
13 - 14.11.17 - 10:54
(12) Но тут ведь путь к отдельно взятому файлу,, а мне нужно открыть проводник и оттуда перетащить нужный мне файл в нужную строку
   LeoKeyn
 
14 - 14.11.17 - 10:59
(13) ПутьФайла = ПараметрыПеретаскивания.Значение.путь;
Я бы так попробовал


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует