Вход | Регистрация


функция НайтиФайлы() не срабатывает

функция НайтиФайлы() не срабатывает
Я
   _barracuda_
 
13.11.17 - 20:33
Добрый день.подключение происходит отлично но как доходит до поиска файла то всегда возвращается ноль.хотя фал там есть 100%
Функция УстановитьСоединение()
    
    АдресСайта "*********************";
    ///Порт = "21";

    Логин = "*********************";
    Пароль = "*********************";
    ИмяКаталога = "dentproduct.com/www/uploads";
    
    Попытка
        Соединение = Новый FTPСоединение(АдресСайта, , Логин, Пароль);
    Исключение
        Соединение = Неопределено;
        Сообщить("Не смог установить соединение с FTP-сервером");
    КонецПопытки;
    
    Возврат Соединение;
КонецФункции

Функция ПолучимФайл()
    
    Если Соединение.НайтиФайлы("export.csv").Количество() = 0 тогда
        Возврат 0;
    КонецЕсли;
    
    
    Соединение.Получить("export.csv","D:\export.csv" );
КонецФункции
 
 
   _barracuda_
 
1 - 13.11.17 - 20:52
дико извиняюсь за отсутствующую строку
        Соединение.УстановитьТекущийКаталог(ИмяКаталога);
   NorthWind
 
2 - 13.11.17 - 21:32
Обычный FTP-клиент показывает под данным пользователем эту папку и наличие файла в ней? Если FTP-сервер юниксовый, то заглавные/строчные буквы в имени соответствуют маске?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует