Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Какое событие возникает при поиске в табличной части

УФ. Какое событие возникает при поиске в табличной части
Я
   ixijixi
 
13.11.17 - 10:23
Коллеги, подскажите, сам не смог найти.

Есть ли событие, отвечающее за поиск и отмену поиска в табличной части? Нужно для отображения актуальных итогов по числовым колонкам.
 
 
   Mort
 
1 - 13.11.17 - 10:24
Лучше забить. Честно.
   oslokot
 
2 - 13.11.17 - 10:31
нет такого события
   ixijixi
 
3 - 13.11.17 - 10:47
Что, всё так печально?
   oslokot
 
4 - 13.11.17 - 10:54
   ixijixi
 
5 - 13.11.17 - 11:15
(4) Не в тему. Табличная часть != Динамический список
   oslokot
 
6 - 13.11.17 - 11:19
(5) так у тебя таблица значений на форме или табличная часть документа?
   ixijixi
 
7 - 13.11.17 - 11:25
(6) табличная часть
   oslokot
 
8 - 13.11.17 - 11:41
Тогда делать свой отбор с кнопками
   oslokot
 
9 - 13.11.17 - 11:44
Еще можно попробовать событие ПриАктивизацииСтроки(), оно должно сработать после поиска по Ctrl+F
   ixijixi
 
10 - 13.11.17 - 16:52
(8) Отбор можно, но не перехватит, если юзер сделает Ctrl+F в уже отобранном списке
(9) Не сработает, если активная строка не изменилась
 
 Рекламное место пустует
   mistеr
 
11 - 13.11.17 - 17:10
(0) ЯННП. Что такое "отображение актуальных итогов по числовым колонкам"? И причем здесь поиск?
   nordbox
 
12 - 13.11.17 - 17:20
(0)Может поможет
https://its.1c.ru/db/metod8dev#content:2207:hdoc
https://forum.infostart.ru/forum9/topic41782/

на самом деле не совсем понятно что ты хочешь
   DexterMorgan
 
13 - 13.11.17 - 17:20
(10) "Не сработает, если активная строка не изменилась" 

Ты проверь, ПриАктвиацииСтроки на каждую фигню отрабатывает
   ixijixi
 
14 - 14.11.17 - 09:39
(11) Что тут непонятного. Поищи в ТЧ документа на УФ, и увидишь, что итоги в подвале не меняются, сколько бы строк не отображалось в ТЧ.
   ixijixi
 
15 - 14.11.17 - 09:41
(12) Вообще не туда.
   Fedor-1971
 
16 - 14.11.17 - 10:30
(0) т.е. другими словами ты хочешь получить доступ к пользовательским отборам на УФ. Для 8.2 никак не получишь, для 8.3 можно достучаться через компоновщик данных

(10) таки проверь, ПриАктивацииСтроки - отбор передёргивает текущую строку, даже если она осталась той-же

(14) выкрутиться можно примерно так: делаем свою кнопку, назначаем ей сочетание клавиш Ctrl+F - в обработчике получаем данные для отбора, устанавливаем оный и пересчитываем итоги, соответственно делаем и кнопку отмены отбора (хочешь простой сброс, хочешь хитрое снятие отборов)
   mistеr
 
17 - 14.11.17 - 12:27
(14) Используйте отборы вместо поиска
   ixijixi
 
18 - 15.11.17 - 09:22
(17) Я-то могу использовать хоть отборы, хоть Git, хоть черта лысого. Но если юзер сделает Ctrl+F, то мне ничего не поможет, если я не перехвачу это событие
   volfy
 
19 - 15.11.17 - 09:27
(18) Отборы Git?
   volfy
 
20 - 15.11.17 - 10:00
А пардон, не понял.. Думал это как то связано :D (18)
   ixijixi
 
21 - 17.11.17 - 09:54
апну
   FIXXXL
 
22 - 17.11.17 - 10:29
(21)
http://v8.1c.ru/o7/201404list/index.htm
можно привязать на активацию строки
   ixijixi
 
23 - 08.12.17 - 14:42
(22) Да не то! У меня табличная часть, а не динамический список!
   DexterMorgan
 
24 - 08.12.17 - 16:01
(23) да забей
   Cyberhawk
 
25 - 08.12.17 - 16:02
Почти месяц прошел, однако ))
   ixijixi
 
26 - 08.12.17 - 17:05
(25) русские не сдаются!
   Cyberhawk
 
27 - 08.12.17 - 17:10
(26) Так ты скорее занял позицию китайца, который ждет, что проблема, предоставленная сама себе, сама собой и разрешится ))
   FIXXXL
 
28 - 11.12.17 - 11:49
(23) ну, как вариант, можешь уйти НаСервер и по старинке через ПостроительОтчета
сам не пробовал, поэтому "но это неточно" :)
   FIXXXL
 
29 - 11.12.17 - 11:54
   Вафель
 
30 - 11.12.17 - 11:55
(29) для поиска (не отбора) нельзя програмно получить значение. поэтому никакого списка не построишь
   FIXXXL
 
31 - 12.12.17 - 09:47
(30) ну а если программно нажать CTRL+A и прочитать выделенные строки?
   Cyberhawk
 
32 - 12.12.17 - 10:54
(31) Так только в клиенте под Виндой получится
   FIXXXL
 
33 - 12.12.17 - 11:19
(32) ну а все-таки ТаблицаФормы в качестве ИсточникаДанных скушает Построитель? :)
 
 
   chelentano
 
34 - 12.12.17 - 11:46
Схема = Элементы.ТаблицаФормы.ПолучитьИсполняемуюСхемуКомпоновкиДанных();
Настройки = Элементы.ТаблицаФормы.ПолучитьИсполняемыеНастройкиКомпоновкиДанных();
    
КомпоновщикНастроек = Новый КомпоновщикМакетаКомпоновкиДанных();
ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(КомпоновщикНастроек.Выполнить(Схема,Настройки,,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений")));
    
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
Результат = ПроцессорВывода.Вывести(ПроцессорКомпоновки);
   FIXXXL
 
35 - 12.12.17 - 16:33
(34) (23) (5)
   1c_July
 
36 - 12.12.17 - 17:02
тоже бодалась с отловом ctrl+F, тоже не динамический список, у меня была таблица записей регистра на форме.
получилось только подключив обработчик ожидания при открытии формы и проверять через ПроверитьСтроку все ли строки есть на форме.

&НаКлиенте
Функция УстановленПользовательскийОтбор()
    
    для каждого текЗапись из НоменклатураВЯчейке_набор Цикл
        Если НЕ Элементы.НоменклатураВЯчейке.ПроверитьСтроку(текЗапись.ПолучитьИдентификатор()) Тогда
            Возврат Истина;            
        КонецЕсли;    
    КонецЦикла;    
    
    Возврат ложь;
    
КонецФункции
   ixijixi
 
37 - 20.12.17 - 08:46
(36) Жестко... Не слишком тормозило?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует