Вход | Регистрация

1С:Предприятие ::

Метки: 

Получение выделенных строк

Я
   AlexeyID
 
12.11.17 - 20:45
Добрый день!

Мне нужно создать новый документ на основании выделенных пользователем строк в динамическом списке. С помощью гугла написал вот это:
[1с]

&НаКлиенте
Процедура Комплектовать(Команда)
    // Вставить содержимое обработчика.
    
    ДанныеСтрок = Новый Соответствие;
    МассивСтрок = Элементы.Заявки.ВыделенныеСтроки;
    Для Каждого СтрокаТЧ Из МассивСтрок Цикл
        ДанныеСтрок.Вставить(СтрокаТЧ, Элементы.Заявки.ДанныеСтроки(СтрокаТЧ));
    КонецЦикла;
    
    Если ДанныеСтрок.Количество() > 0 Тогда
        КомплектоватьНаСервере(ДанныеСтрок);
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
Процедура КомплектоватьНаСервере(ДанныеСтрок)
    
    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Заявка");
    ТЗ.Колонки.Добавить("НоменклатураМастера");
    ТЗ.Колонки.Добавить("Смета");
    ТЗ.Колонки.Добавить("ЕдИзмМастера");
    ТЗ.Колонки.Добавить("КоличествоМастера");
    
    Для Каждого ДС Из ДанныеСтрок Цикл
        СтрокаТЗ = ТЗ.Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТЗ, ДС.Значение);  
    КонецЦикла;
    
КонецПроцедуры

[/1c]

Неужели нет более лаконичного способа?
 
  Рекламное место пустует
   Филиал-msk
 
1 - 12.11.17 - 20:49
Нет.
Ты же поделишься с нами, когда напишешь сам?
   zladenuw
 
2 - 12.11.17 - 20:49
Так решение. Сделай лучше :)
   AlexeyID
 
3 - 12.11.17 - 20:49
Да я и так туплю. Есть или нет?
   Филиал-msk
 
4 - 12.11.17 - 20:50
(3) Есть. Стремись
   AlexeyID
 
5 - 12.11.17 - 20:51
Спасибо за советы. Видимо сойдет
   zladenuw
 
6 - 12.11.17 - 20:53
(5) http://v8.1c.ru/o7/201404list/index.htm
Может вот это на что то натолкнет.
А так работает, делает что надо. работает быстро.
Зачем себя мучат :)
   AlexeyID
 
7 - 12.11.17 - 20:55
Давно не шкодил. Вспоминаю...
Спасибо


Список тем форума
Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует