Вход | Регистрация

1С:Предприятие ::

Метки: 

Убрать пустые строки в ФормеСписка справочника

Я
   illiona
 
10.11.17 - 08:14
Добрый день. Мне нужно убрать пустые строки в колонке Остаток, если там остаток есть - то убирать не нужно, если ноль то скрыть
http://www.imageup.ru/img183/2910040/1.jpg

Так отображается остаток
Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    .......
    
    Для Каждого Строка ИЗ ОформленияСтрок Цикл
        
            СтрТЗ = тзВыгрузка.Найти(Строка.ДанныеСтроки.Ссылка, "Партия");
            Если СтрТЗ <> Неопределено Тогда
                Строка.Ячейки.Остаток.УстановитьТекст(СтрТЗ.КоличествоОстаток);
            КонецЕсли;    
       
    КонецЦикла;    
    
КонецПроцедуры
 
 
   1dvd
 
1 - 10.11.17 - 08:16
Динамический список спасёт отца (мать?) русской демократии


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует