Вход | Регистрация


Получение данных из регистра остатков, объектная модель

Получение данных из регистра остатков, объектная модель
Я
   maptbln
 
08.11.17 - 10:45
День добрый,
Есть документ "Продажа Товаров"
В его форму добавил поле Ост , которое должно показывать общие остатки на складе на момент проведения документа
добавил след код

&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)
    Стр = Элементы.Товары.ТекущиеДанные;
    Если Стр <> Неопределено Тогда
      Ост = ОпределениеОстаткаТовара(Стр.Номенклатура,Объект.Склад,Объект.Дата,Объект.Ссылка);    
    КонецЕсли;                                                                                    
    КонецПроцедуры

&НаСервереБезКонтекста
Функция ОпределениеОстаткаТовара(ТекТовар,Склад,Дата,Ссылка)
            ОстаткиТов=РегистрыНакопления.ОстаткиНоменклатуры;
            
            ФильтрТов=Новый Структура;
            ФильтрТов.Вставить("Номенклатура",ТекТовар);
            ФильтрТов.Вставить("Склад",Склад);
            
Если ЗначениеЗаполнено(Ссылка) Тогда
    ВременнойМомент=Новый МоментВремени(Дата,Ссылка)
иначе
    ВременнойМомент=Неопределено;
КонецЕсли;             

ТаблицаОст=ОстаткиТов.Остатки(ВременнойМомент,ФильтрТов,"Номенклатура","Количество");

  Возврат ТаблицаОст.Итог("Количество");

вроде по-уму,но не работает
подскажите,в чем дело
 
 
   Lexey_
 
1 - 08.11.17 - 10:53
(0) отладчик знает
   Ненавижу 1С
 
2 - 08.11.17 - 10:54
ВременнойМомент=Неопределено;
...
ТаблицаОст=ОстаткиТов.Остатки(ВременнойМомент...


это как?
   maptbln
 
3 - 08.11.17 - 10:58
если документ уже записывался в базу,значит из его даты и ссылки и собираю Момент времени,если документ новый,то определяем актуальные остатки
   youalex
 
4 - 08.11.17 - 11:11
Сделай запросом, пожалей людей после себя.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует