Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как в форме отчета добавить параметр квартал

Как в форме отчета  добавить параметр квартал
Я
   1сЮлия
 
07.11.17 - 17:20
Добрый вечер! Я прописала,ничего не показывает в периоде
Процедура ПредставлениеПериодаМесяцКварталРегулирование(Элемент, Направление, СтандартнаяОбработка)
    Если Направление = 1 тогда
        мПериод = ДобавитьМесяц(мПериод,3);
    иначе
        мПериод = ДобавитьМесяц(мПериод,-3);
    КонецЕсли;
    ЭлементыФормы.ПредставлениеПериодаКвартал.Значение = Формат(мПериод,"ДФ=" "к");
КонецПроцедуры


Процедура ПредставлениеПериодаКварталОткрытие(Элемент, СтандартнаяОбработка)
      мПериод  = ТекущаяДата();

    Если ЗначениеЗаполнено(глЗначениеПеременной("глТекущийПользователь")) Тогда
        Если НЕ ЗначениеЗаполнено(ПредставлениеПериодаГод) Тогда
            ЭлементыФормы.ПредставлениеПериодаГод.Значение =Формат(мПериод,"ДФ=" "к");
        КонецЕсли;
    КонецЕсли;
    

КонецПроцедуры
 
 
   vicof
 
1 - 07.11.17 - 17:31
Да
   aleks_default
 
2 - 07.11.17 - 17:39
пробел между "ДФ=" и "к" зачем?
   1сЮлия
 
3 - 07.11.17 - 19:16
А как в СКД в параметрах укаазать квартал?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует