Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Поле объекта не обнаружено (товар)

Поле объекта не обнаружено (товар)
Я
   alexlencer
 
06.11.17 - 14:25
День добрый, друзья столкнулся с проблемой. Суть в чем. Нужно при изменение наименование (это другой справочник со своими элементами. прикручен к таблице документа поступление на склад) нужно вытащить значение товар в реквизит таблицы документа.
Скрины  
https://hkar.ru/Rx4o
https://hkar.ru/Rx4p
Процедура ТоварНаименованиеТовараПриИзменении(Элемент)
    СтрТабЧасти=Элементы.Товар.ТекущиеДанные;
    СтрТабЧасти.товар=СтрТабЧасти.НаименованиеТовара.товар; 
КонецПроцедуры
 Ошибка 
{Документ.ПоступлениеНаСклад.Форма.ФормаДокумента.Форма(5)}: Поле объекта не обнаружено (товар)
    СтрТабЧасти.товар=СтрТабЧасти.НаименованиеТовара.товар;
 
 
   МимохожийОднако
 
1 - 06.11.17 - 14:27
(0) Встань отладчиком на строчку с ошибкой и убедись, что там действительно нет реквизита Товар.
   Ranger_83
 
2 - 06.11.17 - 14:28
Откуда у строки реквизиты возьмутся?
   1dvd
 
3 - 06.11.17 - 14:33
Радуют реквизиты НаименованиеЧегоТоТам ссылочного типа
   alexlencer
 
4 - 06.11.17 - 14:36
У него тоже самое там есть ответ, не могу въехать
v8: Помогите новичку!
   alexlencer
 
5 - 06.11.17 - 14:38
По аналогии
   Jofa
 
6 - 06.11.17 - 14:53
Что непонятного во фразе "Поле объекта не обнаружено" ?
   AlvlSpb
 
7 - 06.11.17 - 15:01
Процедура ТоварНаименованиеТовараПриИзменении(Элемент)
  СтрТабЧасти=Элементы.Товар.ТекущиеДанные;
  СтрТабЧасти.товар=Строка(СтрТабЧасти.НаименованиеТовара); 
КонецПроцедуры
   alexlencer
 
8 - 06.11.17 - 15:05
AlvlSpb
Не помогло(
{Документ.ПоступлениеНаСклад.Форма.ФормаДокумента.Форма(6)}: Значение не является значением объектного типа (НаименованиеТовара)
    СтрТабЧасти=Строка(СтрТабЧасти.НаименованиеТовара);
   alexlencer
 
9 - 06.11.17 - 15:09
AlvlSpb
Заработало, это я лоханулся;) но он достает значение из наименованиеТовара, это не то ((
   alexlencer
 
10 - 06.11.17 - 15:14
Вот моя )_)_ конфигурация, Вообще реально так сделать, как задумывается? https://yadi.sk/d/KsTwu0QO3PSwPF
 
 Рекламное место пустует
   AlvlSpb
 
11 - 06.11.17 - 16:13
(10) На клиенте, где доступны ТекущиеДанные недоступны ссылочные типы. Надо передать на сервер и получить нужное значение

&НаКлиенте
Процедура ТоварНаименованиеТовараПриИзменении(Элемент)
  СтрТабЧасти=Элементы.Товар.ТекущиеДанные;
 СтрТабЧасти.товар=ПолучитьТовар(СтрТабЧасти.НаименованиеТовара); 
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьТовар(НаименованиеТовара)
Возврат НаименованиеТовра.Товар;
КонецФункции
   alexlencer
 
12 - 06.11.17 - 16:25
AlvlSpb Огромное человеческое спасибо, человек:)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует