Вход | Регистрация

1С:Предприятие ::

Метки: 

Поле объекта недоступно для записи (ФизическиеЛица)

Я
   егаис
 
06.11.17 - 13:43
При формировании ОСВ по 70 счету или любых макетов, где выводятся сотрудники
{ОбщийМодуль.КадровыйУчет.Модуль(491)}: Поле объекта недоступно для записи (ФизическиеЛица)
        ФизическиеЛица = СписокФизическихЛиц;
 
 
   егаис
 
1 - 06.11.17 - 13:44
Функция ПериодыИзмененияФИОФизическихЛиц(СписокФизическихЛиц) Экспорт
   егаис
 
2 - 06.11.17 - 13:51
вылезло на 54.13, смотрю оперативно вышел 54.15
попробую обновиться
   егаис
 
3 - 06.11.17 - 21:36
дело не в обновлении БП.
БП скрещен с УАТ. Учитывая, что крайнее обновление УАТа (не поспевают они видимо) было в сентябре, приходится с напильником накатывать обновления БП (БСП, общие формы, модули).
Ошибка лезет отсюда
Функция ДатыИзмененияОтветственныхЛицОрганизаций(Организация) Экспорт

    УстановитьПривилегированныйРежим(Истина);

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Организация", Организация);
    
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ОтветственныеЛицаОрганизаций.Период КАК Период,
    |    ОтветственныеЛицаОрганизаций.ФизическоеЛицо КАК ФизическоеЛицо
    |ИЗ
    |    РегистрСведений.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций
    |ГДЕ
    |    ОтветственныеЛицаОрганизаций.СтруктурнаяЕдиница = &Организация
    |
    |ОБЪЕДИНИТЬ
    |
    |ВЫБРАТЬ
    |    ОтветственныеЛицаОрганизаций.Период,
    |    ОтветственныеЛицаОрганизаций.ФизическоеЛицо
    |ИЗ
    |    РегистрСведений.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ПодразделенияОрганизаций КАК ПодразделенияОрганизаций
    |        ПО ОтветственныеЛицаОрганизаций.СтруктурнаяЕдиница = ПодразделенияОрганизаций.Ссылка
    |            И (ПодразделенияОрганизаций.Владелец = &Организация)";
    
    ТаблицаОтветственныеЛица = Запрос.Выполнить().Выгрузить();
    ТаблицаОтветственныеЛица.Индексы.Добавить("ФизическоеЛицо");
    
    МассивДат            = ТаблицаОтветственныеЛица.ВыгрузитьКолонку("Период");
    МассивФизическиеЛица = ТаблицаОтветственныеЛица.ВыгрузитьКолонку("ФизическоеЛицо");
    
    МассивДат            = ОбщегоНазначенияБПВызовСервера.УдалитьПовторяющиесяЭлементыМассива(МассивДат);
    МассивФизическиеЛица = ОбщегоНазначенияБПВызовСервера.УдалитьПовторяющиесяЭлементыМассива(МассивФизическиеЛица);
    
    ТаблицаФизическиеЛица = КадровыйУчет.ПериодыИзмененияФИОФизическихЛиц(МассивФизическиеЛица);
    
    Для каждого СтрокаТаблицыФизическиеЛица Из ТаблицаФизическиеЛица Цикл
        
        ДатыНазначенияОтвественныхЛиц = ТаблицаОтветственныеЛица.НайтиСтроки(Новый Структура("ФизическоеЛицо", СтрокаТаблицыФизическиеЛица.ФизическоеЛицо));
        Для каждого ДатаНазначенияОтветственногоЛица Из ДатыНазначенияОтвественныхЛиц Цикл
            // Добавляем дату изменения ФИО ответственного лица, только если оно произошло после назначения в должность

            Если ДатаНазначенияОтветственногоЛица.Период < СтрокаТаблицыФизическиеЛица.Период 
                    И МассивДат.Найти(СтрокаТаблицыФизическиеЛица.Период) = Неопределено Тогда
            
                МассивДат.Добавить(СтрокаТаблицыФизическиеЛица.Период);
                Прервать;
            
            КонецЕсли; 
        
        КонецЦикла; 
    
    КонецЦикла;

    Возврат МассивДат;

КонецФункции


конкретно 
    ТаблицаФизическиеЛица = КадровыйУчет.ПериодыИзмененияФИОФизическихЛиц(МассивФизическиеЛица);

Ошибка 
ОбщийМодуль.КадровыйУчет.Модуль(491)}: Поле объекта недоступно для записи (ФизическиеЛица) 
        ФизическиеЛица = СписокФизическихЛиц;


Проверил права на регистры в запросе, все ок. Понимаю, что сам где-то криво обновил, кажется проверил все. Из-за чего может быть такая ошибка еще?
   Филиал-msk
 
4 - 06.11.17 - 21:37
Из за присутствия в конфигурации общего модуля с таким именем?
   егаис
 
5 - 06.11.17 - 21:48
браво! Есть общий модуль ФизическиеЛица, апендикс УАТа.
Благодарю!


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует