Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отбор по значениям в форме документа

Отбор по значениям в форме документа
Я
   TylerDurden_
 
06.11.17 - 11:13
Процедура ПодобрПоШКПриИзменении(Элемент)
    Если НЕ ЗначениеЗаполнено(СокрЛП(ЭтаФорма.ПодобрПоШК)) Тогда
        Возврат;
    КонецЕсли;    
    Если Объект.Фирма.Пустая() Тогда
        ПоказатьПредупреждение(,"Сначала выберете ФИРМУ");
        Возврат;
    КонецЕсли;    

    СписШК = Новый СписокЗначений;
        
    НайтиШКНаСервере(СокрЛП(ЭтаФорма.ПодобрПоШК),СписШК);
    ОткрытьФорму (
            "Справочник.Номенклатура.Форма.ФормаВыбораСписок",
            Новый Структура("ОтборПоШк", Новый Структура("СписТоваров", СписШК)),
            ЭтаФорма.Элементы.Товары);    
    ЭтаФорма.ПодобрПоШК = "";
КонецПроцедуры

Есть процедура, нужно провести отбор по значениям, не знаю как, подскажите
 
 
   TylerDurden_
 
1 - 08.11.17 - 10:07
так, что никто не подскажет?
   DrShad
 
2 - 08.11.17 - 10:10
зачем вторую тему создавать? вчера же уже была
   dezss
 
3 - 08.11.17 - 10:37
Где нужно провести отбор по значениям, в форме выбора?
Ну так наложи в ней твой переданный отбор в ПриСозданииНаСервере.
   zladenuw
 
4 - 08.11.17 - 10:38
Если для справочника, доступен быстрый выбор. То кроме открытие формы. Нужно накладывать отбор при вводе данных в поле ввода

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует