Вход | Регистрация

  1  2
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Алгоритм разбития документа

v7: Алгоритм разбития документа
Я
   zenon46
 
31.10.17 - 22:30
Есть 7.7, в ней нужно реализовать следующий алгоритм, итак дано : таблица значений в значениях которой ссылки на документы, надо обработать эти документы так, что все документы сумма которого, больше чем заданное значение, надо разбивать на более мелкие документы, т.е. из одного дока сделать несколько маленьких не превышающий определенную сумму.
 
 
   zenon46
 
101 - 02.11.17 - 09:59
(94) спасибо, уже все сделано
   Ёпрст
 
102 - 02.11.17 - 10:00
(101) дай посмотреть
   tgu82
 
103 - 02.11.17 - 10:14
(102) Вот лучше посоветуй. ДЕлаю свертку потом заново создаю периферийку. мы в периферийки те же РКО и ПКО не переносим, да и выписки банка не для всех перифериек. В результате вроде базы меньше но при этом полно незакрытых регистров получается. В центральной-то базе слава богу осоновные рабочие регистры закрываются
   Ёпрст
 
104 - 02.11.17 - 10:25
(103) Незакрытые регистры в ПБ ?
   Ёпрст
 
105 - 02.11.17 - 10:26
сами пко, потом в ПБ ведёте ?
   tgu82
 
106 - 02.11.17 - 10:32
(105) Да нет. Только по розничным возвратам покупателям ЕНВД магазины делают РКО, и по магазинам где еще и опт нужны выписки приход. Выписки расход вообще не нужны пко делаются на ЦБ - 54 закон же.
   tgu82
 
107 - 02.11.17 - 10:35
(106)+ В двух магазинах вообще только розница. В трех еще и опт
   tgu82
 
108 - 02.11.17 - 10:36
(107)+ То есть то что к ним приходит по банку (что касается конкретного магазина) - они должны видеть выписки-приход чтобы с клиентами оптовыми работать
   uno-group
 
109 - 02.11.17 - 11:02
Функция СоздатьНовДок(Док)
Н=1;
Док.ВыгрузитьТабличнуюЧасть(Тз);
Для К=1 по Тз.Количествострок()Цикл
Тз.Выгрузить(ТЗ2,Н,К);
Если Тз2.Итог(Сумма)>МаксСума Тогда
Тз.Выгрузить(ТЗ2,Н,К-1);
Док2.ЗагрузитьТабличнуюЧасть(Тз2);
Тз.Выгрузить(ТЗ,К,);
Док.ЗагрузитьТабличнуюЧасть(Тз)
Возврат Док;
КонецЕсли;
КонецФункции;
//**********

Пока Док.Итог("Сумма")>МаксСума Цикл
СоздатьНовДок(Док)
КонецЦикла;
   uno-group
 
110 - 02.11.17 - 11:04
В простейшем варианте разобьет все где нет строки превышающей лимит. такие строки я бы еще на этапе формирования документа отлавливал и заставлял узера самостоятельно решать что с ними делать.
 
 Рекламное место пустует
  1  2

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует