Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не работает отбор в быстром доступе скд

Не работает отбор в быстром доступе скд
Я
   dmitriyevm
 
31.10.17 - 18:45
Добрый вечер. Подскажите, может кто сталкивался: написал отчет на скд. добавил отбор в настройку отчета "ссылка.контрагент".В форме отчета при изменении значения в быстром доступе значение отбора не меняется. В форме простой настройки такая же ситуация. при изменении значения в расширенной настройке отчет отрабатывает корректно. Подскажите в какую сторону смотреть.
 
 
   vicof
 
1 - 31.10.17 - 19:01
Купил девятку, опускаю стекло -едет, поднимаю - не едет.
Подскажите, в какую сторону смотреть?
   dmitriyevm
 
2 - 31.10.17 - 19:12
Использую вот такой код, при его комментировании проблема исчезвет
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных;
    Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(Макет,  , ДанныеРасшифровки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    ПроцессорВывода.ЗакончитьВывод();
    Для  I = 1 по ДокументРезультат.ВысотаТаблицы-1  ЦИКЛ
        
        Нач = I;
        НачТекст = ДокументРезультат.Область(Нач,1).Текст;
        Пока НачТекст = ДокументРезультат.Область(I+1,1).Текст И I<=ДокументРезультат.ВысотаТаблицы-1 Цикл
            I = I+1;    
        КонецЦикла;
        Если НЕ Нач = I Тогда
            Обл = ДокументРезультат.Область(Нач,1,I,1);
            Обл5 = ДокументРезультат.Область(Нач,5,I,5);
            Обл13 = ДокументРезультат.Область(Нач,13,I,13);
            Обл14 = ДокументРезультат.Область(Нач,14,I,14);
            Обл.Объединить();
            Обл5.Объединить();
            Обл13.Объединить();
            Обл14.Объединить();
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
   youalex
 
3 - 31.10.17 - 19:13
Смотри в сторону пользовательских настроек (свойство компоновщика настроек)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует