Вход | Регистрация

1С:Предприятие ::

Метки: 

не могу записать хранилище значения

Я
   alexshape
 
31.10.17 - 10:56
Привет Всем. Проблема такая. Почему то не записывается хранилище значения у справочника. Есть реквизиты справочника С типом "Хранилище значения". В процедуре "При записи на сервере" присваиваю этому реквизиту Значение. Но в  момент открытия этого элемента, в этом хранилище пусто

&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    ТекущийОбъект.Шрифт = Новый ХранилищеЗначения(Шрифт);
    ТекущийОбъект.ЦветФона = Новый ХранилищеЗначения(ЦветФона);
    ТекущийОбъект.ЦветТекста = Новый ХранилищеЗначения(ЦветТекста);
    
КонецПроцедуры
 
 
   alkorolev
 
1 - 31.10.17 - 11:02
ПередЗаписьюНаСервере
при записи - слишком поздно модифицировать объект
   alexshape
 
2 - 31.10.17 - 11:04
ПередЗаписьюНаСервере та же проблема.
   Cyberhawk
 
3 - 31.10.17 - 11:05
Какая?
   alexshape
 
4 - 31.10.17 - 11:07
(3) В момент открытия элемента справочника в реквизитах с типеом "Хранилище Значения" пусто, хотя я туда записывал значения
   alkorolev
 
5 - 31.10.17 - 11:08
(2) быть такого не может

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    ТекущийОбъект.Шрифт = Новый ХранилищеЗначения(Шрифт); 
    
КонецПроцедуры

&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
    
    ХЗ = ТекущийОбъект.Шрифт;
    Шрифт = ХЗ.Получить();
    
КонецПроцедуры
   alkorolev
 
6 - 31.10.17 - 11:10
>> момент открытия элемента справочника
как выглядит?
   Cyberhawk
 
7 - 31.10.17 - 11:11
(4) "я туда записывал значения" // В отладчике покажи это значение
   alexshape
 
8 - 31.10.17 - 11:14
(5) Может, сам в шоке.

(6) Использую ПриСозданииНаСервере(), Пробовал также ПриЧтенииНаСервере все равно такая же проблема

(7) Поверь, они там точно есть
   alexshape
 
9 - 31.10.17 - 11:16
(6) Отдельно обращаюсь к этому элементу. проблема в момент записи справочника
   Волшебник
 
Модератор
10 - 31.10.17 - 11:19
"Шрифт" - это что?
Если типы не совпадают, то присваивания не произойдёт.
 
 Рекламное место пустует
   alexshape
 
11 - 31.10.17 - 11:27
(10) Шрифт - это Тип "Шрифт". А какая разница какого типа шрифт. Я же его в хранилище засовываю

ТекущийОбъект.Шрифт  - Это хранилище значения,
Шрифт - Это шрифт.
ТекущийОбъект.Шрифт = Новый ХранилищеЗначения(Шрифт);
   alexshape
 
12 - 31.10.17 - 11:34
У этого справочника, даже обычные реквизиты не записываются. С чем может быть связанно?
   Волшебник
 
Модератор
13 - 31.10.17 - 11:36
(12) ошибка где-то в другом месте
   alexshape
 
14 - 31.10.17 - 11:42
(13) Решил написать На "Индуском" и добавил к справочнику Новый Реквизиты Типа ШрифтЖирный ШрифтНаклонный и т.д. И прикиньте все заработало. Хрен пойми в чем проблема была
   Волшебник
 
Модератор
15 - 31.10.17 - 11:43
(14) Если выяснишь, допиши в этой ветке.
   alexshape
 
16 - 31.10.17 - 11:46
(15) Так я у Вас хотел спросить, из за чего такой баг
   vicof
 
17 - 31.10.17 - 13:14
(16) Кнопку сохранения нажимать чаще надо


Список тем форума
Рекламное место пустует Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует